Author Topic: Power Designs TP343A Shorted Output  (Read 1473 times)

0 Members and 1 Guest are viewing this topic.

Offline vmallet

  • Regular Contributor
  • *
  • Posts: 67
  • Country: us
Power Designs TP343A Shorted Output
« on: January 30, 2020, 11:48:39 pm »
I just got a Power Designs TP343A Triple-output power supply (donated by a generous neighbor, lucky me!) and I started doing my homework to see if I could make it work. Found the PDF manual (the crappy scan that's quite hard to read), started spending way too much time reading the giant thread "POWER DESIGNS PRECISION POWER SUPPLIES"...  :)

918068-0

I took a peek inside to look for obvious bad signs and other than a missing diode (CR402 between COM and Source B DC-) things looked about right..

918064-1

Powered it up and the Source A Fault light instantly lit up with the Source A Ammeter going to 2.5A. With a bit of poking around it appeared Source A DC+ and COM were shorted.

I took out C401 and it seemed within tolerances (not shorted, 289uF for 330uF, 0.2oHm ESR); took out the output CR401 and ah-ha, this guy was shorted. Now Source A DC+ and COM are not shorted anymore (with these two components still out).

I decided to measure outputs with C401 & CR401 out (and now, no more fault light on Source A):
Source B and Source C look pretty good (super quick test shows ~0V at 0V. ~5V at 5V). But Source A is whacky: with the pot all the way counterclockwise, I measure ~16V. As I start turning the pot a bit, it slowly increases then suddenly jumps to 32V measured, and the Source A fault light comes on.

32V on a 0-20V supply looks suspicious! Any idea on what might be going on here?

Regarding CR401 (and its missing sibling CR402), the manual says "SI5A2". What would be a good replacement diode for this guy?

Thanks!





 

Offline vmallet

  • Regular Contributor
  • *
  • Posts: 67
  • Country: us
Re: Power Designs TP343A Shorted Output
« Reply #1 on: January 31, 2020, 01:23:39 am »
Note: I took some measurements as indicated in the "Troubleshooting" section and they all look good so far:

"The first step in trouble shooting any Source is to make sure the B+ regulated voltages measured on capacitors "A" C104, "B" C204, "c" C304 fall within 12.4 VDC and 13.2 VDC and are very stable."

Measured: A C104: 12.98V, B C204: 12.90V, C C304: 12.92V

"If these voltages are present, the voltages across zener diodes "A" VR103, "B" VR203, "c" VR302, should fall between 5.0 and 5.8V"

Measured: A VR103: 5.65V, B VR203: 5.47V, C VR302: 5.36V

"Note: "A" VR102, "B" VR202, "C" VR303, are the main reference voltage of the corresponding Source; their voltages must fall between 6.26V and 6.52VDC."

Measured: A VR102: 6.47V, B VR202: 6.45V, C VR303: 6.46V
 

Offline vmallet

  • Regular Contributor
  • *
  • Posts: 67
  • Country: us
Re: Power Designs TP343A Shorted Output
« Reply #2 on: January 31, 2020, 07:05:43 am »
To check things out, I swapped the quad op-amps between Source A and Source B, and A is still bogus and B is still looking good; looks like the op-amps are good.

I tried to play a bit with the over-voltage settings (they were both all the way clockwise) but the results are so erratic I'll have to spend more time understanding what's going on there...
 

Offline vmallet

  • Regular Contributor
  • *
  • Posts: 67
  • Country: us
Re: Power Designs TP343A Shorted Output
« Reply #3 on: January 31, 2020, 06:35:02 pm »
I measured the voltage across the base-emitter resistor on the driver of each source and source A looks suspicious. This was with the output voltage set to minimum (0) on each source:
Source A: R112 (for Q105): 0.06V
Source B: R212 (for Q205): 0.51V
Source C: R3281 (for Q304): 0.51V

Also measured the voltage across base-emitter resistor for Q104, Q204, Q306:
Source A: R111 (for Q104): 0.07V
Source B: R211 (for Q204): 0.4V (-ish)
Source C: R329 (for Q306): 0.33V

Hmm...
 

Offline vmallet

  • Regular Contributor
  • *
  • Posts: 67
  • Country: us
Re: Power Designs TP343A Shorted Output
« Reply #4 on: February 01, 2020, 01:32:21 am »
Well I pulled Q105 & Q205, both tested similarly with a DMM with no obvious short or open. I swapped them when putting them back and Source A is still whacky and Source B is still good.

The investigation continues!
 

Offline xavier60

  • Super Contributor
  • ***
  • Posts: 1609
  • Country: au
Re: Power Designs TP343A Shorted Output
« Reply #5 on: February 01, 2020, 06:25:39 am »
I would expect a small voltage drop across R*11 for a properly working and unloaded SOURCE. Maybe 20mV.
The output transistor could be damaged causing leakage due to being overheated.
« Last Edit: February 01, 2020, 07:04:08 am by xavier60 »
Hioki AS100D vom, HP 54645A dso, Fluke 87V dmm, AN8008 dmm, Agilent U8002A psu,  FY6600 function gen, New! Brymen BM857S-(With Battery)
 

Offline vmallet

  • Regular Contributor
  • *
  • Posts: 67
  • Country: us
Re: Power Designs TP343A Shorted Output
« Reply #6 on: February 02, 2020, 05:04:31 am »
I would expect a small voltage drop across R*11 for a properly working and unloaded SOURCE. Maybe 20mV.
The output transistor could be damaged causing leakage due to being overheated.

I redid the measurements of those transistors with sources A & B set to min, no load. I get this:
Source A:
  R111 (for Q104): 0.08V
  R110 (for Q103): 0.29V
Source B:
  R211 (for Q204): 0.41V
  R210 (for Q203): 0.34V

I'll have to pull those transistors and test them out out of circuit.

What's interesting is that the giant 10,000uF filtering caps for sources A & B (C112, C113, C212, C213) charge up to about 16V each with the power on, but when I turn the power off one of them discharges slowly: C113 from source A. A little while later C113 is down to pretty much 0V on its own. Not sure if there's some short somewhere or if the cap is bad; I'll have to take it out but it's a bit out of reach.

To be continued!
 

Offline xavier60

  • Super Contributor
  • ***
  • Posts: 1609
  • Country: au
Re: Power Designs TP343A Shorted Output
« Reply #7 on: February 02, 2020, 07:56:03 am »
I would expect a small voltage drop across R*11 for a properly working and unloaded SOURCE. Maybe 20mV.
The output transistor could be damaged causing leakage due to being overheated.

I redid the measurements of those transistors with sources A & B set to min, no load. I get this:
Source A:
  R111 (for Q104): 0.08V
  R110 (for Q103): 0.29V
Source B:
  R211 (for Q204): 0.41V
  R210 (for Q203): 0.34V

I'll have to pull those transistors and test them out out of circuit.

What's interesting is that the giant 10,000uF filtering caps for sources A & B (C112, C113, C212, C213) charge up to about 16V each with the power on, but when I turn the power off one of them discharges slowly: C113 from source A. A little while later C113 is down to pretty much 0V on its own. Not sure if there's some short somewhere or if the cap is bad; I'll have to take it out but it's a bit out of reach.

To be continued!
I was looking at the wrong area of the schematic. The  " R111 (for Q104): 0.08V"  indicates that current is leaking to the output without  Q104 being turned on.
The two 10,000uF caps and the pair of power transistors for each of A and B form an automatic tap changing setup. It's likely normal for there to be uneven discharge.
Hioki AS100D vom, HP 54645A dso, Fluke 87V dmm, AN8008 dmm, Agilent U8002A psu,  FY6600 function gen, New! Brymen BM857S-(With Battery)
 

Offline vmallet

  • Regular Contributor
  • *
  • Posts: 67
  • Country: us
Re: Power Designs TP343A Shorted Output
« Reply #8 on: February 03, 2020, 02:21:11 am »
The two 10,000uF caps and the pair of power transistors for each of A and B form an automatic tap changing setup. It's likely normal for there to be uneven discharge.

I see. The thing I thought was suspicious is that out of the 7 10,000uF caps in the system (2 for A, 2 for B, 3 for C), once they are charged and I turn off the whole power (with no load on the source), they all hold their charge really nicely except for that one C113 that starts discharging as soon as I remove power. I come back a day later, 6 of the caps are still at pretty much at the same voltage but C113 is pretty much empty.
 

Offline vmallet

  • Regular Contributor
  • *
  • Posts: 67
  • Country: us
Re: Power Designs TP343A Shorted Output
« Reply #9 on: February 03, 2020, 02:22:33 am »
I made some small progress today. Pulled out Q103 and Q104 to test them (with a DMM diode test). Q104 looked good but Q103 had some bad tests: E-C is 0.69V and C-E is 0.66V. Doesn't look good to me!

I replaced Q103 with the same transistor I stole from Source C (Q307) thinking that might be it... Sadly no. After the swap, it still puts out 15.7V out on the minimum setting on Source A.

There are differences though. Now B-E voltages read like this:
Source A:
  R111 (for Q104): 0.0V
  R110 (for Q103): 0.24V

The other difference is: before the swap, it would start at 15.7v and if I turned the voltage pot just a bit (half a turn?) it would jump to 32V with the Fault light. Now I can turn the voltage pot about 2.5 turns before it jumps to 32V with Fault light.

The hunt continues...
 

Offline xavier60

  • Super Contributor
  • ***
  • Posts: 1609
  • Country: au
Re: Power Designs TP343A Shorted Output
« Reply #10 on: February 03, 2020, 02:44:21 am »
That indicates Q104 or Q103 is passing uncontrolled current. The design should be capable of proper voltage regulation with Q104 removed, also with Q103 removed. Do not load the output of course.

Extra: Q103 is likely C-B leaky.
« Last Edit: February 03, 2020, 02:47:52 am by xavier60 »
Hioki AS100D vom, HP 54645A dso, Fluke 87V dmm, AN8008 dmm, Agilent U8002A psu,  FY6600 function gen, New! Brymen BM857S-(With Battery)
 

Online vindoline

  • Supporter
  • ****
  • Posts: 300
  • Country: us
Re: Power Designs TP343A Shorted Output
« Reply #11 on: February 03, 2020, 01:02:09 pm »
I've had several Power Designs supplies that have had symptoms similar to yours. In both cases the output over-voltage crowbar circuit was fried. The crowbar circuit works by firing a power SCR to short out the output when the set voltage is exceeded. I would check CR24 (the crowbar SCR) - I believe its a TO-3 size one mounted to the chassis as a heat-sink. If you take it out of circuit and the problem goes away, you've found it! The PS should work normally, just without over voltage protection.
 

Offline vmallet

  • Regular Contributor
  • *
  • Posts: 67
  • Country: us
Re: Power Designs TP343A Shorted Output
« Reply #12 on: February 04, 2020, 04:02:29 am »
Thanks @xavier60 and @vindoline for your help! I tried a few things today but still haven't gotten to the root cause of the problem. The problem here is that I still don't understand a lot of the fundamentals of the schematic so I spend a lot of time trying to figure it out and probe to confirm things but I'm not there yet!

I started by pulling out CR112 to test it out thinking maybe it was causing trouble, but no it's all good.

I then went after Q102 and pulled it out (the small transistor that drives Q105) and it looks good too. Just in case I swapped Q102 from source A with Q202 from source B, no difference.

Now I did try to run it without Q102 (while it was pulled out), and Source A give me a -7V instead of the usual 15V. I don't know that it tells me anything though.

Lastly I tried to remove the SCR (CR211 in this case, by disconnecting its cathode) and run Source A, but no difference, still 15V instead of the expected 0.

I measured most of the resistors in Source A & B in-circuit to look for differences there, all the same.

Still to be continued...
 

Offline xavier60

  • Super Contributor
  • ***
  • Posts: 1609
  • Country: au
Re: Power Designs TP343A Shorted Output
« Reply #13 on: February 04, 2020, 05:34:33 am »
With Q2 in circuit, measure inputs and output voltage on the voltage op-amp.
Hioki AS100D vom, HP 54645A dso, Fluke 87V dmm, AN8008 dmm, Agilent U8002A psu,  FY6600 function gen, New! Brymen BM857S-(With Battery)
 

Offline vmallet

  • Regular Contributor
  • *
  • Posts: 67
  • Country: us
Re: Power Designs TP343A Shorted Output
« Reply #14 on: February 04, 2020, 06:32:26 am »
With Q2 in circuit, measure inputs and output voltage on the voltage op-amp.

The thing here is, I'm not sure which reference it makes sense to measure voltages from.. So for both sources A & B I measured from their two outputs to have a full picture. (I mostly use 3 significant digits as I don't know how accurate this DMM is, 4 at times)

Source A: from DC+:
U101: 1: -3.12 (VO)
U101: 2: 0.027 (V-)
U101: 3: 0.030 (V+)
U101: 4: 12.98 (VCC)
U101: 11: -5.66 (VEE)

Source A: from COM:
U101: 1: 12.6 (VO)
U101: 2: 15.8 (V-)
U101: 3: 15.6 (V+)
U101: 4: 28.5 (VCC)
U101: 11: 10.0 (VEE)

Source B: from DC-:
U201: 1: 2.46 (VO)
U201: 2: 0.000 (V-)
U201: 3: 0.002 (V+)
U201: 4: 12.90 (VCC)
U201: 11: -5.43 (VEE)

Source B: from COM:
U201: 1: 2.47 (VO)
U201: 2: 0.000 (V-)
U201: 3:  0.002 (V+)
U201: 4: 12.90 (VCC)
U201: 11: -5.42 (VEE)

Thanks!
 

Offline xavier60

  • Super Contributor
  • ***
  • Posts: 1609
  • Country: au
Re: Power Designs TP343A Shorted Output
« Reply #15 on: February 04, 2020, 09:48:10 am »
"
Source A: from DC+:
U101: 1: -3.12 (VO)
U101: 2: 0.027 (V-)
U101: 3: 0.030 (V+)
U101: 4: 12.98 (VCC)
U101: 11: -5.66 (VEE)"

Measuring with respect to the + output is correct for A. The op-amp is responding correctly to the fault condition, trying to turn off the output transistors.
"
Source A:
  R111 (for Q104): 0.0V
  R110 (for Q103): 0.24V
"
tells me that Q103 is C-B leaky. The output going negative when Q102 is removed tells me that I'm wrong.
Measure the voltage drop across R112 R111 R110.
Hioki AS100D vom, HP 54645A dso, Fluke 87V dmm, AN8008 dmm, Agilent U8002A psu,  FY6600 function gen, New! Brymen BM857S-(With Battery)
 

Offline xavier60

  • Super Contributor
  • ***
  • Posts: 1609
  • Country: au
Re: Power Designs TP343A Shorted Output
« Reply #16 on: February 04, 2020, 10:01:18 am »
Another thing doesn't add up. With 15V at the output while the CV Pot is at minimum should cause a much larger difference across the op-amp's inputs. Check CR104 and CR105.
Hioki AS100D vom, HP 54645A dso, Fluke 87V dmm, AN8008 dmm, Agilent U8002A psu,  FY6600 function gen, New! Brymen BM857S-(With Battery)
 

Offline vmallet

  • Regular Contributor
  • *
  • Posts: 67
  • Country: us
Re: Power Designs TP343A Shorted Output
« Reply #17 on: February 04, 2020, 06:19:52 pm »
Another thing doesn't add up. With 15V at the output while the CV Pot is at minimum should cause a much larger difference across the op-amp's inputs. Check CR104 and CR105.

Definitely agree with something else not adding up  :)

CR104 out-of-circuit: 0.53V / 0L
CR105 out-of-circuit: 0.50V / 0L

While I was in there I also pulled C109 and C111 as they are close enough to the area of interest (and then C106 to compare another cap similar to C109)
C106 out-of-circuit: 370pF
C109 out-of-circuit: 372pF
C111 out-of-circuit: 1.018uF 3.39Ohm ESR (@1KHz)

(measuring these with a DE-5000 LCR meter)
 

Offline xavier60

  • Super Contributor
  • ***
  • Posts: 1609
  • Country: au
Re: Power Designs TP343A Shorted Output
« Reply #18 on: February 04, 2020, 09:26:15 pm »
Confirm that the voltage Pot goes close to zero ohms at it's minimum setting.
If the output voltage is higher than it should be like 15v, their should be negative voltage at the bottom end of R127 and also pin 3 of U101A.
Hioki AS100D vom, HP 54645A dso, Fluke 87V dmm, AN8008 dmm, Agilent U8002A psu,  FY6600 function gen, New! Brymen BM857S-(With Battery)
 

Offline vmallet

  • Regular Contributor
  • *
  • Posts: 67
  • Country: us
Re: Power Designs TP343A Shorted Output
« Reply #19 on: February 04, 2020, 11:04:04 pm »
They were one of the first things I checked but just to make sure I measured them again.
In-circuit, I get:
R136 (Source A): 0.5 - 2K92
R243 (Source B): 0.6 - 2K86

If the output voltage is higher than it should be like 15v, their should be negative voltage at the bottom end of R127 and also pin 3 of U101A.

Where should I measure the base of R127 from?

I have a 28.84V drop across R127. If I measure from DC+ (also common "A"), I have 12.99V to the top of R127 (an expected value for the B+ bias voltage according to the manual), and -15.85V at the base of R127. (R127 is supposed to be a 1/4W resistor and with 28.84V drop it would be pushing 311mW, doesn't look too good. It's barely warm to the touch though).

In contrast when set to min Source B gives me 12.90V at the top of R227 and pretty much 0V at the bottom of R227. If I set Source B to ~15.8V the measurements don't change.

This time around U101A gives me this (measured from DC+/common "A") (Pot set to min):
U101: 1: 0.633V
U101: 2: 0.027V
U101: 3: -0.068V
 

Offline xavier60

  • Super Contributor
  • ***
  • Posts: 1609
  • Country: au
Re: Power Designs TP343A Shorted Output
« Reply #20 on: February 04, 2020, 11:21:31 pm »
They were one of the first things I checked but just to make sure I measured them again.
In-circuit, I get:
R136 (Source A): 0.5 - 2K92
R243 (Source B): 0.6 - 2K86

If the output voltage is higher than it should be like 15v, their should be negative voltage at the bottom end of R127 and also pin 3 of U101A.

Where should I measure the base of R127 from?

I have a 28.84V drop across R127. If I measure from DC+ (also common "A"), I have 12.99V to the top of R127 (an expected value for the B+ bias voltage according to the manual), and -15.85V at the base of R127. (R127 is supposed to be a 1/4W resistor and with 28.84V drop it would be pushing 311mW, doesn't look too good. It's barely warm to the touch though).

In contrast when set to min Source B gives me 12.90V at the top of R227 and pretty much 0V at the bottom of R227. If I set Source B to ~15.8V the measurements don't change.

This time around U101A gives me this (measured from DC+/common "A") (Pot set to min):
U101: 1: 0.633V
U101: 2: 0.027V
U101: 3: -0.068V
Measurement are usually WRT COMMON "A".
With -15V at the bottom of R127, U101A pin 3 must be -0.6V. Check R125 and the op-amp again.
Hioki AS100D vom, HP 54645A dso, Fluke 87V dmm, AN8008 dmm, Agilent U8002A psu,  FY6600 function gen, New! Brymen BM857S-(With Battery)
 

Offline vmallet

  • Regular Contributor
  • *
  • Posts: 67
  • Country: us
Re: Power Designs TP343A Shorted Output
« Reply #21 on: February 04, 2020, 11:57:12 pm »
I just measured the OV pots to just in case:
R134 (Source A): 130 - 2K11
R238 (Source B): 101 - 2K09
(I leave them both on the max setting).

I went to re-measure pin 3 but it changed from earlier, so here's a fresh set.
Source A output: 15.80V (from COM to DC+)
everything else measured from DC+:
U101A 1: -3.222V
U101A 2: 0.027V
U101A 3: 0.030V
R125 "top": 0.030V (obv. same as U101A-3)
R125 bottom: -15.80V
R127 top: 12.99V
R127 bottom: -15.80V (obv. same as R125)

Thanks again for taking time to look at this :)
 

Offline xavier60

  • Super Contributor
  • ***
  • Posts: 1609
  • Country: au
Re: Power Designs TP343A Shorted Output
« Reply #22 on: February 05, 2020, 01:27:15 am »
I just measured the OV pots to just in case:
R134 (Source A): 130 - 2K11
R238 (Source B): 101 - 2K09
(I leave them both on the max setting).

I went to re-measure pin 3 but it changed from earlier, so here's a fresh set.
Source A output: 15.80V (from COM to DC+)
everything else measured from DC+:
U101A 1: -3.222V
U101A 2: 0.027V
U101A 3: 0.030V
R125 "top": 0.030V (obv. same as U101A-3)
R125 bottom: -15.80V
R127 top: 12.99V
R127 bottom: -15.80V (obv. same as R125)

Thanks again for taking time to look at this :)
You need to find the reason for the incorrect voltage on pin 3. Is R125 ok? Is there a low resistance across CR104? Did you check the op-amp again?
I suspect there is still another fault in the output stage. It's ok to test run the PSU with Q103 disconnected.

Extra: On second thoughts, only disconnect the Collector of Q103.
« Last Edit: February 05, 2020, 02:25:05 am by xavier60 »
Hioki AS100D vom, HP 54645A dso, Fluke 87V dmm, AN8008 dmm, Agilent U8002A psu,  FY6600 function gen, New! Brymen BM857S-(With Battery)
 

Offline xavier60

  • Super Contributor
  • ***
  • Posts: 1609
  • Country: au
Re: Power Designs TP343A Shorted Output
« Reply #23 on: February 05, 2020, 02:25:41 am »
On second thoughts, only disconnect the Collector of Q103.
Hioki AS100D vom, HP 54645A dso, Fluke 87V dmm, AN8008 dmm, Agilent U8002A psu,  FY6600 function gen, New! Brymen BM857S-(With Battery)
 

Offline vmallet

  • Regular Contributor
  • *
  • Posts: 67
  • Country: us
Re: Power Designs TP343A Shorted Output
« Reply #24 on: February 05, 2020, 02:26:58 am »
I'll spend more time trying to figure this one out.

Checked R125 again, it's a nice 3.318K for a 3.32K spec. CR104 and CR105 tested clean this morning when I pulled out their legs.

I just did a couple of tests by disconnecting the collectors from Q103 and Q104 (that should be enough to take them out of the equation right?)

With Q103 disconnected, Q104 connected:
voltage pot @ min: Source A = 32.2V instantly w/ fault light

With Q103 connected, Q104 disconnected:
voltage pot @ min: Source A = 15.88V
I could turn the pot almost 6 turns to bring it very slowly to about 16.2V after which it jumped to 32.2V w/ fault light

With Q103 disconnected, Q104 disconnected:
voltage pot @ min: Source A = 2.69V
I could turn the pot to bring the voltage at an ok pace to about 10V, then it jumped to 32.2V with fault light
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf