Author Topic: [Repair] Cyberpower CP1500PFCLCD UPS display  (Read 1653 times)

0 Members and 1 Guest are viewing this topic.

Offline usagi

  • Frequent Contributor
  • **
  • Posts: 361
  • Country: us
[Repair] Cyberpower CP1500PFCLCD UPS display
« on: May 24, 2017, 12:47:11 am »
The display on one of my CP1500PFCLCD is super dim and needs repair.

Looks like an edgelit LED backlight. Voltage across K-A reads 3.9V.

I really have no idea how to go about repairing this!
« Last Edit: May 24, 2017, 02:27:18 am by usagi »
 

Offline bktemp

  • Super Contributor
  • ***
  • Posts: 1623
  • Country: de
Re: [Repair] Cyberpower CP1500PFCLCD UPS display
« Reply #1 on: May 24, 2017, 06:28:43 am »
Verify if the current is correct: 3.9V sounds wrong for two blue LEDs. If they are in series I would expect more like 6V, while a single LED would be around 3V-3.3V.
If the current is ok, the LEDs are probably dead and you need to replace them. Most edgelit backlights use LED chips mounted directly on the pcb. They are almost impossible to replace, so you need to bodge some other LEDs to the display.
 

Offline CJay

  • Super Contributor
  • ***
  • Posts: 3547
  • Country: gb
Re: [Repair] Cyberpower CP1500PFCLCD UPS display
« Reply #2 on: May 24, 2017, 08:51:46 am »
Ah, cute, it's got a backlight strip.

You may be able to replace the strip with something harvested from an LED backlit laptop panel, ask your local PC repair place if they have a smashed panel you could have?
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf