Author Topic: Repair of a Keysight E3633A Power Supply (new board layout)  (Read 573 times)

0 Members and 1 Guest are viewing this topic.

Offline Magnum

  • Regular Contributor
  • *
  • Posts: 157
  • Country: de
Repair of a Keysight E3633A Power Supply (new board layout)
« on: August 25, 2017, 03:22:40 pm »
Hello,
in another thread I was looking for the schematics for a Keysight E3633A power supply. It seems Keysight doesn't make them public anymore.

It is a unit off Ebay which had Error 631 (System DAC test failed) and 632 (Hardware test failed). I used the schematics of the old layout to understand how this thing works. Keysight put in a new processor, ADC (two channels now) and DAC (four channels). As they have more channels on the ADC and DAC they don't need the multiplexers anymore.

The DAC was indeed dead (ADC measured fine the voltage, but setting the voltage and amp didn't work). I made sure that the DAC got power, had reference voltage and was receiving data from the main processor. But all four outputs were dead. As they go through 3k resistors into an opamp it had to be the chip itself.

I soldered in a new chip and the unit is working now. But I have the following problems:

Switching the unit on after it was off for a couple of minutes causes error 632, but the unit works fine. Switching of and on again gives no error, self test passes fine.

With the output turned off the connectors have -150mV and -8mA current.

I will calibrate it now to see if that problem goes away.
 
The following users thanked this post: Samogon

Offline Magnum

  • Regular Contributor
  • *
  • Posts: 157
  • Country: de
Re: Repair of a Keysight E3633A Power Supply (new board layout)
« Reply #1 on: August 25, 2017, 04:19:50 pm »
Ok, calibration fixed the voltage and current problem with output turned off. Now I have to see if Error 632 is gone when the unit is cold.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf