Author Topic: Repair of a Levell R601S Resistance Decade Box  (Read 156 times)

0 Members and 1 Guest are viewing this topic.

Online mendip_discovery

  • Contributor
  • Posts: 7
  • Country: gb
Repair of a Levell R601S Resistance Decade Box
« on: June 30, 2020, 04:03:56 pm »
I slipped at the weekend and ended up making an offer on an old decade box. It's just turned up and I have just done a basic test using the 121GW.



It is clear the 10Ω range had an issue. Only minor but I would like to see if I can fix it.

I REL(nulled) the meter for each decade.

Opening up the unit I was surprised to see its not just 10 resistors but a complicated mess of 6 either in series or parallel or both to achieve the resistance needed.





I have measured each resistor in situ and I get 20.0012Ω, 19.9000Ω, 19.911Ω, 19.971Ω, 20.109Ω, and 20.097Ω

Any pointers on the next steps, I would prefer not to have to dismantle the whole thing. I am also aware the 1Ω range isn't brilliant but I may be tempted to blame that on the 121GW
« Last Edit: June 30, 2020, 04:05:42 pm by mendip_discovery »
--
Motorcyclist, Nerd, and I work in a Calibration Lab :-)
 

Offline bob91343

  • Frequent Contributor
  • **
  • Posts: 819
  • Country: us
Re: Repair of a Levell R601S Resistance Decade Box
« Reply #1 on: June 30, 2020, 05:07:57 pm »
I am surprised that they use 6 resistors per decade. The usual method uses four, maybe 1, 2, 2, 5 in various series combinations.

The errors you see in the second decade are probably due to one resistor out of tolerance.  Find out which and you can fix it.
 

Online mendip_discovery

  • Contributor
  • Posts: 7
  • Country: gb
Re: Repair of a Levell R601S Resistance Decade Box
« Reply #2 on: June 30, 2020, 05:21:41 pm »
I am surprised that they use 6 resistors per decade. The usual method uses four, maybe 1, 2, 2, 5 in various series combinations.

I was expecting 10 resistors. They use 20 \$\Omega\$ resistors for the 10  \$\Omega\$ range and as far as I can see are 1% tolerances. They have H2 printed on there which makes me think they are TE range of leaded resistors with a power factor of 1W

The errors you see in the second decade are probably due to one resistor out of tolerance.  Find out which and you can fix it.

Yes, I have measured them and are all within spec if it is assumed 1% tolerance is correct.
--
Motorcyclist, Nerd, and I work in a Calibration Lab :-)
 

Offline The Soulman

  • Frequent Contributor
  • **
  • Posts: 760
  • Country: nl
  • The sky is the limit!
Re: Repair of a Levell R601S Resistance Decade Box
« Reply #3 on: June 30, 2020, 06:11:44 pm »
Have you tried turning the knob a couple of times back and forth to see if that changes anything?
If it does change a bit that could indicate the switch contacts could use a cleaning.

one way to find out the switching arrangement is to apply a small current across the box (10mA) and measure the voltage across each of the
20 Ohm resistors at each setting to determine which is used when.
Keep higher decades at 0 to not overload them.

It likely is a interesting arrangement.

Quote
I have measured each resistor in situ and I get 20.0012Ω, 19.9000Ω, 19.911Ω, 19.971Ω, 20.109Ω, and 20.097Ω

These resistors are probably selected to form nice pairs, ie: 20.097 + 19.900= 39.997 or 19.900 + 20.109 = 10.002 ect..

have fun.  :)
 

Offline TheMG

  • Frequent Contributor
  • **
  • Posts: 312
  • Country: ca
Re: Repair of a Levell R601S Resistance Decade Box
« Reply #4 on: June 30, 2020, 06:26:45 pm »
First thing I would do is douse all the switches in contact cleaner and work them back and forth. Quite often problems with these old decade resistance boxes are due to poor contacts, which is very likely the case since all the resistors measured individually appear to be in tolerance.
 

Online mendip_discovery

  • Contributor
  • Posts: 7
  • Country: gb
Re: Repair of a Levell R601S Resistance Decade Box
« Reply #5 on: June 30, 2020, 07:30:38 pm »
So after some poking and prodding and lots of switch movement, things still seem the same. The posts do look like they have had better days, I may look to upgrade them at some point.

The contacts are very clean and tidy. If I clean them with contact cleaner is there a lubricant I should use?




Excuse the crap drawing, but its the basic layout of how the pins are connected,


T = Top, TB= Top Bottom, etc.

I did miss there is a Wire from T1 to BB2

Resistors are connected to
R1   TB2      BB2
R2   TB2      BT3
R3   TT4      BT6
R4   TT7      BT10
R5   TT10   BB10
R6   TT11   BB11

My brain will melt if I try to draw the schematic at the moment. I did just try and follow the flow but the series and parallel resistors has me flummoxed.
--
Motorcyclist, Nerd, and I work in a Calibration Lab :-)
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf