Author Topic: Repair of HP8648 Signal Generator  (Read 2641 times)

0 Members and 1 Guest are viewing this topic.

Offline mitslo76

  • Contributor
  • Posts: 7
Repair of HP8648 Signal Generator
« on: March 11, 2015, 08:45:21 pm »
Hi Everyone,

My HP8648A just died. Magic smoke went out  :(. Apparently it's power supply unit, that produce +15,-15,+5 and +38V... I want to try to repair it, but I have two problems. I couldn't find Schematic and also some resistors and one diode near to HV MOSFET IRF840 burned out so I couldn't read values. I was wondering if someone has schematic or at least if someone can take photo of similar unit so I can begin from replacing burned parts. Building totally new power supply is I guess an option too, but as last resort I guess. Any help is more that welcome. Thanks in advance.

Best Regards,
Slobodan
 
 

Offline lowimpedance

  • Super Contributor
  • ***
  • Posts: 1060
  • Country: au
  • Watts in an ohm?
Re: Repair of HP8648 Signal Generator
« Reply #1 on: March 11, 2015, 10:40:12 pm »
 I t would seem that HP only suggested whole assembly repairs in the service manual  :(.
If you have not seen this thread it 'might' be of some use ! .
https://www.eevblog.com/forum/repair/video-teardown-and-repair-of-an-hp-8648c-synthesized-signal-generator/msg152221/#msg152221
good luck

The odd multimeter or 2 or 3 or 4...or........can't remember !.
 

Offline mitslo76

  • Contributor
  • Posts: 7
Re: Repair of HP8648 Signal Generator
« Reply #2 on: March 12, 2015, 12:52:38 am »
Thanks for the link. Actually I saw this tread but as you noticed the HP Operation and Service Guide doesn't have a schematic, they recommend module change... I was thinking since is of the shelf part (its Computer Products Power Supply 510160) maybe someone has the schematic...
 

Offline Unrockstar

  • Newbie
  • Posts: 2
Re: Repair of HP8648 Signal Generator
« Reply #3 on: May 01, 2015, 07:50:01 pm »
Hello,

I repair my Powersupply at this time too,

I shot a photo and Upload it tomorrow.

Can you make a Photo from your Supply?

My Powersupply doesn´t power up correctly after repair.
I think i have make a Mistake by a wrong restistor
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf