Author Topic: Repairing a Tek CFG-280 Function Generator  (Read 11979 times)

0 Members and 1 Guest are viewing this topic.

Offline The_Penguin

  • Regular Contributor
  • *
  • Posts: 103
  • Country: ca
Repairing a Tek CFG-280 Function Generator
« on: January 04, 2012, 02:49:55 am »
I mentioned in the "Thoughts on buying non-working or for-parts Oscilloscopes" thread that I picked up a "for parts or repair" function generator on Ebay.
It's a Tektronix CFG-280. Looks to be in decent shape, pretty clean.
I first noticed a rattle, and upon dis-assembly found a resistor that had de-soldered itself.
I replaced it and did a quick power on test. That resistor and a transistor got hot fast, so no point leaving it on for more tests.

It appears that Q522 (a 2N2905a) is shorted, and it's neighbor Q520 (2N2219A) is bad (Peak tester says unknown bad part DMM diode test reads voltage drop in both directions)

R522 and R520 both appear to have been running hot, and the colours are a bit washed out. Looks like  red brown black or . Both measure 33.4 ohms out of circuit.

Before I blindly replace the transistors, I'm wondering if anyone knows where I might find a service manual or schematic?
Or does anyone know the value for R520 and 522?

I have googled, and found a possible service manual on a pay file transfer site, but I'm not convinced it's legit.

Thanks.

 
 

alm

  • Guest
Re: Repairing a Tek CFG-280 Function Generator
« Reply #1 on: January 04, 2012, 04:51:50 pm »
Don't count on finding the schematics. These were not designed or built by Tek. Even inside Tek documentation was extremely limited.
 

Offline quint

  • Contributor
  • Posts: 33
Re: Repairing a Tek CFG-280 Function Generator
« Reply #2 on: January 04, 2012, 06:24:12 pm »
A while back, I repaired a CFG-280 which had what sounds like the same problem as yours.  While looking for the schematics or any service information, I found an ex-Tek employee who repaired these units under contract to Tek (when they were still supported).  According to him, there was never any service information available outside of the repair facility (these units were depot repair only).  He still has the internal repair information and some notes he wrote up on repair, which he was willing to send for a pretty nominal fee.  I can send you his contact information if you want it.
I didn't end up buying them from him because, in the meantime, I found a couple of shorted transistors and burned resistors in the final output stage.  I suspect those are exactly the same components as you have discovered.  I don't recall the component values at the moment but the transistors had cube shaped heat sinks on them and the resistors were fairly large (in terms of power handling).  I replaced the transistors with new and did my best to read the color codes on the toasted resistors and replaced those.  Since then, the unit has worked quite well and the signals look pretty clean so I've been happy with it for the low price I paid for it as non-functional surplus.
 

Offline The_Penguin

  • Regular Contributor
  • *
  • Posts: 103
  • Country: ca
Re: Repairing a Tek CFG-280 Function Generator
« Reply #3 on: January 04, 2012, 06:28:44 pm »
A while back, I repaired a CFG-280 which had what sounds like the same problem as yours.  While looking for the schematics or any service information, I found an ex-Tek employee who repaired these units under contract to Tek (when they were still supported).  According to him, there was never any service information available outside of the repair facility (these units were depot repair only).  He still has the internal repair information and some notes he wrote up on repair, which he was willing to send for a pretty nominal fee.  I can send you his contact information if you want it.
I didn't end up buying them from him because, in the meantime, I found a couple of shorted transistors and burned resistors in the final output stage.  I suspect those are exactly the same components as you have discovered.  I don't recall the component values at the moment but the transistors had cube shaped heat sinks on them and the resistors were fairly large (in terms of power handling).  I replaced the transistors with new and did my best to read the color codes on the toasted resistors and replaced those.  Since then, the unit has worked quite well and the signals look pretty clean so I've been happy with it for the low price I paid for it as non-functional surplus.

Excellent info, thanks a lot.  I'll try replacing the transistors and resistors and go from there. If that doesn't work, I'll get back to you about the contact info.

Thanks!
 

Offline quint

  • Contributor
  • Posts: 33
Re: Repairing a Tek CFG-280 Function Generator
« Reply #4 on: January 04, 2012, 09:29:18 pm »
You're welcome.  Let us know how the repair goes.
BTW, I know these units were one of Tek's attempts to compete in the lower cost instrument market by manufacturing in Asia.  I don't know if they were a complete rebadge or Tek had a hand in design.  I was reasonably impressed with the build quality in any case.  If someone knows of a similar instrument under another brand name, it would be interesting to compare the internals.  The specs would be pretty easy to spot in another unit I think: 11 MHz sine, triangle and square wave output at 50% duty cycle.  1/20th of that at 95/5 duty cycle.  0-2V and 0-20V variable output ranges, 100 MHz frequency counter, internal and external frequency sweep, etc.
 

Offline FenderBender

  • Super Contributor
  • ***
  • Posts: 1118
  • Country: us
    • The Solid State Workshop
Re: Repairing a Tek CFG-280 Function Generator
« Reply #5 on: January 04, 2012, 09:35:10 pm »
Hey maybe you could upload some pictures of the fix or anything else?  Would be awesome
 

Offline The_Penguin

  • Regular Contributor
  • *
  • Posts: 103
  • Country: ca
Re: Repairing a Tek CFG-280 Function Generator
« Reply #6 on: January 06, 2012, 12:53:54 am »
Hey maybe you could upload some pictures of the fix or anything else?  Would be awesome

I'll try to get some photos this weekend.  Digikey and Mouser are back-ordered on the 2N2219A  so I have some coming from Jameco. Snailmail to Canada will be about a week.
 

Offline The_Penguin

  • Regular Contributor
  • *
  • Posts: 103
  • Country: ca
Re: Repairing a Tek CFG-280 Function Generator
« Reply #7 on: January 07, 2012, 10:34:11 pm »
Here are some photos, in the last photo you can see where I have removed the 2 transistors.
 

Offline FenderBender

  • Super Contributor
  • ***
  • Posts: 1118
  • Country: us
    • The Solid State Workshop
Re: Repairing a Tek CFG-280 Function Generator
« Reply #8 on: January 08, 2012, 04:10:42 am »
Looks nice! But Tektronix with the Suscon electrolytics? Tsk tsk.
 

Offline The_Penguin

  • Regular Contributor
  • *
  • Posts: 103
  • Country: ca
Re: Repairing a Tek CFG-280 Function Generator
« Reply #9 on: January 08, 2012, 05:09:32 am »
Looks nice! But Tektronix with the Suscon electrolytics? Tsk tsk.
Yeah no kidding.  In higher stress circuits like switchmode supplies and monitors sux-on are replace on sight.
I did measure a few and they check ok, but I may need to replace them so I can sleep at night. :)
 

Offline Rerouter

  • Super Contributor
  • ***
  • Posts: 4671
  • Country: au
  • Question Everything... Except This Statement
Re: Repairing a Tek CFG-280 Function Generator
« Reply #10 on: January 08, 2012, 05:44:54 am »
some of the layout on the boards looks like tek, but barely at that, and the wiring!, gah!, i would have to say its a majority rebadge aswell
 

Offline FenderBender

  • Super Contributor
  • ***
  • Posts: 1118
  • Country: us
    • The Solid State Workshop
Re: Repairing a Tek CFG-280 Function Generator
« Reply #11 on: January 08, 2012, 09:57:36 pm »
some of the layout on the boards looks like tek, but barely at that, and the wiring!, gah!, i would have to say its a majority rebadge aswell

Yeah and the wiring is definitely not exactly what I would expect.
 

Offline The_Penguin

  • Regular Contributor
  • *
  • Posts: 103
  • Country: ca
UPDATE- Re: Repairing a Tek CFG-280 Function Generator
« Reply #12 on: January 29, 2012, 10:17:40 pm »
My transistors finally arrived just as I was leaving for Mexico, so just got back and got back to work on this.

Replaced the 2 transistors, and the 2 crispy looking resistors, and fired it up.
Looks good!!  Nice clean sine wave, the transistors and resistors are relatively cool.
I left it running for a while, going through the range of about 10hz to 10Mhz, and it seems good.

Since it's capable of 20v p-p I'm thinking maybe someone cranked it up into a very low impedance load at caused the output transistor to short.

Anyway, $55.00 well-spent.

 

alm

  • Guest
Re: Repairing a Tek CFG-280 Function Generator
« Reply #13 on: January 29, 2012, 10:22:32 pm »
Glad you were able to fix it. There's always the internal 50 ohm series resistance, so it's not really a dead short. A good function generator should have no problem with being shorted. Someone connecting it to a voltage source seems more likely to me.
 

Offline wendtmk

  • Newbie
  • Posts: 3
Re: Repairing a Tek CFG-280 Function Generator
« Reply #14 on: March 01, 2012, 12:54:39 pm »
A while back, I repaired a CFG-280 which had what sounds like the same problem as yours.  While looking for the schematics or any service information, I found an ex-Tek employee who repaired these units under contract to Tek (when they were still supported).  According to him, there was never any service information available outside of the repair facility (these units were depot repair only).  He still has the internal repair information and some notes he wrote up on repair, which he was willing to send for a pretty nominal fee.  I can send you his contact information if you want it.
I didn't end up buying them from him because, in the meantime, I found a couple of shorted transistors and burned resistors in the final output stage.  I suspect those are exactly the same components as you have discovered.  I don't recall the component values at the moment but the transistors had cube shaped heat sinks on them and the resistors were fairly large (in terms of power handling).  I replaced the transistors with new and did my best to read the color codes on the toasted resistors and replaced those.  Since then, the unit has worked quite well and the signals look pretty clean so I've been happy with it for the low price I paid for it as non-functional surplus.

Quint,

Can you send me the info on the fella you mention above?  I'd love to get whatever info on this piece of equipment that I can.

Thanks,
Mark
 

Offline ecc

  • Newbie
  • Posts: 1
Re: Repairing a Tek CFG-280 Function Generator
« Reply #15 on: July 04, 2012, 10:18:12 pm »
I got a not-quite-working one of these recently.  At low frequencies (< 1kHz), the waveforms look OK.  But anything above that and the amplitude goes way down and the waveforms are very distorted (for example, the square wave just looks like a charge/discharge cycle through a capacitor).  Do these symptoms ring any bells with anyone?  I'd also appreciate the contact info for the ex-Tek guy in case I need to get those notes.  Thanks.
 

Offline steve_tech

  • Contributor
  • Posts: 5
Re: Repairing a Tek CFG-280 Function Generator
« Reply #16 on: July 01, 2015, 11:16:35 pm »
Did you ever get your CFG-280 running? I have 2, one works and one is missing a PAL. I have service info....
 

Offline ajjj1000

  • Newbie
  • Posts: 2
  • Country: us
Re: Repairing a Tek CFG-280 Function Generator
« Reply #17 on: May 27, 2016, 12:43:08 am »
Hello, I bought a tektronix CFG 280 on ebay not working and when I got it it was missing the display IC and a smaller IC nex to it. Anyone know what the numbers are for these ICs?

Thanks,
Arnmold.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf