Electronics > Repair

REPRO PS-305D power supply - bringing it back to life - I have questions

(1/2) > >>

bpjl:
Hi,

My name is Przemek, I come from Silesia, and this is my first post on this forum. Of course, I come straight away with problems and questions :)

Let's get to the point:

Hi,

I plan to buy a new workshop power supply, but I also decided to revive the old REPRO PS-305D. After replacing the damaged transistors, the equipment came back to life. I'm also planning to replace the radiator to relieve them.

I also replaced the old potentiometers (all four) because there were problems with setting low current and voltage values. When I tried incrementing the values ​​from 0 - first, nothing happened, then some value appeared, but it fluctuated and only within a further range could stable settings be obtained. After replacement, the problem went away.

I also struggled with calibration - https://www.eevblog.com/forum/reviews/yh-305d-power-supply-calibration-procedure/.

After all these treatments, everything seems to be OK, but a few things bother me:


1. I think, but I could be wrong, that in the past it was possible to set the desired voltage by having the current potentiometers turned to 0. Currently, in order for any voltage to appear, I have to turn the current to at least the smallest minimum. Is it supposed to be like that or is it a glitch?

2. By calibrating the power supply readings with potentiometers on the back of the display PCB, I set the mA and A readings without any problems. However, with voltage it's a different story. The differences between what the multimeter shows and the power supply's readings are as follows:



When the readings converge at low voltages, the higher voltages start to diverge significantly. And similarly - if you synchronize the top, the bottom is terrible. As you can see above, I have set it as such accuracy up to 2V. I know that I cannot expect hyper-accuracy and "being razor sharp" from such a power supply, but maybe there is a way to improve the values readings ​​shown above?

I don't mean that the power supply should reach the declared 30V (although it would be great). I care more about showing the voltage more accurately throughout its entire range. Below are the photos of the display PCB:

   

Fun fact: Yes! I know that all these power supplies are one and the same inside. The only difference is the print on the front of the case.
But to that extent? Outside it's REPRO and the display PCB is YIHUA?

3. What is the "mA and A offset" potentiometer used for, because I don't really understand it?

I am attaching a diagram for the Yihua YH-305D power supply. Maybe it will be helpful.

DanielDlouhy:
Hello,

1. That's fine. There needs to be some small current to set the output voltage (to charge output caps and there's also propably a resistor on the output). Maybe the old pot didn't go all the way to 0 with resistance when it was set to 0, so it always set a very small current...

2.That might be because of that cheap panel voltmeter... But I don't have the schematic.

3.That is propably the "error" between mA and A range. For example: If you set the output current to 900mA in a mA range, then is should show 0,9A in a A range. But I suppose that ranges are selected automatically, so it is probably so it doesn't jump from 0,999mA to 1,1 A for example... But again, without a schematic, it's hard to guess.

If you happen to find a schematic for your unit with the pots labeled, I might be able to help you more...

-Daniel

bpjl:

--- Quote from: DanielDlouhy on May 27, 2024, 05:11:08 pm ---1. That's fine. There needs to be some small current to set the output voltage (to charge output caps and there's also propably a resistor on the output). Maybe the old pot didn't go all the way to 0 with resistance when it was set to 0, so it always set a very small current...
--- End quote ---
You're probably right, and that could have been the case.


--- Quote from: DanielDlouhy on May 27, 2024, 05:11:08 pm ---2.That might be because of that cheap panel voltmeter... But I don't have the schematic.
--- End quote ---
As I have already mentioned, there is a YIHUA print on the PCB of the measuring panel. I have a diagram for the Yihua YH-305D power supply. I think they are the same panels. I am attaching the file to this entry.
I also received this answer and advice on another forum. It may be helpful:

--- Quote from: Vogelek23 @ [url=http://www.elvikom.pl ---www.elvikom.pl[/url] forum]If the built-in voltage meter overstates the readings by about 10% (you can immediately see that it is non-linear - at 2V it is about 5%, and at 26V it is about 13.5%), then I see only one solution here - replacing R17 to 1.82kΩ (tolerance 0.1-0.25%, E192 series) and replace V11 with a multi-turn potentiometer (e.g. 5kΩ value is available for Bourns 3296 series). Then, set the "standard" multimeter to 15.0V at the power supply output and, by turning V11, equalize the readings of the built-in meter. After calibrating for 15V, check the 2V and 26V settings to see if the values ​​roughly match. Why "roughly"? Because this voltmeter is, unfortunately, 100% software - the microcontroller controlling the displays reads the voltage directly on the I/O port set as ADC (and this is after the 1/8 resistor division, where the resistors themselves are certainly not temperature compensated). The non-linearity of the indications can therefore be corrected only by far-reaching changes in the firmware, which, of course, he has no access to because the µC is read-protected. The best solution (in terms of calibration and compensation possibilities, and therefore the accuracy of indications) would be to write your own firmware for this µC.
--- End quote ---


--- Quote from: DanielDlouhy on May 27, 2024, 05:11:08 pm ---3.That is propably the "error" between mA and A range. For example: If you set the output current to 900mA in a mA range, then is should show 0,9A in a A range. But I suppose that ranges are selected automatically, so it is probably so it doesn't jump from 0,999mA to 1,1 A for example... But again, without a schematic, it's hard to guess.
--- End quote ---
Thanks for the clarification. I will check it when I assemble the power supply. Currently, I am in the process of replacing the heat sink for the power transistors with a larger one.

 Yihua YH-305D.pdf (203.53 kB - downloaded 33 times.)

DanielDlouhy:
Looking at the schematic, you can't do much about the voltmeter. As "Vogelek23" from "elvikom.pl" said, the voltmeter is 100 % software. You can try to averige it (as he also said), by replacing the R17 and V11. But that's pretty much all you can do.

Daniel

bpjl:
As soon as I assemble the power supply, I will try this solution. Of course, I will write what came out of it.

For now, thank you for your help and time.

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod