Author Topic: Einhell cc-bc 30 not charging  (Read 412 times)

0 Members and 1 Guest are viewing this topic.

Offline CurrentBitesOnlyOnce

  • Contributor
  • Posts: 7
  • Country: af
Einhell cc-bc 30 not charging
« on: July 09, 2020, 09:53:24 pm »
Hi ppl,
I have charger from the title but is not charging. I got it with blown 50amp fuse at the back, after replacing the fuse still no luck. As far as i could test it i am getting volts but not the amps. With charger plugged in and volt settings on 12 and through all amp settings 1-6 and at the clamps i have 12 voc on dvom, on the scope i have pulsed unfiltered 13-14voc. When i put the clamps at the empty battery (11v) i have around 15v at the clamps but on the ampclamp around positive i got nothing, with dvom on amp setting in series to negative post and clamp i got nothing. Charger's ampmeter shows zero all the time. On ~ terminals of the bridge rectifier i have 13v with the clamps off the battery. If i put shortly the dvom as ampermeter instead of the battery i have up to 50-60 amps at the ampclamp and charger's ampmeter goes full scale. So why no current through the battery (tried several batteries) but there is current through the dvom or shortcircuit? And why 8 diodes in the bridge, i guess for power??
 

Offline CurrentBitesOnlyOnce

  • Contributor
  • Posts: 7
  • Country: af
Re: Einhell cc-bc 30 not charging
« Reply #1 on: July 10, 2020, 06:19:35 pm »
After more testing looks like everything is fine, looks like all the batteries are bad. On the new battery charger works fine. I was puzzled yesterday because all looked kinda fine but no charging. Was nice talking to myself. Cheers ppl.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf