EEVblog Electronics Community Forum

Electronics => Repair => Topic started by: WaterMM on April 20, 2016, 06:28:51 am

Title: Rohde & Schwarz Signal Gerator SML-01
Post by: WaterMM on April 20, 2016, 06:28:51 am
Hi All, I'm new here.

I have 2 units SML-01 need repair.
The failure as below:

Unit 1
1)  Internal cal failed Harm Filter & Level Preset
2)  Selftest failed : 
      Err 110, O/P unleveled  Failed selftest

Unit 2
1)  Internal cal failed Harm Filter & Level Preset
2)  Selftest Err 110, O/P unleveled  Failed selftest ,
Err -313 Cal memory lost  : Level Preset
Err -313 Cal memory lost : Harmonic filter

I've perform internal cal according to the user manual, but it still the same.
I suspect for the flash cal memory lost ? Any idea and advise from your experience. Thank you.
Title: Re: Rohde & Schwarz Signal Gerator SML-01
Post by: Smith on April 20, 2016, 02:39:35 pm
Welcome,

Some more info would be nice. Have you bought both broken? Do you know what happened to the units? I reckon the output could be blown/defective, or something like calibration.  I don't think the calibration is an issue, and maybe it even failed on unit 2 after the unit was broken.

You could take a look here: https://www.eevblog.com/forum/repair/rohde-schwarz-signal-gerator-sml-01-dead-needs-repair/ (https://www.eevblog.com/forum/repair/rohde-schwarz-signal-gerator-sml-01-dead-needs-repair/)

I think it would be wise to check voltages first. Also, does the unit work besides the errors/warnings?
Title: Re: Rohde & Schwarz Signal Gerator SML-01
Post by: HighVoltage on April 22, 2016, 03:41:48 pm
A few month ago, I repaired a broken one and it all came down to the power supply circuit and bad electrolytic caps.
https://www.eevblog.com/forum/repair/rohde-schwarz-signal-gerator-sml-01-dead-needs-repair/msg843706/#msg843706 (https://www.eevblog.com/forum/repair/rohde-schwarz-signal-gerator-sml-01-dead-needs-repair/msg843706/#msg843706)
The repair was easier than I had expected.

You should start at all the rail voltages.