Author Topic: Rom writing error - TL866II Plus help  (Read 372 times)

0 Members and 1 Guest are viewing this topic.

Offline Pickles

  • Newbie
  • Posts: 3
  • Country: us
Rom writing error - TL866II Plus help
« on: December 17, 2019, 10:24:18 pm »
Hello everyone,
I am in the process of restoring a rom (long story) on a system and I keep getting this error. Not sure what else to do. I had a backup (re-read the chip 5 times and did a checksum with the saved roms). They all seem okay. When i write the image back the rom I get this error (see attached) and not sure what to do...

This problem comes up with not only the original rom, the modified rom and even a newly downloaded rom from a known good source...

Sorry if I sound really stupid with this, I am kinda new to this whole thing. If there is any other information you need me to provide, let me know. Any help welcomed!

Yes, I have tried googling the issue. Absolutely zero results have come back. Maybe wrong search terms? Problem is I don't even know what I don't know....

Also, some clarification:
Checksum for original image vs itself, no issues. Verified chip prior to writing and compared its contents to the rom saved, no issues.
Issue occurs with ANY rom being writen to rom chip.
« Last Edit: December 17, 2019, 10:27:14 pm by Pickles »
 

Online NivagSwerdna

  • Super Contributor
  • ***
  • Posts: 1923
  • Country: gb
Re: Rom writing error - TL866II Plus help
« Reply #1 on: December 17, 2019, 11:22:51 pm »
Post a photo of the device.
 

Offline Pickles

  • Newbie
  • Posts: 3
  • Country: us
Re: Rom writing error - TL866II Plus help
« Reply #2 on: December 17, 2019, 11:41:15 pm »
Will this do?

I just wrote another chip without issues... Is it possible the rom has a bad sector?
 

Offline TK

  • Super Contributor
  • ***
  • Posts: 1327
  • Country: us
  • I am a Systems Analyst who plays with Electronics
Re: Rom writing error - TL866II Plus help
« Reply #3 on: December 18, 2019, 01:38:29 am »
Is the memory you are programming soldered on the target PCB and powered on?
 

Offline CJay

  • Super Contributor
  • ***
  • Posts: 3547
  • Country: gb
Re: Rom writing error - TL866II Plus help
« Reply #4 on: December 18, 2019, 09:13:06 am »
Will this do?

I just wrote another chip without issues... Is it possible the rom has a bad sector?

It's possible the chip is faulty, years ago I interviewed with a company that had a problem with a device they designed and manufactured (cathodic protection device), the coder had written the firmware so it was updating a small number of locations in a 24Cxx series EEPROM every minute or so and they were failing after a couple of months, changing the update frequency to twice a day fixed the problem.

The failure mode was just like a bad block on a hard drive, you could use the chip as long as you didn't try to write to the affected location(s)
 

Offline Pickles

  • Newbie
  • Posts: 3
  • Country: us
Re: Rom writing error - TL866II Plus help
« Reply #5 on: December 18, 2019, 03:12:13 pm »
Honestly wouldn't surprise me. Going to see if I can steal a chip from another system.

looks like it was a bad chip! Coolio! Thanks guys!
« Last Edit: December 18, 2019, 03:17:13 pm by Pickles »
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf