Author Topic: [Solved] Sanken SI-1125HD hybrid schematic (Sony STR-313L)  (Read 223 times)

0 Members and 1 Guest are viewing this topic.

Offline shakalnokturn

  • Super Contributor
  • ***
  • Posts: 1436
  • Country: fr
[Solved] Sanken SI-1125HD hybrid schematic (Sony STR-313L)
« on: April 21, 2021, 01:13:53 am »
I'm working on a Sony STR-313L with distorted sound on left channel.
Found the datasheet for the Sanken amplifier hybrid that does include a schematic but the .pdf is so low quality that it's not much use.
Anyone out here have a usable copy that would save me some time in reverse engineering?
« Last Edit: April 22, 2021, 11:05:55 pm by shakalnokturn »
 

Offline shakalnokturn

  • Super Contributor
  • ***
  • Posts: 1436
  • Country: fr
Re: Sanken SI-1125HD hybrid schematic (Sony STR-313L)
« Reply #1 on: April 21, 2021, 10:11:34 pm »
Before poking around inside the removed hybrid the component tester on my Hameg scope was clearly showing differences between channels.
Not really expecting any reply here I went and drew the schematic with values from the good channel, funny thing is they're both showing the same thing now on the component tester...
Anyway just in case it's of future use I've attached other photos and schematics found while searching and a zip file with my notes and schematic.
(Beware zip files may contain  viruses!)

Time to fit it back in the amplifier and check if it has self repaired.
 
The following users thanked this post: fzabkar

Offline shakalnokturn

  • Super Contributor
  • ***
  • Posts: 1436
  • Country: fr
Re: Sanken SI-1125HD hybrid schematic (Sony STR-313L)
« Reply #2 on: April 21, 2021, 10:54:30 pm »
Finally caught the glitch before re-fitting it for nothing, the emitter bonding of the upper output transistor had fused into a small ball, almost making contact.
An external isolated TO-220 it will be...
 

Offline shakalnokturn

  • Super Contributor
  • ***
  • Posts: 1436
  • Country: fr
Re: Sanken SI-1125HD hybrid schematic (Sony STR-313L)
« Reply #3 on: April 22, 2021, 11:03:07 pm »
A few more pictures as a follow-up.

A quick check with random transistors there's room to fit four TO-247 packages besides the hybrid if things come to the worse.
Base and Emitter break-out wires epoxied onto the defective transistor.
Reassembled with a 2SD2059 in place of the bad output transistor.
Good I/V curve on the component tester between +Vcc and output on the removed hybrid.

The amplifier is now working well, without noticeable difference between channels.
The MPX trimmer needed readjusting on the receiver to get stereo.

Anyone know why the service manual mentions replacing R239 from 13k to 24k when IC201 is replaced?
I checked against the voltages given on the schematic with and without muting. The mute line is close to 0V when muted but not close to 5V un-muted (only 2.7V), replacing R239 with 24k allows to get close to 5V, but why replace it only if replacing IC201?

Thanks for watching.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf