Author Topic: HP8590L spectrum analyzer calibration signal issues  (Read 1883 times)

0 Members and 1 Guest are viewing this topic.

Offline Bjoern

  • Contributor
  • Posts: 36
  • Country: sg
Re: HP8590L spectrum analyzer calibration signal issues
« Reply #25 on: July 25, 2018, 03:15:29 am »
You are absolutely right, I never had a working SA. Not familiar with the operations but I got some good news today that a friend of mine got access to a 500Mhz scope and hopefully we will be able to trace the signal.
 

Offline Bjoern

  • Contributor
  • Posts: 36
  • Country: sg
Re: HP8590L spectrum analyzer calibration signal issues
« Reply #26 on: July 25, 2018, 06:16:01 pm »
A friend of mine lent me his 500Mhz scope so I could do some more testing today.
I measured the T- signal that goes into the YIG oscillator and I get a good 122khz signal with a span adjustment above 10Mhz.
Below or equal 10Mhz I get a jittery signal which looks faulty.
I disconnected the YIG from on the RF side to measure any output but there is nothing.
Now I am not sure, if the YIG is damaged, and in addition I have a problem below 10Mhz Span or if the analog board doesnt provide the correct signals to the YIG.
The voltages on the YIG are OK.
The T+ signal shows nothing really.
The heater works.
Does anybody understand what signals I should be able to measure in order for this module to work properly ??
 

Offline Bjoern

  • Contributor
  • Posts: 36
  • Country: sg
Re: HP8590L spectrum analyzer calibration signal issues
« Reply #27 on: July 26, 2018, 05:29:11 am »
I have also a problem with my YIG. I measure the following on the connector:
FM-  = -3.8mV
FM+ = -1.2mV the resistance between FM- and FM+ is 0.48 Ohm !
When I disconnect the connector FM+ measures +7.5 V (with an 139khz signal on top of the DC), this is with a span of >10Mhz. If the span is <=10Mhz the signal jumps hence the DC is unstable (coming from the analogue board)
Main Coil has 13 Ohm resistance and 13V as well as 14.95 V respectively
I cant get a signal on FM- with or without connection.

Do you see any indication that the YIG is definitely damaged (too low resistance on FM?)?
It seems I might have two issues, one on the YIG with FM and another with the <>10Mhz span fed from the analogue board ?

Would be great to get your insides.  BTW my HP is the 8590L, I attach the relevant schematics.

 

Offline Bjoern

  • Contributor
  • Posts: 36
  • Country: sg
Re: HP8590L spectrum analyzer calibration signal issues
« Reply #28 on: July 28, 2018, 04:29:19 am »
I did some more work on the Spectrum Analyzer and noticed that above a SPAN of 100khz I seem to have a good signal versus a SPAN of <100khz where it becomes distorted.

Could you point me to the circuit that could be potentially responsible for this error ?
 

Offline collett.marcelo@gmail.com

  • Contributor
  • Posts: 5
  • Country: br
Re: HP8590L spectrum analyzer calibration signal issues
« Reply #29 on: October 04, 2018, 12:24:46 pm »
Hello Bjoern,

I am facing a similar issue with my SA and I kindly ask if you is you could share the whole schematics file or the shortcut for this instrument.
Despite my model is different , I think it will be a start reference....

Thank you very much!

Marcelo
 

Offline Bjoern

  • Contributor
  • Posts: 36
  • Country: sg
Re: HP8590L spectrum analyzer calibration signal issues
« Reply #30 on: October 05, 2018, 07:00:40 am »
Hi I tried to send to you but each PDF is around 15Mbyte large and I cant attached it here.
Any suggestions ?
 

Offline SaabFAN

  • Frequent Contributor
  • **
  • Posts: 665
  • Country: de
Re: HP8590L spectrum analyzer calibration signal issues
« Reply #31 on: October 05, 2018, 03:13:58 pm »
Upload to Dropbox or Google Drive and send the Links by PM or post here would be a good idea, I think.

Were you able to fix it in the end btw. ?


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf