Author Topic: Seasonic 1250W X-Series Faulty power good signal.  (Read 2764 times)

0 Members and 1 Guest are viewing this topic.

Offline gnif

  • Administrator
  • *****
  • Posts: 1105
  • Country: au
Seasonic 1250W X-Series Faulty power good signal.
« on: July 24, 2016, 09:50:25 am »
Hi All,

Just wondering if anyone else has seen this fault before. I have a Seasonic 1250W X-Series PSU for my main rig, there is some history to this.

I installed this PSU about 8 months ago, and was working fine until about 2 months ago when it started to act up, after a blackout/brownout (frequent occurrences where I am) the PSU would not start until I had disconnected it from power for about 20 minutes. Figured it got into some strange state and it just needed to discharge internally to reset. Eventually the PSU stopped working completely, so I had it replaced under warranty.

Now, my new PSU is doing the same thing, out of a desperate need to get my work machine operational again I forced the PSU on (grounded PWR_ON) and checked all the voltages with a dummy load attached, everything was in spec. So I investigated the power good signal and found it is always at 0v. I tied it to 5v via the standby 5v power and now the machine operates.

Clearly there is a fault with the power good signal, the PSU is under warranty so I don't want to open it, but I would like to know if others have had the same/similar issue. If so I might demand they replace it with a different model entirely.
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission

I volunteer my time to manage this server, if you would like to support this work I have a patreon here:
https://www.patreon.com/gnif
 

Offline janoc

  • Super Contributor
  • ***
  • Posts: 2885
  • Country: fr
Re: Seasonic 1250W X-Series Faulty power good signal.
« Reply #1 on: July 24, 2016, 10:20:15 am »
If the power good doesn't come on, there is a very likely problem with something inside of that PSU. It has likely got damaged by the power spike.

I strongly suggest you remove the power supply from use asap, because you don't know what it may do. The voltages could be in spec now, but the you can have a heap of molten slag instead of a computer two hours later if the controller chip goes bonkers.

You may also want to get a surge protector (or even UPS) if you have frequent problems with brownouts/blackouts.
« Last Edit: July 24, 2016, 10:26:35 am by janoc »
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1105
  • Country: au
Re: Seasonic 1250W X-Series Faulty power good signal.
« Reply #2 on: July 24, 2016, 10:19:58 pm »
I have both a surge protector and a enterprise grade 2RU UPS, unfortunalty not fully online though so doesn't save from brownouts. Highly doubt it is a surge fault.

Edit: Also for the record I have swapped to a secondary backup PSU as I do not trust this unit at present. I guess I will be sending it back again, I will have to see if I can obtain a different model as I have numerous PCs on the same circuit and this is the only one that screws up each time.
« Last Edit: July 24, 2016, 11:07:26 pm by gnif »
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission

I volunteer my time to manage this server, if you would like to support this work I have a patreon here:
https://www.patreon.com/gnif
 

Offline Stefan Payne

  • Contributor
  • Posts: 36
  • Country: de
Re: Seasonic 1250W X-Series Faulty power good signal.
« Reply #3 on: July 28, 2016, 03:32:12 am »
Hm, sound strange...

And maybe it's more like a board issue -> Board just doesn't like this kind of PSU, for whatever reason...
And thus the PSU does not work that reliably with the system...

Or maybe it's an issue with the UPS??
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1105
  • Country: au
Re: Seasonic 1250W X-Series Faulty power good signal.
« Reply #4 on: July 28, 2016, 04:06:36 am »
It is certainly not a bad board or UPS, the machine runs fine on other supplies, and the UPS is powering 3 other computers including a enterprise server and SAS array. The fault only developed after a brown out, which points the finger at some design flaw in the PSU since this is the 2nd time this has occurred on the exact same PSU.
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission

I volunteer my time to manage this server, if you would like to support this work I have a patreon here:
https://www.patreon.com/gnif
 

Offline Stefan Payne

  • Contributor
  • Posts: 36
  • Country: de
Re: Seasonic 1250W X-Series Faulty power good signal.
« Reply #5 on: July 28, 2016, 04:50:47 am »
Well, maybe, or there is some issues with the power good signal and the PSU can't deliver it in the timeframe the board expect it and that causes the thingy to work...

The only way to make sure is to test the PSU with another board. If it works fine with that board but not the one you want and the one you want does work with other PSUs it's just some kind of incompatibility...

Changing the mainboard could possibly solve the problem as well as going to a different PSU.

And by the way:
Are you talking about the SS-1250XM or the SS-1250XM2?
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1105
  • Country: au
Re: Seasonic 1250W X-Series Faulty power good signal.
« Reply #6 on: July 28, 2016, 05:02:40 am »
It is the initial revision, not the XM2.

It is certainly not an incompatibility, I have confirmed this by powering the supply on while disconnected from the machine by pulling PW_ON signal low, the PW_GD signal is never present, if a PSU fails to do this, it does not conform to the ATX spec, and 99% of motherboards on the market will fail to start on it.

According to ATX spec, there should be +5V on the PW_ON signal once the PSU is in a stable state at which point the motherboard will exit reset state and proceed to post. Since a +5V output is never present and all other voltages measure correctly and are stable on an oscilloscope, it points that there is a certain fault with the power supply's stable state detection circuitry and never signals the motherboard it is ready to be used.

Quote
deliver it in the timeframe the board expect
There is no timeframe ever, the board is simply held in the reset state until this voltage is present.
« Last Edit: July 28, 2016, 05:10:23 am by gnif »
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission

I volunteer my time to manage this server, if you would like to support this work I have a patreon here:
https://www.patreon.com/gnif
 

Offline Stefan Payne

  • Contributor
  • Posts: 36
  • Country: de
Re: Seasonic 1250W X-Series Faulty power good signal.
« Reply #7 on: July 29, 2016, 12:27:21 am »
If your unit is still in warranty, you should contact seasonic and ask for a replacement...
That's the easiest way, though it might be replaced with the 'true single rail' XM2 version, and not the quad rail one.

And have you tested the PSU on another mainboard?
Please do, before concluding that it is not an incompatibility...
 

Offline ovnr

  • Frequent Contributor
  • **
  • Posts: 658
  • Country: no
  • Lurker
Re: Seasonic 1250W X-Series Faulty power good signal.
« Reply #8 on: July 29, 2016, 01:07:57 am »
What incompatibility. It's a PSU; it has two control signals: The "turn on" input and a "power good" output. Both are dumb as a pile of bricks, logically speaking. Unless you plug it into something weird like old Dell motherboards, the only issue you'd see is a too small PSU failing; this is not that problem.
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1105
  • Country: au
Re: Seasonic 1250W X-Series Faulty power good signal.
« Reply #9 on: July 29, 2016, 01:12:03 am »
It is under warranty as I initially stated, I was just looking for others that might have had the same issue.

And have you tested the PSU on another mainboard?
Please do, before concluding that it is not an incompatibility...

It is 100% not an incompatibility...
Please read: https://en.wikipedia.org/wiki/Power_good_signal

ATX spec states how the PSU MUST work, no ifs, maybes, perhaps we should... It states that the power good signal MUST be present after the PSU stabilizes. It never presents the signal, EVER, as such it doesn't matter squat if it works with another motherboard, it is faulty.

If it did work with another motherboard it just means that that other motherboard is also faulty or is some cheap chinese crap that doesn't conform to standards.
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission

I volunteer my time to manage this server, if you would like to support this work I have a patreon here:
https://www.patreon.com/gnif
 

Offline Stefan Payne

  • Contributor
  • Posts: 36
  • Country: de
Re: Seasonic 1250W X-Series Faulty power good signal.
« Reply #10 on: August 17, 2016, 01:00:58 pm »
It is 100% not an incompatibility...
Please read: https://en.wikipedia.org/wiki/Power_good_signal
I know of the Power Good specification and such. Still, there just are incompatibilitys in the real world - they don't happen that often but they do happen.

ATX spec states how the PSU MUST work, no ifs, maybes, perhaps we should... It states that the power good signal MUST be present after the PSU stabilizes. It never presents the signal, EVER, as such it doesn't matter squat if it works with another motherboard, it is faulty.
That's the theory...
In the real World it's not how it goes...
It's how it should, I agree with that, but it's not the way it is...


If it did work with another motherboard it just means that that other motherboard is also faulty or is some cheap chinese crap that doesn't conform to standards.
No it just means there is an incompatibility...

There are also other factors beside the power good signal, it's not only that. And sometimes you just have problems...

Take a look at the PCB manufactoring tour on this site. Somewhere there was stated that only one particular jelly bean chip (some LM I think it was) did work as intended...

And pls do NOT blame the chinese for that. They do it cheap because we want it to be cheap. They just have a different mentality...
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1105
  • Country: au
Re: Seasonic 1250W X-Series Faulty power good signal.
« Reply #11 on: August 17, 2016, 01:06:28 pm »
It is 100% not an incompatibility...
Please read: https://en.wikipedia.org/wiki/Power_good_signal
I know of the Power Good specification and such. Still, there just are incompatibilitys in the real world - they don't happen that often but they do happen.

ATX spec states how the PSU MUST work, no ifs, maybes, perhaps we should... It states that the power good signal MUST be present after the PSU stabilizes. It never presents the signal, EVER, as such it doesn't matter squat if it works with another motherboard, it is faulty.
That's the theory...
In the real World it's not how it goes...
It's how it should, I agree with that, but it's not the way it is...


If it did work with another motherboard it just means that that other motherboard is also faulty or is some cheap chinese crap that doesn't conform to standards.
No it just means there is an incompatibility...

There are also other factors beside the power good signal, it's not only that. And sometimes you just have problems...

Take a look at the PCB manufactoring tour on this site. Somewhere there was stated that only one particular jelly bean chip (some LM I think it was) did work as intended...

And pls do NOT blame the chinese for that. They do it cheap because we want it to be cheap. They just have a different mentality...

 |O |O |O |O |O |O |O |O |O |O |O |O |O |O |O |O |O |O |O |O |O

If I did not have the equipment to TEST and PROVE the PSU is providing the voltages as expected, and PROVE that the signal good is MISSING, I might believe you... But... I DO have the equipment consisting of two reputable multi-meters (Agilent and Bryman), a very recently calibrated bench multi-meter (Escort 3146A), and a 1Ghz/s 100Mhz DSO. Are you saying that all my tools are faulty?

Seriously... It is not a matter of the signal is low, or inconsistent, or sporadic, it is simply NEVER, and I mean NEVER presented. Doesn't matter what you say, any 1/2 decent motherboard wont post without the power good signal being presented unless it does not conform to spec, in which case it is a cheap ass load of crap that would never see use in my office.

The fact that if I manually pull the power good signal to 5v standby everything operates as expected, post, boot and rock stable under load, clearly shows your 'guess' at an incompatible power supply is complete and utter bull.

You seem like one of those idiots people that believe that you need $10,000 nude virgin OFC cables for your digital signals...
« Last Edit: August 17, 2016, 01:19:30 pm by gnif »
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission

I volunteer my time to manage this server, if you would like to support this work I have a patreon here:
https://www.patreon.com/gnif
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1105
  • Country: au
Re: Seasonic 1250W X-Series Faulty power good signal.
« Reply #12 on: August 17, 2016, 01:31:56 pm »
If it did work with another motherboard it just means that that other motherboard is also faulty or is some cheap chinese crap that doesn't conform to standards.
No it just means there is an incompatibility...

Yes, it is incompatible with the ATX specification and as such should not be sold as a ATX motherboard.

There are also other factors beside the power good signal, it's not only that. And sometimes you just have problems...

Like what? Seriously...

+5V, +12V and +3.3V are all in spec, even under load conditions with extremely low ripple and pretty much no overshoot (my reason for selecing this PSU in the first instance).
+5V standby is present and in spec
PW_ON signal is working as expected

What else is there?
« Last Edit: August 17, 2016, 01:34:04 pm by gnif »
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission

I volunteer my time to manage this server, if you would like to support this work I have a patreon here:
https://www.patreon.com/gnif
 

Offline ovnr

  • Frequent Contributor
  • **
  • Posts: 658
  • Country: no
  • Lurker
Re: Seasonic 1250W X-Series Faulty power good signal.
« Reply #13 on: August 18, 2016, 09:12:30 am »
It is 100% not an incompatibility...
Please read: https://en.wikipedia.org/wiki/Power_good_signal
I know of the Power Good specification and such. Still, there just are incompatibilitys in the real world - they don't happen that often but they do happen.

ATX spec states how the PSU MUST work, no ifs, maybes, perhaps we should... It states that the power good signal MUST be present after the PSU stabilizes. It never presents the signal, EVER, as such it doesn't matter squat if it works with another motherboard, it is faulty.
That's the theory...
In the real World it's not how it goes...
It's how it should, I agree with that, but it's not the way it is...


If it did work with another motherboard it just means that that other motherboard is also faulty or is some cheap chinese crap that doesn't conform to standards.
No it just means there is an incompatibility...

There are also other factors beside the power good signal, it's not only that. And sometimes you just have problems...

Take a look at the PCB manufactoring tour on this site. Somewhere there was stated that only one particular jelly bean chip (some LM I think it was) did work as intended...

And pls do NOT blame the chinese for that. They do it cheap because we want it to be cheap. They just have a different mentality...

Really? No. You evidently have no idea what you're blathering on about, or how these things work.


On the problem at hand with PGOOD not asserting: Sure, maybe the rails are all fine. Maybe it's just the monitor chip that's broken. But it might also be something iffy up-stream (APFC output out of limits, etc); you don't really know without figuring out why it's not being asserted, and it'd be a fair bit of warranty-voiding repair work to do that. So I'd just RMA the whole mess.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf