Author Topic: Service manual for Tecsun PL-880 'flagship' receiver?  (Read 903 times)

0 Members and 1 Guest are viewing this topic.

Offline peteb2

  • Regular Contributor
  • *
  • Posts: 188
  • Country: nz
Service manual for Tecsun PL-880 'flagship' receiver?
« on: May 26, 2019, 10:41:51 pm »
Have done an indepth Google to find any info but i expect Tecsun are doing their best to keep things among their agents.

I bought one these receivers less than 5 months ago from Amazon and while using the ordinary medium wave AM band one afternoon, the thing suddenly let out a loud as hell buzzing noise and then only hiss. The entire AM band is now silent save for hiss. The LW, HW, SW & FM stills works 100%.

On account of being so far down-under in NZ the cost to return the PL-880 under warranty is beyond being sensible. I've opened the thing up breaking the seal (too bad) and discovered one of the most terrible assembly jobs ever on such a kind of equipment. I am used to the likes of the extreme quality of Sony or Yaesu RF gear but this thing is a JOKE.

The PCBs have been truly badly flow soldered and there are micro-balls of legacy solder paste everywhere. Screen cans have been badly (manual) half soldered to the board and i won't go into further detail here on just what a mess things really are.

My option now is to obtain service manual or at least any service info and sort this thing otherwise it will go into being another reason NOT to buy this kind of OneHungLow Brand of equipment.

Such a pity, nice looking, fully optioned unit & reasonably great performance with rave revues but in reality zero reliability all because of truly low assembly standard.
 

Offline Tac Eht Xilef

  • Frequent Contributor
  • **
  • Posts: 516
  • Country: 00
Re: Service manual for Tecsun PL-880 'flagship' receiver?
« Reply #1 on: May 27, 2019, 09:07:49 am »
I've opened the thing up breaking the seal (too bad) and discovered one of the most terrible assembly jobs ever on such a kind of equipment. I am used to the likes of the extreme quality of Sony or Yaesu RF gear but this thing is a JOKE.

Having been inside something like 40 or 50 Tecsun radios - mostly PL-600's, 660's, and 880's - for modding (e.g. IF output) or repair reasons (mostly rotary encoders on early build ones, & headphone/antenna sockets on later units), I'm surprised. Their physical build quality has always been right up there with the best Chinese manufactured stuff I've ever seen. I've certainly never seen anything even remotely like you describe.

I have seen that sort of thing from the likes of Kaito or the OEM'd cheap Ali/Banggood specials, but not Tecsun. Either it's a very bad one-off, they've taken a massive dive in quality recently, or someone has started selling fakes.

Unfortunately I've never seen that sort of fault (odd that it's only affecting MW & not SW), nor do I know of any genuine service manuals or schematics - just a number of 'unofficial' schematics that are either poorly reverse-engineered, or just obviously BS wrong. And I don't think I've even seen one of those for the '880.

edit: turns out I do have a (Russian, reverse-engineered) PL880 schematic. Hope it helps. Still can't quite see what'd affect MW but not LW/SW.

« Last Edit: May 27, 2019, 10:25:56 am by Tac Eht Xilef »
 
The following users thanked this post: peteb2


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf