Author Topic: Soniq U65TX14A-AU No display  (Read 106 times)

0 Members and 1 Guest are viewing this topic.

Offline SaltFpv

  • Newbie
  • Posts: 2
  • Country: au
Soniq U65TX14A-AU No display
« on: June 07, 2021, 01:19:44 pm »
Hi everyone,
Just wondering if someone could please help me?
I have a Soniq U65TX14A-AU, when I power it on the back light works and the start up sound plays but no image. 
What happened was after some time when it did work it would get a green image running from top to bottom and I would turn it off and on after 5 min it would be fine.
Now it has no display.
I opened it up. Checked the 5 and 24v rail on the main board. However I noticed the heat top heat sink was lifted on what I think is the BGA LCD Chip.

Would replacing the main board - U65TX14A-AU - Main Board -(ST6369IV-TC1) (222-665006002-30) work?
Or should I replace the main board along with the
Tcon Board -(6870C-0466B) ?

Any way I could prove it's that particular component which the heat sink was not secured too? I think it would be the BGA LCD TV chip that the heat sink was lifted. I dont have a reflow station.

Any help would be greatly appreciated, I am new here and new to electronics. Only repaired minor boards like PDB,s and Flight controllers. Just don't want to throw out something if it can be fixed.
Cheers
 

Offline SaltFpv

  • Newbie
  • Posts: 2
  • Country: au
Re: Soniq U65TX14A-AU No display
« Reply #1 on: June 11, 2021, 12:44:06 pm »
Thanks for all the support, managed to diagnose the issue and repair the board. Tv is now working after replacing a few components with a heat gun and soldering.  :-+
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf