Electronics > Repair

Sony 50" TV KDL-50W800B LED TV Faulty

(1/1)

WaynesWorld:
Hi. I inherited one of these in a non-working order.

The unit powered on. Backlight on, but no picture or sound.

After a bit of reading on here and the internet in general, and some YT vids, I came to the conclusion it must be the T-con board. I think I even did some voltage tests to confirm this. Unfortunately, I didn't take note of the power LED diagnostics.

I order an exact replacement from AE for about $11. Ordered a second from a different seller for about the same.

The first one arrived and I just installed it. Initially it blinked the red LED 5 times. I reseated the cables to the T-con board and powered again.

No backlight this time - just Continuous alternating orange(amber) and green light. I can't find any reference to this in the service manual or on the web.

What did I mess up?

wraper:
If you return the original board, does it work as it did previously? All of those T-CON boards on ebay are pulls from scrapped TVs, very likely untested. So there is a large chance you received a faulty board.

DavidAlfa:
Emmc issues are common in these models.
Simply replacing and programming the emmc is not enough, the system is linked to the emmc unique  ID.
There's a way, but it's not public, only certain tools can do it.
Search "Sony w800(b/c..) emmc" for more info.
I have 55w808, crossing my fingers after 5 years...

WaynesWorld:

--- Quote from: wraper on October 19, 2021, 11:33:39 am ---If you return the original board, does it work as it did previously? All of those T-CON boards on ebay are pulls from scrapped TVs, very likely untested. So there is a large chance you received a faulty board.

--- End quote ---
With the original board, I get the back light only.

According to some other sites, the flashing orange and green means it needs a software update. I downloaded the latest from Sony and followed the procedure in the service manual. The procedure on the Sony official site also included steps to reset. No luck either way.

I was hoping to have the second board by now so I could report but still hasn't arrived.


--- Quote from: DavidAlfa on October 19, 2021, 01:17:33 pm ---Emmc issues are common in these models.
Simply replacing and programming the emmc is not enough, the system is linked to the emmc unique  ID.
There's a way, but it's not public, only certain tools can do it.
Search "Sony w800(b/c..) emmc" for more info.
I have 55w808, crossing my fingers after 5 years...

--- End quote ---
I've researched EMMC but can't find too much on it. What is it? How does one program the EMMC, and what more is required that being not enough?

Navigation

[0] Message Index

There was an error while thanking
Thanking...
Go to full version