Author Topic: Successful repair of Owon SDS5032E oscilloscope  (Read 1055 times)

0 Members and 1 Guest are viewing this topic.

Offline Arek_R

  • Regular Contributor
  • *
  • Posts: 60
  • Country: gb
  • Polish guy living in the UK
Successful repair of Owon SDS5032E oscilloscope
« on: March 30, 2018, 06:35:24 pm »
Hello everyone, I'm new here and I decided to post this as it can help a lot of people with their oscilloscope as it seems to be a common manufacturing issue which has no official solution as this chinese company doesn't care about their customers.

I got mine from ebay as faulty(customer return), once I received it, it was in perfect physical condition, so description was 100% true.
What was wrong, unit boots up, display turns on with "welcome image", dimms it slightly, then goes black and repeats boot sequence over and over.
Of course decided to crack it open, after hours of measuring and inspecting, I couldn't find any hardware issue, conclusion - software issue.
This issue was basically the same as Dave's Siglent function generator(EEVblog2 "Siglent Signal Generator FAIL") which he then later repaired by uploading new firmware with help from siglent in next video "Siglent Signal Generator Fix"
So I knew what to do, was extremly sure that I have to do same thing, so I rushed to Owon's website and sent them an email where I very nicely asked to help me with this, of course they didn't...
No way to fix it without their software and firmware.
Month later decided to google this again, and then I found video where some guy was going to review this device and had same problem, he contacted Owon and got all necessary files, and he shared them!:
You can see the issue at his vid: https://youtu.be/AIiIOXBt0M0?t=490

So I downloaded these files from his link, connected scope to my PC, installed drivers, run the software, did what it said, and IT WORKS!!!

Here are these files: https://drive.google.com/open?id=14li4fleK4quQmkfdSUdyOzy2bOYdJrJH

Big thanks to Aviprink from YouTube, if not him it would never be fixed!
« Last Edit: March 30, 2018, 06:40:05 pm by Arek_R »
 

Offline dalmatian

  • Newbie
  • Posts: 1
  • Country: jp
Re: Successful repair of Owon SDS5032E oscilloscope
« Reply #1 on: September 25, 2018, 02:27:50 pm »
Hi, could you share some detail on how to use the patch? I tried the patch but did not work. At first I thought it might be good to update to the latest firmware, because I think I found some bugs with the SCPI commands. After updating using the patch until the second step, the oscilloscope just keeps restarting so it becomes unusable. I am wondering if I need to tinker with the ini or xml files in the patch. Thanks
 

Offline Arek_R

  • Regular Contributor
  • *
  • Posts: 60
  • Country: gb
  • Polish guy living in the UK
Re: Successful repair of Owon SDS5032E oscilloscope
« Reply #2 on: November 10, 2018, 05:15:04 pm »
Wait, you mean that your oscilloscope was working and after using this patch program it doesnt?
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf