Author Topic: Repairing my brand new µCurrent GOLD  (Read 796 times)

0 Members and 1 Guest are viewing this topic.

Offline krautguy

  • Contributor
  • Posts: 6
  • Country: de
  • Open Source developer; Hacker
    • https://bues.ch/
Repairing my brand new µCurrent GOLD
« on: March 25, 2017, 08:50:14 pm »
A few days ago I got my brand new µCurrent GOLD, yay.
It works perfectly, except for that it doesn't.

The on/off-switch is jerky as hell:
https://bues.ch/misc/ucurrent_onoff.avi
 :-BROKE

Surely this can't be by design. So there must be something strange going on with that switch.
The switch is fairly easy to open, so let's do that.
One of the contact sliders doesn't show much wear at all (compared to the other one). That's a bit strange. I don't know which side this slider was on, though.
But let's look at the contacts. Looks pretty good.
...
But ...  :o ... what's that strange dot there on contact 3?
Let's clean it with some rubber and isopropanol.

After greasing it with some silicone grease (that's what I had at hand) it works like a charm.

Thanks Dave for this great tool. :)
« Last Edit: March 25, 2017, 09:00:23 pm by krautguy »
 

Offline krautguy

  • Contributor
  • Posts: 6
  • Country: de
  • Open Source developer; Hacker
    • https://bues.ch/
Re: Repairing my brand new µCurrent GOLD
« Reply #1 on: March 26, 2017, 10:25:10 am »
I did not take pictures while opening the on/off switch.
So here are some pictures of the range switch.

The required tools are:
- Three needles
- Tweezer
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf