Electronics > Repair

Tablet does not power on, how to check battery & charge circuit?

(1/2) > >>

Twiggy:
Hello,

I picked up this old family tablet, a huawei mediapad t3 10 ags-w09, that was sitting dead in some drawer.

I've been interested in electronics repair for quite some time, although so far I've only done simple jobs like smartphone screen or swollen capacitors, so nothing that required any kind of diagnostic ability, which is why I write this thread :)

So this tablet, when I press the power button, vibrates, screen displays some icon indicating a power issue, and turns off.
I left it on the charger for several minutes, no change.
Charger and cable are good, tested with other devices.

I open the tablet, disconnect the battery, and check voltage, it shows 3.4
I plug the battery, and check voltage between battery terminals (circled in red in pic) and ground, and now it shows 1.6V. No difference when the charger is plugged in.

I conclude from this that the battery is bad, since as soon as it's in circuit its tension collapses, and that it's not charging, since when I plug the charger i would expect to see >4V between battery and ground.
But i do not get why it's not coming on when the charger is plugged.

Before I try to source a new battery, how could I confirm the problem is not on the charging circuitry? Would it help if I bought some USB power meter?

Thanks for any kind of advice :)


CountChocula:
Have you tried putting some load on the battery, like a resistor (say, 100Ω) to see if its voltage does, indeed, collapse? That should give you an indication whether the problem is in the cell or somewhere in your circuit.

Twiggy:
Hello, I tried what you suggested. With a 100ohm resistor attached to the battery I measured 3.4V.

sleemanj:
Disconnect battery, get a TP4056 charger, connect battery to charger, connect USB to charger, charge battery fully, then try again.

Twiggy:
External charger revived the battery and I could boot the tablet. However android doesn't detect when I plug the usb cord and I dont measure a different voltage on the battery terminals with or without the usb cord.

Attached is a pic of the charging port, sorry it's blurry, i only have a phone and it doesnt focus well when it's so close.

Some measurements with usb cord plugged in :
Uab = 5V (charger), as expected i suppose
UAC= 0, as expected again as both are ground
UBC=0.1V, I would have expected to see 0 since both points are supposed to be ground

What should I check now?

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod