Author Topic: TDK Lambda Alpha II 650 Power Supply issue  (Read 1157 times)

0 Members and 1 Guest are viewing this topic.

Offline ramin.azizli

  • Newbie
  • Posts: 2
  • Country: az
TDK Lambda Alpha II 650 Power Supply issue
« on: May 22, 2017, 08:31:01 pm »
Hello everyone,

I have Alpha II 650 power supply by TDK Lambda. Here is the link in case you want to have a look:

http://www.tdk-lambda.com/products/sps/ps_alpha/alpha2/indexe.html

Just quick explanation: Alpha II 650 power supply (input: 110VAC, 220VAC) has an AC filter and 375VDC in the output. Output goes directly into a transformer with ferrite. That transformer gives ~18VAC pk2pk (!) at the secondary side which is the input of the DC to DC converters. This is what I get with my oscilloscope (see attachments). Ground was at the center of the screen when I made measurements.
So I have in repair one of these boards and it has a problem with its DC to DC converter (24V). In order to hook that up to the lab power supply I need to know the input voltage (which is obvious). But my multimeters did not measure anything neither in DC nor in AC mode at the input of the converters. Meanwhile as was mentioned before I measure 17.8VAC pk2pk (50Hz sinusoidal) with my oscilloscope (see attachments). So I'm puzzled.
Can you please advise or help to find out that input voltage?
Maybe someone has some experience on this boards and maybe he knows the general problems that faces these type of boards (especially with the DC to DC converters).
I would highly appreciate if you can share your knowledge.

Looking forward for your responses and help.

Thanks in advance to the whole community here... :)
« Last Edit: May 23, 2017, 11:17:30 am by ramin.azizli »
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf