Author Topic: fluke 8840a display fading in and out  (Read 746 times)

0 Members and 1 Guest are viewing this topic.

Offline mr3141

  • Contributor
  • Posts: 5
fluke 8840a display fading in and out
« on: November 18, 2018, 07:22:33 pm »
Dear all

I have an old Fluke 8840a which is working fine, except the display is going dark from time to time. Not completely off, just fading out... few seconds later coming back on. Until now it helped to gently push on top of the case to make the display come back on.

Today, it didn't work at all. I opened the unit and measured voltage rails (all fine). While I had the unit open, it was upside down. I switched it on and noticed that the display was working again. I put it back together and switched it on (in its normal position) and it had the display issue again. It seems to be very reproducible that the display works reliably only if the unit is turned upside down.

I guess this is a mechanical issue, but no idea where exactly.

Any idea?
 

Online mzacharias

  • Frequent Contributor
  • **
  • Posts: 633
  • Country: us
Re: fluke 8840a display fading in and out
« Reply #1 on: November 18, 2018, 09:04:22 pm »
Solder connections. Main board (around the power transformer), or at the FL tube itself.
 

Offline lowimpedance

  • Super Contributor
  • ***
  • Posts: 1087
  • Country: au
  • Watts in an ohm?
Re: fluke 8840a display fading in and out
« Reply #2 on: November 18, 2018, 11:11:44 pm »
 Most certainly re solder the transformer even if they look okay, and for that matter best to re do all connections in the path to the filaments. one other point is IIRC all front PCB connections are via dil headers, give those a wiggle then check for any corrosion on the pins etc. While your at it solder 2 wires to the filament connections right at the VFD to see if the supply is interrupted at any time when the unit is moved/inverted and back. (using a CRO or other DMM etc)
 The fact that it seems to function then fail repeatably when inverted does sound like an issue in the VFD itself which is not a happy thought, so make triply sure all other possible issues have been eliminated.
Good luck.
The odd multimeter or 2 or 3 or 4...or........can't remember !.
 

Offline mr3141

  • Contributor
  • Posts: 5
Re: fluke 8840a display fading in and out
« Reply #3 on: November 19, 2018, 11:32:53 am »
Thanks for your replies!

I took a closer look to the power transformer solder connections. There were flux residues, I guess someone has done a reflow before. Under microscope I could see that two of the joints  were visibly cracked. I've done reflow of all connections.... considering how heavy that transformer is it seems now quite obvious that this was the issue.
I also reconnected the front PCB dil cables. Sockets and pins looked clean.

I have it running now in its normal position and the display brightness stable :) Thanks for the tips!



 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf