Author Topic: Finding info on NJW1298  (Read 596 times)

0 Members and 1 Guest are viewing this topic.

Offline TheMG

  • Frequent Contributor
  • **
  • Posts: 508
  • Country: ca
Finding info on NJW1298
« on: December 12, 2020, 01:04:36 am »
My home theater receiver (Emotiva UMC-200) has decided to crap out. Has zero audio output no matter what I do.

So far, I've been able to determine that the main DAC does output audio, but then it goes to this NJW1298 IC which is a combination input selector and volume control. Nothing is coming out of that IC at all.

The only datasheet I can seem to find is this:

https://www.njr.com/electronic_device/PDF/NJW1298_E.pdf

Unfortunately, it seems to not be a complete datasheet. Most importantly it doesn't have the pinout information. I need to determine whether the IC is receiving its necessary supply voltages, and if the digital commands are getting from the main microcontroller to this IC.

As far as getting a service manual or schematic... surprise surprise... not available.

Anyways, anyone know where to find more information on this IC? I've emailed the IC manufacturer but I'm not holding much hope of getting any kind of a reply.
 

Offline amyk

  • Super Contributor
  • ***
  • Posts: 7153
Re: Finding info on NJW1298
« Reply #1 on: December 12, 2020, 04:25:58 am »
This manual from another product that uses the NJW1298 has schematics which show the pinout:
https://www.vintageshifi.com/repertoire-pdf/pdf/telecharge.php?pdf=Harman-Kardon-AVR-3600-Service-Manual.pdf

It's odd that the 1298 doesn't, and doesn't specifically say the datasheet has been truncated; similar parts from them like the NJU72340A do have a full datasheet. Given that it looks more like a mistake than a deliberate hiding of information, you may have a higher chance of success contacting them about it.
 

Offline TheMG

  • Frequent Contributor
  • **
  • Posts: 508
  • Country: ca
Re: Finding info on NJW1298
« Reply #2 on: December 12, 2020, 06:32:25 pm »
Awesome, that's a good starting point. I can use that to validate supply voltages and if serial commands are being sent to the chip.

Thanks.
 

Offline TheMG

  • Frequent Contributor
  • **
  • Posts: 508
  • Country: ca
Re: Finding info on NJW1298
« Reply #3 on: December 13, 2020, 08:12:12 pm »
A quick bit of probing... +7V -7V supply pins ok. With the scope I do see "stuff" on the CLK and DATA pins when manipulating the volume controls and selecting between different inputs.

Hard to tell if it's valid data from brief flashes on the analog scope (I really should get a proper DSO). When I get some more time I'll get my crude logic analyzer on it and try to determine if there's sensible data there or just gibberish.

But it is more and more looking like that IC might be dead and not responding to any commands.
 

Online fzabkar

  • Frequent Contributor
  • **
  • Posts: 867
  • Country: au
Re: Finding info on NJW1298
« Reply #4 on: December 13, 2020, 08:40:10 pm »
 
The following users thanked this post: amyk

Offline TheMG

  • Frequent Contributor
  • **
  • Posts: 508
  • Country: ca
Re: Finding info on NJW1298
« Reply #5 on: December 14, 2020, 01:20:13 am »
Well I dusted off the 12 year old crappy logic analyzer (cheap USB thing). Sure looks like serial control data is being sent to it appropriately.

After doing that, however, it started working again?!?!?

Cold solder joint maybe? Anyways, I ended up reflowing the whole IC with fresh solder and flux. Time will tell if it continues to work or if this was just a fluke.

Actually a cold/cracked solder joint is probably a reasonable assumption. This unit had started acting up about a month prior due to a bad capacitor in the power supply. When I recapped the power supply I also removed the main board and checked all the capacitors on it. On the bottom of the board near the NJW1298 is a flat-flex connector that is rather tricky to insert, so it's probable that the stress/flexing of the board when I was reinserting that connector led to a (probably already weak) solder joint cracking partially, and the thermal cycles of using the unit in the following weeks eventually led to an open connection.

That's going to be my theory for now.
 

Online rsjsouza

  • Super Contributor
  • ***
  • Posts: 4415
  • Country: us
  • Eternally curious
    • Vbe - vídeo blog eletrônico
Re: Finding info on NJW1298
« Reply #6 on: December 14, 2020, 01:58:34 am »
Congratulations on fixing this. In my experience, receivers are usually prone to cold solder as a great deal of them use single layer PCB and parts of their circuits run very hot.

A long time ago my receiver started muting itself unexpectedly at times on any digital inputs. When I was disassembling it, a 7805 voltage regulator simply fell from its place - the solder joints simply gave up. A quick resolder and everything became normal.
Vbe - vídeo blog eletrônico http://videos.vbeletronico.com

Oh, the "whys" of the datasheets... The information is there not to be an axiomatic truth, but instead each speck of data must be slowly inhaled while carefully performing a deep search inside oneself to find the true metaphysical sense...
 

Offline TheMG

  • Frequent Contributor
  • **
  • Posts: 508
  • Country: ca
Re: Finding info on NJW1298
« Reply #7 on: January 04, 2021, 11:39:18 pm »
Well... it lasted a few weeks and crapped out again.

This time, when I probed the CLK pin I found there was no clock signal when commands were sent to the IC. In fact, there was a lot of noise on that line indicating that it was probably floating. This was not the case last time I was troubleshooting this, so it must be intermittent and just happened to be working again when I was measuring it the last time.

So I visually traced the CLK signal on the PCB (thankfully, only a double-sided board) all the way back to the MCU. Then I measured from one IC to the other with my DMM and... open circuit, and occasionally 20-30 ohms if I gently twist the board a certain way.

Eventually I narrowed down the problem to a bad via, as I have near zero ohms on one side of the via, and high resistance on the other side of the via. To repair, I removed some solder mask from both sides of the via and a bit from the trace, threaded a strand of fine wire through the via, and soldered it down to the exposed copper on both side. It works!!! Hopefully for good this time.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf