EEVblog Electronics Community Forum

Electronics => Repair => Topic started by: jker on October 21, 2020, 05:49:28 am

Title: Tektronix 455 with "squished" left-side trace
Post by: jker on October 21, 2020, 05:49:28 am
Hello all! New to the forum (and the hobby in general).

I have recently acquired a Tektronix 455 from a friend's basement, but have mostly been using it as an absurdly oversized DC voltmeter. There is an issue with the left-hand side of the trace at higher (ie more time/div) horizontal settings on the trace, visible with a real AC signal (or even the calibration signal). Images attached.  When I crank the time/div into the micro-second range, this issue goes away.

I think this is what is being described in the tek-parts/troubleshooting-scopes.pdf under "Typical Horizontal Problems"

> Problem: Compression or expansion of the sweep as it is positioned from one side to the other
> Solution: This problem is typically caused by the diode network between the bases of the amplifier. Check for leaky diodes.

I have two issues with this:

One: I don't actually know if I'm using the correct terms to describe this problem. If this issue goes by another name, I would appreciate someone letting me know... as I could easily be looking at a completely different issue.
Two: Where exactly are the "bases of the amplifier", either physically or in the circuit diagrams (I have the tek_455_clean_schematics and the manual).

EDIT: I've uploaded an animated gif to imgur showing this, as well as me moving the position knob and timebase, sorry for the shaky camera, it's on an extremely shaky extension. https://imgur.com/ZlYHXqG
Title: Re: Tektronix 455 with "squished" left-side trace
Post by: George Edmonds on October 21, 2020, 07:05:37 am
Hi

As with anything Tektronix of the age of a 455 check the power supplies for correct voltage and ripple, the main smoothing electrolytic capacitors have probably failed by now.

George G6HIG Dover UK
Title: Re: Tektronix 455 with "squished" left-side trace
Post by: jker on October 21, 2020, 08:06:49 am
Quote
As with anything Tektronix of the age of a 455 check the power supplies for correct voltage and ripple...

If this is the 32V/GND/+5V/-5V test points on either side, those seem to be very close to on target. I'm not entirely sure what tolerance I should be looking for here, but they're all fairly close.
Title: Re: Tektronix 455 with "squished" left-side trace
Post by: George Edmonds on October 21, 2020, 10:32:48 am
Hi

There is a +95VDC supply that is used for the horizontal deflection amps, or you have a failure in the horizontal deflection amplifier.

At least this is a good starting point.

George G6HIG
Title: Re: Tektronix 455 with "squished" left-side trace
Post by: pbarton on October 21, 2020, 03:07:21 pm
If the scope has been dropped or bumped then the CRT internal X plate(s) may have moved. If that's the problem, the only solution is a replacement CRT.
Title: Re: Tektronix 455 with "squished" left-side trace
Post by: MarkL on October 21, 2020, 04:00:15 pm
An easy way to check the CRT for mechanical damage is to swap the leads for (in this case) the horizontal plates.  These are two single-pin connectors on the neck of the CRT.  Be very gentle with them since the pins are fused to the glass at the base.

The trace will then be mirrored horizontally.  If the "squished" problem stays on the left, the CRT is at fault.  If it moves to the right, something is wrong with the horizontal drive.

The trace looks bizarre enough that it could be mechanical damage, but not conclusively.
Title: Re: Tektronix 455 with "squished" left-side trace
Post by: jker on November 11, 2020, 05:44:29 am
There is a +95VDC supply that is used for the horizontal deflection amps, or you have a failure in the horizontal deflection amplifier.

At least this is a good starting point.

Sorry that took so long, mad dash on some outdoor projects as the weather turned bad.

In any case, measuring this 95V test point at first shows 69V. It very slowly rises to 71 or so after 5-10min. This seems likely to be an issue.
Title: Re: Tektronix 455 with "squished" left-side trace
Post by: Shiv on November 11, 2020, 12:08:08 pm
There is a +95VDC supply that is used for the horizontal deflection amps, or you have a failure in the horizontal deflection amplifier.

At least this is a good starting point.

Sorry that took so long, mad dash on some outdoor projects as the weather turned bad.

In any case, measuring this 95V test point at first shows 69V. It very slowly rises to 71 or so after 5-10min. This seems likely to be an issue.

Wow, It´s almost like my old one (Tek 468) I had to change caps years ago...


The 95V test point should have it +/-2V with less than 1V ripple.
If is that, should be easy (If you find appropiate capacitors)

According to manual, +95V are unregulated.

From tranf T550 coil, passes through CR582, filtered with 2.2uF(C582) and 2uf(C584) in paralell with L582 coil in the middle.

http://bama.edebris.com/download/tek/455/Tektronix%20455_svc.pdf (http://bama.edebris.com/download/tek/455/Tektronix%20455_svc.pdf)  (P 181)

I bet is one (or both) capacitor leaking.

+95 is used for blanking and horizontal so I think it should be all.
Takes sense that it is faultyer in slow rates (just when capacitors have more job to do)

If it works, Ill send you my paypal ;)