Author Topic: Tektronix TDS754D - acquisition board test fail  (Read 7929 times)

0 Members and 1 Guest are viewing this topic.

Offline RaxTopic starter

  • Frequent Contributor
  • **
  • Posts: 965
  • Country: us
Re: Tektronix TDS754D - acquisition board test fail
« Reply #25 on: May 20, 2024, 02:30:09 am »
BTW - not to jinx it, but I feel stronger and stronger that replacing those four SRAMs was called for, because there seems to be just one error now and those RAMs don't pop in there at all anymore.
 

Offline TERRA Operative

  • Super Contributor
  • ***
  • Posts: 2977
  • Country: jp
  • Voider of warranties
    • Near Far Media Youtube
Re: Tektronix TDS754D - acquisition board test fail
« Reply #26 on: May 20, 2024, 02:56:10 am »
Yeah, looks like you had a few errors to deal with, at least you are making progress!

I'll have a search and think about your current error. My feeling is to either track down that address to a RAM chip and replace it as well (if not already done) or figure out what is controlling that RAM chip and stare intently at that.
I'd expect that if it was the chip passing the data to the RAM chips, it would be a periodic error across multiple chips rather than just one RAM chip in that case due to how the RAM is written to with bank switching etc.

One way to find the right RAM chip is to ground/apply 5V (have to double check which one) to the WE (Write Enable) pin one chip at a time and see what errors are thrown on self test due to that chip not being enabled to be written to.
If you get new errors on the same address range as your latest error, you found the chip.
Where does all this test equipment keep coming from?!?

https://www.youtube.com/NearFarMedia/
 

Offline RaxTopic starter

  • Frequent Contributor
  • **
  • Posts: 965
  • Country: us
Re: Tektronix TDS754D - acquisition board test fail
« Reply #27 on: May 20, 2024, 03:24:19 am »
After running SPC, I got:

"SUN MAY 19 20:07:47 2024  ERROR: Internal adjustment range exceeded, ( 3 @   7464): DIGc gain = -0.400113, bal = 1.113079"

Bad news?...  :-\
 

Offline TERRA Operative

  • Super Contributor
  • ***
  • Posts: 2977
  • Country: jp
  • Voider of warranties
    • Near Far Media Youtube
Re: Tektronix TDS754D - acquisition board test fail
« Reply #28 on: May 20, 2024, 05:43:45 am »
oooeerrrr.... Either bad cal (unlikely) or something is bad on that channel. Maybe as simple as a bad relay on the hybrid. It's not too hard to swap hybrids between channels, just need to be extra careful not to crack the ceramic PCB.
Relays aren't toooo difficult to replace, I have a video on Youtube about it.
youtube.com/watch?v=b0P1sJBomDQ

Is that the only error after clearing via GPIB?
Can you run SPC maybe 5 or 6 times to exercise the relays, then clear all errors, self test and SPC once more and list the entire error log here?
Where does all this test equipment keep coming from?!?

https://www.youtube.com/NearFarMedia/
 

Offline RaxTopic starter

  • Frequent Contributor
  • **
  • Posts: 965
  • Country: us
Re: Tektronix TDS754D - acquisition board test fail
« Reply #29 on: May 21, 2024, 11:22:05 am »
something is bad on that channel.
Would that be CH3? The error body is a bit cryptic to me.

Is that the only error after clearing via GPIB?
Those two errors above, yes. The second error occurs if I run SPC.

Can you run SPC maybe 5 or 6 times to exercise the relays, then clear all errors, self test and SPC once more and list the entire error log here?
Been doing a few of those, and the error seems pretty persistent.

I should also say, I don't feel there's anything very specifically wrong going on with CH3 - if that's the one found faulty by SPC. If anything, CH4 seems a bit choppier and there's a bit more freezing and vertical bars "noise." But they all work pretty well, their measurements are accurate as much as my other meters think. It just fails tests. Oh, and DPO mode doesn't work very well - there's a good amount of "video noise" - color pixelation ("snow") on the screen when that's enabled.
 

Offline TERRA Operative

  • Super Contributor
  • ***
  • Posts: 2977
  • Country: jp
  • Voider of warranties
    • Near Far Media Youtube
Re: Tektronix TDS754D - acquisition board test fail
« Reply #30 on: May 21, 2024, 12:11:20 pm »
I think the firmware sees the chanel numbering as 0 indexed, i.e. 0, 1, 2, 3 corresponds to physical channels 1, 2, 3, 4. So I would look for problems on channel 4

Try swapping the channel 1 and channel 4 hybrid (don't forget the thermal paste on the chip on the hybrid module!) and see what happens.
I keep saying it and will say it again.... Be careful with the hybrids, and make sure they are perfectly seated in the metal holder before screwing it to the PCB! :)

Easy tests are easy, so may as well rule out bad relays or bad hybrid module.
Where does all this test equipment keep coming from?!?

https://www.youtube.com/NearFarMedia/
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf