Author Topic: Tripplite 2200RMXL2U, functional, but clicking relay.  (Read 740 times)

0 Members and 1 Guest are viewing this topic.

Offline electronics-whiz

  • Regular Contributor
  • *
  • Posts: 73
Tripplite 2200RMXL2U, functional, but clicking relay.
« on: June 26, 2016, 04:43:24 am »
I got this old UPS from my work, we had 2 of this model with bad batteries, we ordered one new pack to see if we could get one of them running. This one was questionable but tried it even with full charge this is wat it does and not sure why. If you plug it in it's fine, unplug it with good full battery it goes to UPS mode so that's good. But when you go to unplug it and shut it down it will not shut down and what sounds like a relay will not stop clicking until the battery power is cut to it.

I did open it up to look for visual damage, smell of burnt electronics. Got nothing but I did notice this: They used some relays in it that appear to be for load transfer or controlling the outputs. They have large spade terminals on the top of these relays with connections to the transformer and the outlets. I did notice one white wire was turned a light shade of brown like it got hot. I checked all the internal connections and that spade connector to that relay was loos, I squezed it down some with a pliers to try and fix that which helped, but it still clicks.

I'm not sure if maybe it got hit by a surge, the heating of the wire somehow damaged that relay, or if there is some other issue. Part of me would like to fix this as it seems to be a fairly nice UPS unit. However, I also don't know if I should be trusting something like this not to go up in flames one day. It could be nice for a home rack or lab, but that is not critical either so UPS is not a huge deal. Maybe could turn into a power inverter, but still not sure i'd trust it for that.

Any ideas or suggestions what I should do with this thing? thanks.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf