Electronics > Repair

Unable to access UART in WAP300N

(1/13) > >>

poncho7788:
I have a Linksys WAP300N access point that has been bricked just by changing the configuration to work in 5GHz. Apparently this is a known issue for a specific firmware version (https://community.linksys.com/t5/Access-Points/WAP300N-becomes-unresponsive-after-switch-to-5GHz/td-p/692471/page/5). As the device is out of warranty, the vendor does not provide any solution.
I would like to try to access the console of the device to check if there is any possibility of recovery, so I opened it and found what could be 4 UART pins in the PCB (see image).

I have used a multimeter to try to identify the pins with the following results:
Pin 1 (leftmost, the squared one), gives consistently a measure of 3.3v so it will probably be the Vcc
Pin 2 gives 0v so GND
Pin 3, gives a measure of about 3.29v for 25 seconds after the device is switched on, then drops to 1.01v
Pin 4, is always close to 0 (0.10v)

I thin that Pin 3 could be Tx giving some information during the boot sequence, but I have not been able to extract any information. The serial connection using a USB adaptor does not provide any data (nor even garbage), I have tried with the typical serial speeds.
I have also used a logical analyzer, but without results. I am stuck here, but I would like to keep trying, so any suggestion would be appreciated.

LateLesley:
Can you take a picture, showing where the traces go? sometimes they lead to empty pads, which need resistors fitted before it'll communicate. I think they may be pull up resistors, but may be wrong. Sometimes they are in line with the signal, so probably protection of some sort.

tsman:
What USB adapter did you use?

The two empty resistor pads nearby, are they connected to your UART header?

poncho7788:
Thank you for your answers.

The traces from the suspected Tx and Rx pin seem to go to a bunch of pads (some used, some empty) with labels R375 and R120 (see picture). As you would have already imagined, I dont know a lot about this, could you please provide more info about why the pullups would be required?

I have used an Arduino UNO as explained in https://forum.arduino.cc/index.php?topic=138832.0 with a terminal emulator in my PC. Nothing. I have also connected directly the pins to the Tx and Rx of the Arduino getting always the same value (equivalent to a constant voltage I guess).

LateLesley:
Many digital signal lines, work by pulling a line low via a transistor. Some chips have internal pull up resistors, but some require you to fit the resistor externally. I learned recently that it actually can take up a lot of die space on ICs to have internal resistors, so the chances are that ICs with more complex functions will use this space for it's different functions, and expect the circuit builder to fit external pull up resistors. For logic high signals, the voltage needs to come from somewhere! :-)

Anyway, I'm finding it quite hard from the picture to figure out where those tracks go, unfortunately the silkscreen seems to be hiding it a little, and they also seem to disappear into via's. Thats making it hard to see where they go. Sometimes they have pull ups, sometimes they have in-line resistors (I think for protection or current limiting. ) Untill we tell what type of resistors (or empty pads in this case) those lines are connected to, it's hard to give you a value to try. But a rough standard for pull up would be 10K, and in line maybe 1K. that would be 104 and 103 marked SMD resistors respectively.

I tried to find a datasheet to give us a clue, but I was unsuccessful in finding one.

Edit : I did find a datasheet for a Ralink RT3050, and it does seem on that at least that the uart wouldn't need a pullup. They also seem to be 5V tolerant, so I don't see the need for pull up resistors. SO it may have in line resistors, just to stop folk like us tapping into production models.

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version