Author Topic: unusual computer motherboard issue.  (Read 1116 times)

0 Members and 1 Guest are viewing this topic.

Offline lilshawn

  • Regular Contributor
  • *
  • Posts: 62
  • Country: ca
  • I break stuff...then fix it...sometimes
unusual computer motherboard issue.
« on: September 29, 2021, 06:19:22 pm »
I have a NLA, unsupported, custom industrial motherboard with a bit of an odd issue. I'm not really sure where to start diagnosing it. it is a MX280NI.


it's set in the bios to "on AC loss", to power on... so you can use the main AC power switch to power on and off the system.  For some reason, after 4 years, it has now stopped doing this. for whatever reason it has randomly decided to not power on when the power switch is applied. the power comes on, the computer appears to start the BIOS to start the POST, does the POST beep and it immediately powers off. if i jumper the power switch header, it powers on and operates normally.

I've reset the BIOS defaults and set the appropriate option to have it power on.. it just doesn't do it. Motherboard has new BIOS battery. but it still wouldn't power on like it's supposed to. I decided that I would program a microcontroller to wait a few seconds (for the computer to fail it's initial poweron) and then "press" the power button. this got it going in the interim.

this worked for a while... then just as randomly as it stopped powering on... it started up on it's own again just like its supposed to. (problem was, my microcontroller would then power off the computer) So i disabled the microcontroller, powered on the board, had it boot up, and everything was good for about 30-45 minutes... then it just blanked out and shut off. jumpering the power header powered it back on again.

the computer powers on normally by itself about 20% of the time. so i've managed to confirm that when the computer powers itself on, the computer will eventually shut off after about half an hour to an hour of running. when the power button is actuated (or my "defibrillator" microcontroller turns it on) it will stay on an indefinite amount of time. thermals are good so it's not powering off due to anything i can tell, other than just giving up and not wanting to stay on any longer.

so it seems whatever the bios is using to turn on and keep on the computer when the on AC restore setting is set to on....and whatever the power switch header connection are using to turn on and keep on the computer...are 2 different systems?

short of disabling the on AC restore function and keeping my "power on defibrillator" microcontroller as the primary means of powering on the system...what could possibly be the issue? I'd like a not so hackey poweron but if that's what it is going to take that's what it is then.

does suspicion about the 2 separate systems hold any truth?
 

Offline jmelson

  • Super Contributor
  • ***
  • Posts: 2294
  • Country: us
Re: unusual computer motherboard issue.
« Reply #1 on: September 29, 2021, 10:16:06 pm »
I think you need a new power supply.  PC power supplies are getting more complicated, with microcontrollers in them to manage power on/off and self-test.  And, you can get all sorts of flaky results if the standby supply is bad.
Jon
 

Offline lilshawn

  • Regular Contributor
  • *
  • Posts: 62
  • Country: ca
  • I break stuff...then fix it...sometimes
Re: unusual computer motherboard issue.
« Reply #2 on: September 30, 2021, 02:08:51 am »
this motherboard simply takes 12v in and has DC-DC converters in it to create it's own rails. if a rail was going funky, I'd think it would act more inconsistent in how it behaves.

as it stands, manually powering it on with the power button, the motherboard operates 100% of the time.

having the PC auto power on with the bios setting "on AC loss" set to ON... (and when it does power on) fails 100% of the time. (eventually)

it's weird.
 

Offline amyk

  • Super Contributor
  • ***
  • Posts: 7697
Re: unusual computer motherboard issue.
« Reply #3 on: September 30, 2021, 03:11:57 am »
This one? https://www.bcmcom.com/bcm_product_MX280NI.html

The chipset datasheet is here: https://datasheet.octopart.com/CG82NM10-S-LGXX-Intel-datasheet-76215416.pdf
Section 5.14 contains the details of this functionality, specifically 5.14.7.5.

In particular: "Pressing the PWRBTN# Signal for more than 4 seconds to cause a Power Button
Override event."...which turns the system (soft-)off immediately.

Quote
the power comes on, the computer appears to start the BIOS to start the POST, does the POST beep and it immediately powers off.
Does it take almost exactly 4 seconds when it decides to do that? If so, I suspect what's happening is that the power button is "stuck down", so that when A/C power is restored, the chipset correctly powers up based on the configuration (see the text about "AFTER_G3" in the datasheet) and begins to boot, but then due to the stuck power button, goes into soft-off after 4s.
 

Offline PKTKS

  • Super Contributor
  • ***
  • Posts: 1423
  • Country: br
Re: unusual computer motherboard issue.
« Reply #4 on: September 30, 2021, 08:00:49 am »
Worth nothing to mention i have seen similar symptoms with PSU having aged bad caps with very high ripple when warmed up...

They look and behave normal cold and start the funky dance when warm

Paul
 

Offline jmelson

  • Super Contributor
  • ***
  • Posts: 2294
  • Country: us
Re: unusual computer motherboard issue.
« Reply #5 on: October 01, 2021, 01:33:28 am »
this motherboard simply takes 12v in and has DC-DC converters in it to create it's own rails. if a rail was going funky, I'd think it would act more inconsistent in how it behaves.
Ugh, that makes isolating the issue WAY harder!
Jon
 

Offline David Hess

  • Super Contributor
  • ***
  • Posts: 14103
  • Country: us
  • DavidH
Re: unusual computer motherboard issue.
« Reply #6 on: October 02, 2021, 06:41:53 pm »
I was also going to suggest the power supply.  I have seen exactly that problem caused by worn out ATX power supply capacitors.

I would hook something, like a digital storage oscilloscope, to the "power good" signal if you can find it and monitor it.  That will indicate if the power supply is resetting the computer.  Set the DSO to a single shot normal mode trigger so that you do not have to sit there and watch it.
 

Offline amwales

  • Regular Contributor
  • *
  • Posts: 61
  • Country: gb
Re: unusual computer motherboard issue.
« Reply #7 on: October 02, 2021, 07:53:23 pm »
Have you tried disconnecting the case power switch and using a different one, its simple to try?
I've seen someone experience similar frustrations, replacing the power supply, removing all
connected devices nothing solved the strange behaviour.
Finally swapped the case and problems went away.
 

Offline lilshawn

  • Regular Contributor
  • *
  • Posts: 62
  • Country: ca
  • I break stuff...then fix it...sometimes
Re: unusual computer motherboard issue.
« Reply #8 on: October 18, 2021, 04:02:24 pm »
sorry for going dark. been busy with other things.... some updates...

@amyk, yes thats the one.

@amwales the computer does not actually have a power switch. instead solely relying on the on ac restore to power on the computer. which is fine, the board i made can power it on no problem.

the software on the hard drive is doing something in the BIOS settings and i'm kind of confused about it.

there is definitely something dickey going on between the bios settings, and the software on the harddrive that loads. perhaps someone can shed some light on it...

if i pull the harddrive and battery... and reset the CMOS settings, it comes up on poweron (manually with power button header connection) asking me to reset the date and time etc. yes, i do this and set it.

BUT... after i have done that, saved the settings and rebooted the board, it still displays a mesage that the date and time are incorrect and prompts to enter the BIOS to fix it or press F1 to cotinue. in the bios, it has the correct date and time etc. no amount of rebooting or saving or resetting eliminates the message.

BUUUUUUUT if i install the harddrive and allow the system to boot (press F1 to continue past the prompt)... it boots and then when powered off no longer displays the message... and the software somehow has the ability to change the BIOS settings, because despite it being disabled in the bios, it has (after there was a software update) reenabled the ac loss power on value back to on (it says off in the bios settings, but it now still tries to startup (which it does if i disable my poweron board... but not keep the computer going properly as mentioned before)

seems like there is an alternative section of bios settings the harddrive software has access to that despite what any settings in the bios has, overrides and the computer uses.

does this make sense? this board is making me crazy! it defies all standard computer logic.
 

Offline perieanuo

  • Frequent Contributor
  • **
  • Posts: 837
  • Country: fr
Re: unusual computer motherboard issue.
« Reply #9 on: October 19, 2021, 08:04:13 am »
sorry for going dark. been busy with other things.... some updates...

@amyk, yes thats the one.

@amwales the computer does not actually have a power switch. instead solely relying on the on ac restore to power on the computer. which is fine, the board i made can power it on no problem.

the software on the hard drive is doing something in the BIOS settings and i'm kind of confused about it.

there is definitely something dickey going on between the bios settings, and the software on the harddrive that loads. perhaps someone can shed some light on it...

if i pull the harddrive and battery... and reset the CMOS settings, it comes up on poweron (manually with power button header connection) asking me to reset the date and time etc. yes, i do this and set it.

BUT... after i have done that, saved the settings and rebooted the board, it still displays a mesage that the date and time are incorrect and prompts to enter the BIOS to fix it or press F1 to cotinue. in the bios, it has the correct date and time etc. no amount of rebooting or saving or resetting eliminates the message.

BUUUUUUUT if i install the harddrive and allow the system to boot (press F1 to continue past the prompt)... it boots and then when powered off no longer displays the message... and the software somehow has the ability to change the BIOS settings, because despite it being disabled in the bios, it has (after there was a software update) reenabled the ac loss power on value back to on (it says off in the bios settings, but it now still tries to startup (which it does if i disable my poweron board... but not keep the computer going properly as mentioned before)

seems like there is an alternative section of bios settings the harddrive software has access to that despite what any settings in the bios has, overrides and the computer uses.

does this make sense? this board is making me crazy! it defies all standard computer logic.
hi,
in first post you said this:
Quote
I decided that I would program a microcontroller to wait a few seconds (for the computer to fail it's initial poweron) and then "press" the power button. this got it going in the interim.
then you say the computer doesn't have a power switch.
so with your microcontroller board you delay what? the power mains line (delayed regarding to what???), the powerswhitch that doesn't exist?
i bothered to open the manual of that mobo https://www.bcmcom.com/admin/manual/MX280NI_Users_Manual_V1.0.pdf ,page 17, surprise you have a linePWRBTN# in System Panel Header.
powering directly all the voltage rails imho is suicide for that mobo's life expectancy, so just connect 2 wires and a button and start from this. you won't pay a fortune for standby consumption, especially if it's industry and that generates revenue.
what can you do, start with the basics, try to update bios, ask them for this. if they don't give you the bios, re-writing should be no big deal removing the flash with some external programmer, finding the .bin is the hard task.
as some people here said, have you tried another ps? everybody does this when a pc make funny bussiness, for you it's easy you got only one voltage to apply and 19V adapters are common, i saw the mobo acepts also less ("9-19V DC in").
leave the hdd removed when testing, mobo's are tested with processor+memory+live OS, i prefer linux-ones. your choice on OS.
i suggested bios update because the mobo should remember date/time with bios cmos battery changed, here you touched the sensitive point
also i see at/atx jumper, try change this to AT
so reload your gear with this configs and maybe something comes out
[edit] maybe you have one bios copy on the CD they mention comming with the mobo
« Last Edit: October 19, 2021, 08:27:08 am by perieanuo »
 

Offline amyk

  • Super Contributor
  • ***
  • Posts: 7697
Re: unusual computer motherboard issue.
« Reply #10 on: October 19, 2021, 01:42:53 pm »
Dump the CMOS RAM and compare. You may have an unusual issue but this is by no means an unusual/rare chipset. NM10 was used in plenty of computers when it was new.
 

Offline lilshawn

  • Regular Contributor
  • *
  • Posts: 62
  • Country: ca
  • I break stuff...then fix it...sometimes
Re: unusual computer motherboard issue.
« Reply #11 on: October 19, 2021, 02:48:15 pm »
@perieanuo - sorry, I should have clarified. typically this board is powered by an external 12v power supply. (actually a power supply that supplies 12v and 24v.) the AC power switch simply powers on the external power supply, that in turn powers the computer board, which in turn (when it works) turns on due to the BIOS setting on AC power loss which would be set to on.

when the computer stopped powering on automatically, as it should, I programed a microcontroller to wait until the computer did it's initial power on and subsequently fail... supply a low signal to the PWRBTN front panel header (normally unoccupied) to power on the board.

except it seems to randomly automatically power on as it should, but doesn't stay powered on when it does.
when forced on with the PWRBTN header, it runs and operates just fine.

if it weren't for it randomly working and "properly" powering on like it should, i would just stick with the microcontroller turn on.

I've checked the power supply for ripple and low voltages, but everything is tip top...and can confirm that his issue is isolated to the motherboard itself, as this is a known issue with these boards. (we have had 4 other replaced by the company under warranty but his system is no longer available to us and the service depot refuses to work on them.)

@amyk - I am in contact with the first party company who supplied the system to see if i can get a known good copy of the flash, as it's a customized firmware for that company (boot logos etc) and it wouldn't match with the bone stock MX280 firmware as supplied by BCM anyway. i'm tempted to just flash stock firmware to the BIOS, but i suspect the software may no longer work...this company has a tendency to do stuff like that. i have another computer form this company that will not boot with anything but a western digital brand harddrive installed. all other drives (and even no drive) say that an unauthorized harddrive is installed... and this is in the BIOS before it's even booted.
 

Offline amyk

  • Super Contributor
  • ***
  • Posts: 7697
Re: unusual computer motherboard issue.
« Reply #12 on: October 20, 2021, 12:31:05 am »
I'm still of the opinion that this is a hardware, not software, fault. I'd measure the voltages on the power button pins and see if something is somehow activating it randomly. If a pullup/pulldown is bad, you can see this sort of behaviour.
 

Offline perieanuo

  • Frequent Contributor
  • **
  • Posts: 837
  • Country: fr
Re: unusual computer motherboard issue.
« Reply #13 on: October 20, 2021, 04:33:51 pm »
ok, it's clear now
so maybe you don't need a micro to start this when 12Vdc comes in, maybe just a big capacitor will do. finally, until you find the fault, this will be the same as your existing delayed powerbtn solution
try to rewrite the bios, i saw they offered some bios updates at the time, maybe try some alternative bios if you can write the bios in external programmer to be safe (saving this existing one first)
bon courage
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf