Author Topic: Voltcraft dso-1102D  (Read 837 times)

0 Members and 1 Guest are viewing this topic.

Offline Dmitrij90

  • Newbie
  • Posts: 1
Voltcraft dso-1102D
« on: October 04, 2018, 08:58:57 pm »
Hello, for all I'm new in forum,my name is Dmitrij I live in Germany. So I looking for some help, I new in electronic end I buyed a scope from ebay ....... its stucked on boot,  but I don't looked in discription when I buyed (yes know stupid thing to do so)  so long story  short is it possible to update firmware with jlink?  I have some experience with segger jlink (updated automotive tester)  but this is new to me, I disassembled the scope end I see  2 jtag connection points one labeled "J901" another "J701"  end third "J700"  so my question is how can I connect to this device end how to update the firmware? End also my question is can it be repaired or its not a firmware issue? What can make scope to stuck on boot screen ( just voltcraft logo end not changing)  On board I have number t1218539 if its meaning something.  (End I see on board that somebody tryed to solder on board, the connector jtag on back is also soldered) Thanks for any help.
« Last Edit: October 04, 2018, 11:37:48 pm by Dmitrij90 »
 

Offline Corlumbus

  • Newbie
  • Posts: 2
  • Country: ch
  • Country: ch
Re: Voltcraft dso-1102D
« Reply #1 on: December 12, 2018, 04:14:16 pm »
Hello
this is exactly my problem:
After trying to update the firmware of my Voltcraft DSO 1102D (sn T1218563), it is stuck at the boot screen.
When I opened the Scope to attach my USB2serialTTL cabel to fix the problem, I realized that the board layout changed and all the hints in this forum do not work anymore, because there is no visible place to connect the RXD/TXD cables... (see the attachment by Dmitrij90)

If somebody with knowledge of this machine could give instructions where to attach the serial interface, I would be very grateful!

Thanx in advance!
 

Offline PeDre

  • Regular Contributor
  • *
  • Posts: 71
  • Country: at
  • Country: at
Re: Voltcraft dso-1102D
« Reply #2 on: December 12, 2018, 06:05:15 pm »
Hello Corlumbus,

maybe the link will help you:
https://www.mikrocontroller.net/topic/205820?page=single#4209717
 

Offline Corlumbus

  • Newbie
  • Posts: 2
  • Country: ch
  • Country: ch
Re: Voltcraft dso-1102D - solved!
« Reply #3 on: December 13, 2018, 05:06:34 pm »
Hello
after days of searching and trying I finally solved my problem with my Voltcraft ds0-1102D oscilloscop!

I found a lot of useful information on this forum and want to share my solution to contribute to this valuable source of knowledge:

The problem started with an attempt to upgrade the firmware with a file downloaded from http://voltcraftdownload.info/Default.aspx?modelno=DSO-1102D (DO NOT USE THIS!)

After the Update, the scope would only display the boot screen and be stuck there.

my Solution:
-) download firmware from Hantek:
http://www.hantek.com/en/ProductDetail_3.html

DSO5102B for DSO1102D
DSO5202B for DSO1202D
DSO5062B for DSO1062D


-) unzip DSO5102B_Firmware.zip
     -> dso5kb_func_dso5102b20180226.up

-) decrypt:
gpg -o dso5102B.tar.gz -d dso5kb_func_dso5102b20180226.up

(password  dso5000b)

(some errors and warnings seem not to matter...)

-) gunzip dso5102B.tar.gz
     ->  dso5102B.tar

-) tar -xvf dso5102B.tar
    -> dso5kb_func_dso5202b20180228.up.tar   (seems to be the same for dso1102D and dso1202D)

-) tar -xvf dso5kb_func_dso5202b20180228.up.tar
->  tekwayup_client (directory) und upend (text file)



-)copy the tekwayup_client directory to a USB stick

-) connect Oszilloskop per Serial TTL to your computer.

-) start your serial terminal programm (putty 115200B, 8n1)

-) switch on the oscilloscop (don't touch the power supply!)

(following commands should run on the scope)

copy the directory tekwayup_client to /tmp/ :

-) cp -R /mnt/udisk/tekway_client /tmp

-) chmod 777 /tmp/tekwayup_client/packet/do_update.sh

run the update:
-) /tmp/tekwayup_client/packet/do_update.sh


-) sync

-) sync


... and your scope should be fine again!
« Last Edit: December 13, 2018, 05:28:36 pm by Corlumbus »
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf