EEVblog Electronics Community Forum

Electronics => Repair => Topic started by: ez24 on May 20, 2015, 03:16:02 am

Title: Wavetek 145 bad square wave at high freqs
Post by: ez24 on May 20, 2015, 03:16:02 am
Hi

Here is what the square wave looks like at 2 MHz, 10 and 20 MHz.  At 20 it is no way a square wave.

The switches and pots seem ok.  Has anyone had this problem?  I thought I would ask before I open it.  I have the manual and the first thing to do will be to look for bad components then check and adjust voltages.  I hope someone had and remember the fix for this.

thanks


Title: Re: Wavetek 145 bad square wave at high freqs
Post by: Richard Crowley on May 20, 2015, 03:32:34 am
Are you sure your oscilloscope properly displays a 20MHz square wave as "square"?
Yes, it is rated for 50 MHz, but how do you know the generator isn't good, and the scope broken?
It wouldn't be the first time the test equipment or methodology gave a false impression.
Title: Re: Wavetek 145 bad square wave at high freqs
Post by: miguelvp on May 20, 2015, 03:38:39 am
If you look at the specs of the wavetek 145, rise time is under 20ns rise time, also the signal is 50 ohms terminated and it looks like you are just plugging it directly to your scope without a 50 ohm terminator.

Edit, and it seems you are also using probes to measure the signal, the ground lead is going to do a lot of ringing that way.

(https://www.eevblog.com/forum/repair/wavetek-145-bad-square-wave-at-high-freqs/?action=dlattach;attach=152901;image)

You need a BNC T connector and a 50 ohm terminator, not that it's going to make the rise time faster on the wavetek.

Edit: green terminators in this setting are 50 ohms, purple one is 75 ohms (for VGA signal)
(https://www.eevblog.com/forum/beginners/converting-15khz-analog-rgb-to-digital/?action=dlattach;attach=99968;image)
Title: Re: Wavetek 145 bad square wave at high freqs
Post by: tautech on May 20, 2015, 03:51:49 am
Best you study this thread:
https://www.eevblog.com/forum/testgear/show-us-your-square-wave/ (https://www.eevblog.com/forum/testgear/show-us-your-square-wave/)

You'll see many squarewave generators that when max'ed out don't produce a "perfect" squarewave,
Quite normal.  :=\
Title: Re: Wavetek 145 bad square wave at high freqs
Post by: miguelvp on May 20, 2015, 03:56:03 am
Also if you need the full manual:

http://bama.edebris.com/manuals/wavetek/145/ (http://bama.edebris.com/manuals/wavetek/145/)
Title: Re: Wavetek 145 bad square wave at high freqs
Post by: dom0 on May 20, 2015, 10:31:45 am
20 ns specified rise time pretty much says that the 20 MHz square wave will be more like a sine.
Title: Re: Wavetek 145 bad square wave at high freqs
Post by: ez24 on May 20, 2015, 05:38:37 pm
Quote
20 ns specified rise time pretty much says that the 20 MHz square wave will be more like a sine.

I can get my head around this number and will sketch this all out.

I am going to order some 50 ohm adapters today.  It seems there is no need to open up the Wavetek  :clap:

thanks everyone
Title: Re: Wavetek 145 bad square wave at high freqs
Post by: Grapsus on May 20, 2015, 06:16:30 pm
The two meg screenshot definitely shows ringing, so it's a termination problem. If you don't have terminators, you can take any BNC connector and solder a 50 Ohms (or 47) resistor to it with as short legs as possible. It won't be as good at super high frequencies but for two megs it will surely improve your situation.

However on the other screenshots the traces look rounder so it has more to do with a bandwidth limitation somewhere.

Edit: also be careful with the amplitude, 15 Vpp into 50 Ohms is not a negligible amount of power.
Title: Re: Wavetek 145 bad square wave at high freqs
Post by: dom0 on May 20, 2015, 07:07:26 pm
The two meg screenshot definitely shows ringing, so it's a termination problem

Not necessarily ; some generators just don't produce a clean square wave as others.
Title: Re: Wavetek 145 bad square wave at high freqs
Post by: TimFox on May 20, 2015, 09:42:36 pm
Quote
20 ns specified rise time pretty much says that the 20 MHz square wave will be more like a sine.

I can get my head around this number and will sketch this all out.

I am going to order some 50 ohm adapters today.  It seems there is no need to open up the Wavetek  :clap:

thanks everyone
Numbers:  20 MHz square wave = 50 ns period = 25 ns "mark" + 25 ns "space".  20 ns rise time and fall time will take up almost all of the half-period.
Title: Re: Wavetek 145 bad square wave at high freqs
Post by: grumpydoc on May 20, 2015, 10:09:27 pm
Even if the square wave were perfect a 50MHz scope would have difficulty with a 20 MHz square wave.

The first term in the Fourier series is the 3rd harmonic at 60MHz - that will probably be OK but the next term is the 5th harmonic at 100MHz which is going to be way down given the DSO's input filter response.

A "square" wave with just one term looks like this: