Author Topic: XBox One S repair (Ebay project)  (Read 589 times)

0 Members and 1 Guest are viewing this topic.

Offline LiftedTrace

  • Regular Contributor
  • *
  • Posts: 52
  • Country: us
XBox One S repair (Ebay project)
« on: June 16, 2019, 10:22:04 pm »
Hi. I am a noob, leraning to swim in the deep end. I am looking for some help in my adventure trying to repair an xbox one s I got off ebay. I got it more for the fun of trying to repair it more than getting it to work. It was listed as having water damage, so I did what the standard is when you get anything....."Dont turn it on.....take it apartt".

I found right away that someone else had already had a go at this thing. There was a connector that looked really bodged and the board was shorted internally at that point. I have no clue if it was caused from the previous owner or what, but I dug out some of the burn to the point I had no more short. When I plug the mother board in now, I get a few virtually no current draw for about 1-2 seconds, then a few hundred mA draw for about a half a second, then back ti virtually nothing. It seems like something is maybe trying to start, and then shutting down.

I find many many posts of people having similar issue, the only difference they have that I dont is a speaker beep letting them know the board is powering up and then back down. I could not find any info online that talked about what may be going on when there is no feed back at all, so I thought I would ask the smartest group I know.....this forum.

I dont know much of what to tell you other than what I know.
The board takes 12v, and probing around the board I find 12volts present on all most all the power supplies. Where its missing is what I believe to be the power supply for the APU. When I press the power button, I see a voltage spike to 1v, and then off. I checked the mosfets and they are working and not shorted. I assume they are working because I see a short voltage spike and then off, so I can only assume they are getting triggered and then shut down again....which then makes me assume what ever is driving them is also working the way its supposed to. They are definitely not shorted.
I also have 5v, 3.3, 1.8v, and I believe another  present when power is plugged in.

The fact that the board makes no noise at all when the power button is pressed makes me thing there is something deeper wrong than I am able to repair. Other than a slight audible sound coming from the 5v power supply coil when you press the button, there is no user audible feedback like there should be.

Does anyone have any sort of experience on the basics of how these devices power up? Why there may be no beeps from the speaker, etc. Here is a pic of the front and back of the board.
Besides me possibly ....  :horse: .... I hope to learn alot from this adventure.
 

Online fzabkar

  • Frequent Contributor
  • **
  • Posts: 474
  • Country: au
Re: XBox One S repair (Ebay project)
« Reply #1 on: June 16, 2019, 11:10:45 pm »
The PCB has several onboard switchmode DC-DC converters. Each converter has a coil. I would start by locating all the coils and measuring the resistance between each of these and ground. This will tell you if the load on the corresponding converter is shorted to ground.
 

Offline LiftedTrace

  • Regular Contributor
  • *
  • Posts: 52
  • Country: us
Re: XBox One S repair (Ebay project)
« Reply #2 on: June 17, 2019, 12:07:46 am »
So most coils measured to ground up in the few k_ohms, The ones marked Red, Blue, Green were different. I wish I had a working one to compare normal.
The Green circle measured 2.6 Ohms to ground and is marked "NBCORE",
The Red circles measured from top to bottom, .8, .4, .4 Ohms and is marked "V_GFXCORE",
The Blue one measured 22.4 Ohms ans is marked "MEM10"

Update:
I decided to go ahead and remove all the Caps and Coils by the large chip, the ones circled in red.  Checking the plus side of the cap to ground after the caps and coils are removed I am reading .1 ohms on all but the bottom two where I read .5 ohms.
« Last Edit: June 17, 2019, 02:03:18 am by LiftedTrace »
 

Online fzabkar

  • Frequent Contributor
  • **
  • Posts: 474
  • Country: au
Re: XBox One S repair (Ebay project)
« Reply #3 on: June 17, 2019, 03:52:12 am »
Sorry, I don't know what resistances to expect when measuring the CPU and Northbridge cores. A value of 0.1 ohm for V_GFXCORE seems very low, but this chip draws a lot of power from a 1V (?) supply …

Perhaps you could use the core resistance of a PC motherboard CPU or GPU for comparison?

I notice three 5-pin chips at U3E1, U3F1, and U5D2. I wonder if these are LDO regulators (or load switches), in which case it might be worth measuring the resistances at their outputs.

FWIW, there are some Xbox 360 manuals and schematics here:

https://elektrotanya.com/showresult?what=xbox&kategoria=&kat2=all
https://elektrotanya.com/xbox_360_xenon_retail_rev_k7_fab_k_sch.pdf/download.html
« Last Edit: June 17, 2019, 04:39:58 am by fzabkar »
 

Offline Rasz

  • Super Contributor
  • ***
  • Posts: 2308
  • Country: 00
    • My random blog.
Re: XBox One S repair (Ebay project)
« Reply #4 on: June 17, 2019, 04:46:28 pm »
whats with the violet skidmark near hdd power connector?
also https://www.youtube.com/channel/UCfOrKQtC1tDfGf_fFVb8pYw/videos had a little ebay xbox fix adventure, didnt go as expected
Who logs in to gdm? Not I, said the duck.
My fireplace is on fire, but in all the wrong places.
 

Offline LiftedTrace

  • Regular Contributor
  • *
  • Posts: 52
  • Country: us
Re: XBox One S repair (Ebay project)
« Reply #5 on: June 17, 2019, 07:21:23 pm »
Quote
whats with the violet skidmark near hdd power connector?
Sadly this is not my “actual board” had it been “my” board you would have been like  :-DD
I just reposted a pic someone else had of theirs. Mine actually looks much worse.

I tried measuring the resistance to ground on a laptop cpu and nothing came close to .1 or .2 ohms.
So I don’t know if this is normal or not.  I suspect .1ish ohms is pretty much a dead short seen as when I short my probes together I get the same readings  :-DMM

Is it possible the apu could be shorted?
I did the old “let’s stick some voltage here and see what’s taking power”, and kept the current low, but noticed the board was taking as much as I was willing to give. I took it to 2 amps, and nothing but other than the apu was warming up. But then again, these guys are supposed to get mega hot, so again, I don’t now if that’s normal  :-DD
« Last Edit: June 17, 2019, 07:24:27 pm by LiftedTrace »
 

Online fzabkar

  • Frequent Contributor
  • **
  • Posts: 474
  • Country: au
Re: XBox One S repair (Ebay project)
« Reply #6 on: June 18, 2019, 03:39:09 am »
Is it possible the apu could be shorted?
That's the way it looks to me, although a photo of your actual PCB would help.

It might be interesting to see if all the other supply voltages come up and stay up, now that the core supply has been disconnected.
 

Offline LiftedTrace

  • Regular Contributor
  • *
  • Posts: 52
  • Country: us
Re: XBox One S repair (Ebay project)
« Reply #7 on: June 18, 2019, 03:07:31 pm »
I’ll give that a shot. Maybe I can at least get a beep out of the thing. Given my skill set and the fact it had water damage, I am not holding my breath for repairing it, but I can at least learn some trouble shooting skills an figure out why it’s not working.

I’ll post a pic of my board later tonight after I get a chance to power it up and see if it gets further with the apu disconnected.  from power.
 

Offline LiftedTrace

  • Regular Contributor
  • *
  • Posts: 52
  • Country: us
Re: XBox One S repair (Ebay project)
« Reply #8 on: June 20, 2019, 01:52:43 am »
So powering it up with the APu disconnected from the power rail gave same results.
That coil in the lower right is the 5v supply, and that happens to be the one that was shorted to ground before I dug the board out at the connector in the back of the board.
I still get 5v though so maybe what ever it’s feeding has Died.
 

Offline LiftedTrace

  • Regular Contributor
  • *
  • Posts: 52
  • Country: us
Re: XBox One S repair (Ebay project)
« Reply #9 on: June 20, 2019, 02:56:16 am »
I wish I would have taken a screen shot of my scope.
I was just probing around and found a fet that has some NASTY signal on it.
I looked at it and it’s surrounding caps, and noticed the corroded look at the pads of some caps.
So I hit them all with some flux and solder and rechecked the signal, and low and behold, I had a clean 12 volts where before I had filthy mc nasty and nowhere near12 volts.
So I think I learned a lesson today. I think I am going to have to touch up all the nasty looking joints.
My only fear is some of them nasty looking joints are under  the big chips, and I don’t have the capability to do that stuff.
So I guess I’ll spend some time hitting all the nasty looking ones first and see what I get.
If there are any others like that one I just fixed, I could see that causing issues.
It was the caps and the fet by the SATA connectors.
 

Offline LiftedTrace

  • Regular Contributor
  • *
  • Posts: 52
  • Country: us
Re: XBox One S repair (Ebay project)
« Reply #10 on: June 21, 2019, 05:03:46 pm »
Well if nothing else than having a good time, I believe I really did bite off more than I can chew. That water damage is truly a mean sucker. Looking over the board for any funky looking corrosion, I came across pics one and two. The first one had a cap on it, the second one was just gone. Maybe I can see from that other persons board what used to be there lol.
The first pic though, I was trying to trace back the track to a spot i could prove and see if it was making contact. It disappears into a via that goes nowhere. All I can guess it it’s traveling somewhere inside the board. The other side go right into the APU. So I decided to the cap off and see if it was connected under there. And the pic is what I found. If I have stuff like this throughout the board, it’s no wonder it don’t boot.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf