Author Topic: XENYX 1204FX crackling sound, missing left phones channel  (Read 5384 times)

0 Members and 1 Guest are viewing this topic.

Offline Derresh

  • Contributor
  • Posts: 22
XENYX 1204FX crackling sound, missing left phones channel
« on: December 21, 2014, 02:55:53 pm »
So... my mixer started to act up recently. Since i never had a go at repair of one i decided to ask first if someone had this issue before or has a idea what my problem is here.

http://www.behringer.com/EN/Products/1204FX.aspx

So i had two problems. One is that I am missing the left phones channel for monitoring (its there on the main and mon outputs). It sometimes did come back when i smacked the darn thing but it went dead and dose not want to come back anymore

Second problem is that the mixer started to develop a weird crackling distortion. Sounds like I would put on the volume to high, but it happens at any volume.

I do know my way around a soldering iron and test equipment, but i don't have that much experience with audio gear thats why the question. I do have schematics for the mixer, if anyone happens to have a service manual for that one that explains where test points or similar trouble shooting guidelines for that thing It would help a long way.

So I decided to fix this thing over the xmas break since i finally got some spare time on my hand. So any advice where to start looking for the problem ?
 

Offline stev.dk

  • Regular Contributor
  • *
  • Posts: 67
  • Country: dk
Re: XENYX 1204FX crackling sound, missing left phones channel
« Reply #1 on: December 21, 2014, 03:24:21 pm »
Do you have a scope?

That would help a lot. I once had a similar distortion problem with a guitar amplifier on the clean channel. It was a pull down (or pull up, i dont remember) resistor on the output transistor, that was broken (open circuit).

Did you check the mini-jack input for bad solder joints?
Crank it up till' everybody's ears are bleeding, then back off just a notch.
 

Offline janoc

  • Super Contributor
  • ***
  • Posts: 2978
  • Country: fr
Re: XENYX 1204FX crackling sound, missing left phones channel
« Reply #2 on: December 21, 2014, 04:04:23 pm »
The crackling and intermittent signal is a pretty much typical failure mode for the linear pots used in there. The pot is not sealed in any way or manner and gets gunked up over time. Cigarette smoke is an especially reliable killer here.

Try to open the mixer and clear the track of the pot with some alcohol. Also check whether the wiper has a good contact everywhere. In the worst case you may have to replace the pot.

If "smacking" the thing  :o has "fixed" the issue for a while, then check for bad/broken solder joints as well. Typical places are the ones that are under mechanical stress - connectors, pots, switches. That should be fairly easy to find visually.

The distortion problem could be a consequence of a bad contact above, so check that first. If it doesn't fix it, then you may want to check for failed capacitors.

 

Offline Derresh

  • Contributor
  • Posts: 22
Re: XENYX 1204FX crackling sound, missing left phones channel
« Reply #3 on: December 21, 2014, 04:37:06 pm »
I did suspect the lineral pots, since they are open form the top and my room is far form a clean room... but.

The Main out is clean, its only the monitor and headphone out that use a sealed one turn pot. I dont have a scope at hand, but I can borrow a rigol form a friend. Don't think he will need it that much for the holidays. For now thanks for the advice. I will start working on it in some free time and report if i got any progress. I did hear that the mixers are not the best durability so someone might find what i get out of this fix and troubleshooting as usefull
 

Offline janoc

  • Super Contributor
  • ***
  • Posts: 2978
  • Country: fr
Re: XENYX 1204FX crackling sound, missing left phones channel
« Reply #4 on: December 21, 2014, 05:49:32 pm »
The pot problems are common even with the most expensive studio gear, unfortunately. At least the old analog one. Pots simply do fail - dust, oxidation or the carbon layer simply wears out due to the wiper running over the same spot again and again.

Good luck trying to fix your mixer!

 

Offline Derresh

  • Contributor
  • Posts: 22
Re: XENYX 1204FX crackling sound, missing left phones channel
« Reply #5 on: December 21, 2014, 09:13:45 pm »
OK, scratch the crackling part, i got that fixed, tho... i have another problem of the missing left phones channel

So. I did check the pot, its ok,
I found out that this has a shared line for phones and control room output, the control room output works fine and the phones dont. I found some RC4580 in a very weird single line package, currently suspecting them to be dead. Since i have my headphones attacked to the control room output atm via a headphone amp I didin't have to fix that right now. I will continue this on tomorrow.

Thanks for all the tips so far

P.S.
Anyone has any idea where to get RC4580 in a single line package ? i can only find DIPs for it
 

Offline SL4P

  • Super Contributor
  • ***
  • Posts: 2103
  • Country: au
  • There's more value if you figure it out yourself!
Re: XENYX 1204FX crackling sound, missing left phones channel
« Reply #6 on: December 21, 2014, 10:20:41 pm »
Assuming the obvious - that you've tried a different set of 'cans...? (headphones)
Don't ask a question if you aren't willing to listen to the answer.
 

Offline Derresh

  • Contributor
  • Posts: 22
Re: XENYX 1204FX crackling sound, missing left phones channel
« Reply #7 on: December 21, 2014, 10:39:24 pm »
Yeh, i did check with 3 diffrent sets of headphones.

So... since the control room output is working and the only thing that is between that track and the headphones jack is two

http://www.coolaudio.com/docs/datasheet/V4580_DATASHEET.pdf

in a sip-8 package. I think its that, since its the only thing left to check I decided to order them (payed 5 usd for 5 of them with shipping)

So the only reason why i think it might have failed is that i did have a damaged cable ones on my head phones. Since I don't work with audio equipment that often, how likely is it for amp to die if the cable gets shorted ?
 

Offline SL4P

  • Super Contributor
  • ***
  • Posts: 2103
  • Country: au
  • There's more value if you figure it out yourself!
Re: XENYX 1204FX crackling sound, missing left phones channel
« Reply #8 on: December 21, 2014, 10:43:04 pm »
More likely a dry or broken solder joint / damaged track than 'partially' dead IC.
I suppose it could be a stressed pin on the IC, but in diminishing order.
Look at any connectors for surface corrosion too.
Don't ask a question if you aren't willing to listen to the answer.
 

Offline Derresh

  • Contributor
  • Posts: 22
Re: XENYX 1204FX crackling sound, missing left phones channel
« Reply #9 on: December 21, 2014, 10:45:38 pm »
I did check the connectors, they are good
The sip packages are the only thing left, and weird is there are 2 one per channel, despite they are dual opamps. The traces are ok till there, and all the stuff on the way there checks out (at least according to the schematic i got).
 

Offline SeanB

  • Super Contributor
  • ***
  • Posts: 15263
  • Country: za
Re: XENYX 1204FX crackling sound, missing left phones channel
« Reply #10 on: December 22, 2014, 05:51:47 am »
Very likely the opamps, and if you cannot get the SIL the simple fix is to use the DIL and dead bug half the pins with thin wires. They claim short circuit proof but that really is not true under all conditions. They might be that with 5V rails but not with 15V rails.
 

Offline janoc

  • Super Contributor
  • ***
  • Posts: 2978
  • Country: fr
Re: XENYX 1204FX crackling sound, missing left phones channel
« Reply #11 on: December 22, 2014, 02:22:26 pm »
Well, an opamp doesn't just die like that.

Check the power rails, then if you have a scope, check whether you have signal on the input and anything on the output. If you don't have a scope, you could use input of another channel as an improvised probe to check whether there is any signal on the input of that amplifier.

If there is input but no output at all and the voltages are good, then likely the opamp has an issue. However, I would then check the other things around it too - these things don't just die by themselves.
 

Offline wraper

  • Supporter
  • ****
  • Posts: 10598
  • Country: lv
Re: XENYX 1204FX crackling sound, missing left phones channel
« Reply #12 on: December 22, 2014, 02:30:43 pm »
Anyone has any idea where to get RC4580 in a single line package ? i can only find DIPs for it
NJM4580L on ebay, probably at respected sources too. As of partially dead ICs, that happens quiet often actually.
 

Offline nitro2k01

  • Frequent Contributor
  • **
  • Posts: 844
  • Country: 00
Re: XENYX 1204FX crackling sound, missing left phones channel
« Reply #13 on: December 22, 2014, 03:10:30 pm »
I've had a similar problem with the exact same mixer. In my case it was bad contacting in the switches. For me it was the level switch for one of the channels, but I would suggest going through all the relevant switches, such as the source/mode/alt switches since that's likely where the fault might be as you're describing your problem. Give them a light wiggle back and forth, both in the pressed and depressed position and listen for audio coming back, or for crackles. The pots are of course also a likely culprit, but the switches are perhaps more easily overlooked.
Whoa! How the hell did Dave know that Bob is my uncle? Amazing!
 

Offline Derresh

  • Contributor
  • Posts: 22
Re: XENYX 1204FX crackling sound, missing left phones channel
« Reply #14 on: December 22, 2014, 03:58:58 pm »
Hmm I did not thing of the switches, are they that cheap and prone to fail

The pots i all checked out, desolderd them and check out how the behave with my multimeter, they are good, also the fact the control room out is working fine takes the pots off the list... unless someone here decided to a very creative way of dealing with how a pot is connected to audio line

Well i did ask around the local suppliers, usually they have stuff but they seem to have no stock on the SIP8 pack on this thing, tho i found it on ebay.

For now I ordered the excat same ones as i have, branded as coolaudio (never heard of this IC maker... anyone ?)

As for the cause i suspect it was my headphone cable, i did run it over with my chair once and the sound they headphones made back then made my ears bleed... like i said I dont know much about audio stuff but would a shorted output duing playback with headphones a bit on the strong side (150 ohm cans) cause a opamp to fail. It has nothing after the IC other then one 47k resistor, between the jack and the output of the opamp

As for pictures I had to close the mixer for now, the crackling is gone so recording at least is no longer a issue.

If someone can take a look at the schematic and tell me other possible places of fail for the headphones out, its on page 6, the phones out is missing left channel, CR bout L and R work both fine. I suspect the part marked as IC1B as failed

https://www.dropbox.com/s/k073s5dzfs2gse3/behringer_xenyx_1204fx.pdf?dl=0
 

Offline wraper

  • Supporter
  • ****
  • Posts: 10598
  • Country: lv
Re: XENYX 1204FX crackling sound, missing left phones channel
« Reply #15 on: December 22, 2014, 05:20:45 pm »
For now I ordered the excat same ones as i have, branded as coolaudio (never heard of this IC maker... anyone ?)
Never heard of them too. Opamps do not seem to be their specialty so probably this is some rebadged clone. AFAIK original part is NJM4580 made by New Japan radio company, other being clones of it.
 

Offline wraper

  • Supporter
  • ****
  • Posts: 10598
  • Country: lv
Re: XENYX 1204FX crackling sound, missing left phones channel
« Reply #16 on: December 22, 2014, 05:24:57 pm »
From their website:
Quote
Branded Semiconductors at Amazing Prices:
COOLAUDIO also supplies a wide range of branded semi-conductors from TI, Analog Devices, etc. – all at extremely competitive prices. Click here for price list 1 and price list 2. These products are all original manufacturer components and fully factory sealed. Please contact us for any inquiries or questions you have.
Therefore it might be just rebadge from reputable or not so reputable brand. Like Multicomp from Farnell.
 

Offline Derresh

  • Contributor
  • Posts: 22
Re: XENYX 1204FX crackling sound, missing left phones channel
« Reply #17 on: December 22, 2014, 06:03:37 pm »
Managed to change my order at the suplier, they had NJMs so i get the original here. well we see if changing them will work
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf