Author Topic: Yamaha RX-V2071 (RX-A2010) Flash Memory  (Read 1834 times)

0 Members and 1 Guest are viewing this topic.

Offline Raff

  • Regular Contributor
  • *
  • Posts: 82
  • Country: au
Yamaha RX-V2071 (RX-A2010) Flash Memory
« on: August 03, 2016, 01:10:16 am »
Hi guys / gals,

I'm trying to repair a Yamaha RX-V2071 / RX-A2010 receiver.

The fault is no sound, picture is ok.

Ive narrowed the fault down thanks to the on board diagnostics to the "digital 2" board, it has DSP #2 on it.

Ive tried reflashing all the firmware, but the process goes ok until its tries to verify and fails with error 0100.

I have checked the voltages on the board and they are ok, and I can see data on the pins ok.

I'm suspect of the flash chip that holds the DSP firmware, its a Winbond 25x40bvng.

My questions before I go and maybe screw things up.

Anyone had a similar chip go bad on them?

I recall from old TV repair that similar chips that held the settings for TVs would often go bad.

I have a couple of similar but 8mbit chips from Macronix.

If I replaced the chip with the larger one and reflashed it do you think it would work?

At this point I guess I don't have much to loose.

Attached is a PDF of the schematic of the Digital 2 board.

Thanks,
Raff
 

Offline Raff

  • Regular Contributor
  • *
  • Posts: 82
  • Country: au
Re: Yamaha RX-V2071 (RX-A2010) Flash Memory
« Reply #1 on: August 06, 2016, 03:03:14 am »
An update.

I got my el cheapo programmer in the mail today that handles those sorts of flash chips, so I de-soldered the one in the Yammy and read it, erased it and reprogrammed it fine, I also tried the larger ones I had.

The end result? Didn't make much difference except now I get error 0200 when I try to update the receivers firmware on verify.

Looks like the actual DSP chip is faulty, oh well.

I'm off to try and either source the whole little board or it will have to go off to an authorised Yammy repair agent it seems.
 

Offline Raff

  • Regular Contributor
  • *
  • Posts: 82
  • Country: au
Re: Yamaha RX-V2071 (RX-A2010) Flash Memory
« Reply #2 on: August 09, 2016, 08:07:20 am »
Further update.

I managed to buy the "digital 2" module direct from Yamaha Australia and now the amp works fine.

Hope it helps someone else.

Raff
 

Offline Gregegg

  • Newbie
  • Posts: 2
  • Country: au
Re: Yamaha RX-V2071 (RX-A2010) Flash Memory
« Reply #3 on: May 05, 2019, 10:01:24 pm »
Hello Raff,

I just want to thank you for posting this fix as it appears I have the same fault.

 I was going for the Speaker O/P relays but now realize that since all sound channels are off and all video and controls are working fine that my fault is likely the same.
I have contacted Yamaha Australia to see if could obtain this DSP 2 PCB.

I will update here if successful with purchase from Yamaha and is also my fix. Now to return the 30 odd screws securing the rear panel.  :(

Thank you again for posting.
 

Offline Gregegg

  • Newbie
  • Posts: 2
  • Country: au
Re: Yamaha RX-V2071 (RX-A2010) Flash Memory
« Reply #4 on: May 10, 2019, 05:57:26 am »
Hello All, Yamaha supplied the Digital 2 PCB, replaced and all working fine. Hope this helps someone else

 :)
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf