Author Topic: Yamaha RX-V420RDS won't turn on at all  (Read 1054 times)

0 Members and 1 Guest are viewing this topic.

Offline Blocki

  • Newbie
  • Posts: 1
Yamaha RX-V420RDS won't turn on at all
« on: April 22, 2015, 09:12:13 pm »
Hey folks,

I have an Yamaha RX-V420RDS on my bench which won't turn on at all. Not even a relay click. The voltage regulator transistors are already switched and there is no 22µF cap.
Once I was able to get 1 relay click while pressing the on-button but nothing more happened. Another time I had a constant relay clicking like a minigun but display stayed off.

I cannot even bring it into DIAG mode as it won't turn on at all.

I have the schematics if required.

My main problem is that I have no real idea where to actually start the real debug. I only have a DMM to work with.
 

Offline mzacharias

  • Frequent Contributor
  • **
  • Posts: 612
  • Country: us
Re: Yamaha RX-V420RDS won't turn on at all
« Reply #1 on: April 24, 2015, 05:19:17 pm »
T start with, I would be checking to see if perhaps the standby 12V is low - also check the microprocessor B+ (perhaps 3.3 volts) and it's oscillator crystal and reset lines. The crystal typically is about 1/2 Vcc  DC volts on either side, and the reset line should toggle LOW when the unit is plugged in, and rise to B+ pretty quickly and smoothly.

Also, you can just look at the relay turn-on line coming to the standby power board and see if there is any action there when you press the Standby / On button.

Come to think of it, that should be your FIRST step.

If, for example you see that line budge but not go much more - you could have a leaky relay drive transistor.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf