Author Topic: Tenma 72-8155 (UT 603) LCR meter - bin or repair?  (Read 4408 times)

0 Members and 1 Guest are viewing this topic.

Offline mianchen

  • Regular Contributor
  • *
  • Posts: 225
  • Country: gb
Tenma 72-8155 (UT 603) LCR meter - bin or repair?
« on: November 24, 2013, 07:00:43 pm »
Bought 2 x cheapo Tenma LCR meters off Toploser recently. One of them working the other does not measure L/C as described.

These meters are exactly same as a UT603 shown in this thread.

After opened and poked around the faulty one, couldn't find anything obviously wrong with it. The only difference is that it draws 20+mA in L or C modes whereas the working one only takes <10mA. The 6V regulated rail reads 5.8V, 200mV lower than the 6.0V in the working one.

I ended up wasting a lot of time measuring most of the components in circuit and compared that with the working unit - no difference. Swapping the 'daughter board' confirmed that the fault is on the 'motherboard'...

Well it's still a good deal for 1 working unit. I don't want to waste more time on the faulty one and I'm gonna bin it (well maybe 'shelf' it and re-purpose it for something else). However before I do so, I'd like to ask here to see if anyone knows that this is a common fault and maybe an easy fix.

(OT: If I want to buy an LCR meter I will definitely avoid these cheapo, doesn't do much, and give no confidence what-so-ever in the results you get from them. lowest range is 2mH, terrible for any uH inductor measurement.)

Attached is a schematic I found on a Chinese forum. The L/C section of the UT603/Teman 72-8155 is identical to this. Almost all of the components and their values are identical. (sorry for the picture quality, couldn't find any better ones)
 

Offline SeanB

  • Super Contributor
  • ***
  • Posts: 15379
  • Country: za
Re: Tenma 72-8155 (UT 603) LCR meter - bin or repair?
« Reply #1 on: November 24, 2013, 07:25:11 pm »
Have you checked the voltage rails. there is a -6V rail, and if it is missing you will have very unhappy chips and no working. Likely the 7660 is either not generating -6V or the TLO62 on the input side is fried. Otherwise check the oscillator is working on the 7106 and the 555 timer is oscillating at the right frequency.
 

Online PA0PBZ

  • Super Contributor
  • ***
  • Posts: 4279
  • Country: nl
Re: Tenma 72-8155 (UT 603) LCR meter - bin or repair?
« Reply #2 on: November 24, 2013, 07:25:21 pm »
Since it doesn't do L or C, is the R measuring correct?

If so maybe there's something wrong with the oscillator, did you measure/compare the output with a scope?

It looks like the oscillator is the OP62 TL062 somewhere in the middle of the diagram.
Keyboard error: Press F1 to continue.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf