EEVblog Electronics Community Forum

Electronics => Repair => Topic started by: joeqsmith on March 02, 2019, 05:35:02 pm

Title: Yokogawa TY720 / Kyoritsu KEW1062 Needs repair
Post by: joeqsmith on March 02, 2019, 05:35:02 pm
I recently tested a Yokogawa TY720 to failure. The only mode that is not functioning is capacitance.   

The meter is designed using mostly standard parts that are readily available.  The upside, the damaged parts may be easy to source.  The downside, it would take a fair amount of time to try and trace it out and I have not found a schematic for it.

The problem appears to be on the receive side.  There is a pulsed waveform when looking at leads of the meter.  Manually changing ranges does change the waveform.   I suspect the input is on the center resistor an not through the other leg with the second GDT.   The second GDT does switch to a high speed clamp when the capacitance mode is selected but it does not appear to go anywhere else.

The meter uses an ADS1240 ADC which supports 4 inputs.  AIN0&1 route to a couple of 4053 mux's.  AIN3 goes to a buffer and it appears AIN2 is shorted to the meter's common lead.   This could be a clue.

It appears all of the discrete diodes and transistors are fine.  The meter has 4 X DG444 quad switches along with the muxs to steer the signals.  I can change out an IC much faster than I can trace out the meter and took a change at shotgunning it.  No luck.   

If you have access to the schematic for the meter,  it would really save me a lot of time trying to hunt this problem down.   If you have a working version of this meters and don't mind checking, I would like to know if  pin 13 of the ADC (AIN2) is connected to the common connector.   That may give me a starting point.   

Pictures of the PCB. 
https://www.eevblog.com/forum/testgear/ty720-kew-1062-handheld-multimeter-inside-high-resolution-images/msg1491871/?topicseen#msg1491871 (https://www.eevblog.com/forum/testgear/ty720-kew-1062-handheld-multimeter-inside-high-resolution-images/msg1491871/?topicseen#msg1491871)
Title: Re: Yokogawa TY720 / Kyoritsu KEW1062 Needs repair
Post by: joeqsmith on March 02, 2019, 06:05:00 pm
From the attached picture, I have replaced all four DG444 quad switches which had no effect. 
Title: Re: Yokogawa TY720 / Kyoritsu KEW1062 Needs repair
Post by: HKJ on March 02, 2019, 07:39:41 pm
I have the Kyoritsu KEW1062, it looks to be mostly the same (It is not exactly the same).
I have traced out the input section, but not anything more. I supposed you have checked the clamp transistor has not suffered in its breakdown voltage, i.e. the capacity test uses a 1V waveform for testing.
I do not really want to desolder the shield again to do more measurements.
Title: Re: Yokogawa TY720 / Kyoritsu KEW1062 Needs repair
Post by: joeqsmith on March 03, 2019, 05:01:13 am
No need to reply.  I have it sorted out.
Title: Re: Yokogawa TY720 / Kyoritsu KEW1062 Needs repair
Post by: rsjsouza on March 03, 2019, 04:44:40 pm
For completeness, what was exactly the issue?

You don't want to do what DennerCoder9 did, now do you?  :-DD
https://xkcd.com/979/