Products > Other Equipment & Products

DSO Atten 50 Mhz with very strange sintom

(1/1)

Francirius:
Hi!, Some time ago i was looking for a DSO, and finally i get the Atten ADS1062C. I bought from Ebay, and like a month later arrive. I'm from Chile, and i started measuring a few things, but i had an accident, I measured a circuit with no transformer in the power source (it was a switching, i think ) and i get a shortcircuit with the both "grounds" (of the circuit and from the DSO). It seems that nothing happen but the DSO started to works rare, and finally it freezes. Talking with the dealer (from korea), i could open the DSO, and following their advice i disconected the display flex. It work one time, but again it freezes and death with a white display. In the end, i could get a new oscilloscope, but i'm affraid to use it, 'cause when i turn it on, the display trembles, but it works fine for the moment.
This is my experience with Atten, i would like to change it, i don't know if is normal this "tremble" in the display in the beggining.
Bye, and sorry for the english, i'm from Chile.

Mechatrommer:
replace with another brand. last night i accidentally probe unisolated circuit with my rigol too (thought the motor is low volt dc, checked with my uni-t dmm, its just mains supply, trickled and controlled by some ic circuit. the same with you, gnd circuit to gnd dso, and then walla! the circuit breaker trip. rigol still works ok i think. this is the second time happened.

Navigation

[0] Message Index

There was an error while thanking
Thanking...
Go to full version