Products > Other Equipment & Products

Dyson V10 motor PCB

(1/1)

li_gangyi:
Have a weird one, a V10 Motor PCB that will not work in low or medium speed (just pulses once for like 1/4 a sec and gives up), in Max mode it runs, but appears to be a tad slow (scoping the hall-effect output, I see 6.8kHz instead of 7.3kHz on 2 other working PCBs I have, on the same motor).

So far I've figured out the following.

U7 and it's vicinity are a ~10V buck converter, that voltage is present and stable even after the motor is commanded off with the trigger depressed.

U10/J8 vicinity are the battery data lines (differential pair I presume).

U4 on the bottom side is the motor hall effect sensor, that same signal is brought out to a test point on the top edge of the board. I have tried swapping in a known good hall effect sensor with no change in behavior.

U2 is the 3/3V regulator that supplies the main uC, the speed selector and U4 at least, that voltage is also present and stable after the motor is commanded off with the trigger depressed.

What I haven't worked out, is what's tripping the uC to cut drive to the motor, the FETs are not shorted, FET drivers on the top side appear to work properly when scoped.

Additionally I tried shorting out the shunt resistor on the bottom side of the board, the PCB will refuse to drive the motor, which is weird (unless the uC is using the current waveform to drive the motor perhaps).

What I have yet to do is to extend the motor and hall effect (U4) sensor wires and do some probing around the bottom side of the board.

li_gangyi:
Just realized this might be better in the repair section. Mods please do feel free to move this topic.

prolux:
It does this if the battery is not delivering the current, Dyson use critical parameters to sell batteries.

li_gangyi:
It's weird how the same motor and battery are working with another PCB though, I have extended out the hall effect sensor and the only difference is the PCB (same sensor in place during swaps). I cannot scope anything different (monitored the current shunt opamp).

It's something cool somehow, and if the battery was the issue, I'd expect it to fail driving the motor at maximum speed.

turenabo:
thanks, I got same issue, the motor makes a sound like gears slipping then followed by a sound like "dong", then stop... have you find the reason?

ln your post, looks like all components are not failed, but the motor doesn't work, have you measured all the components?

I'm trying to measure all the components, but there doesn't seem to be any obvious abnormalities.

Navigation

[0] Message Index

There was an error while thanking
Thanking...
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod