Products > Other Equipment & Products

KSGER Hot Air Soldering Station

(1/6) > >>

0xPIT:
Hi,

does anyone have a KSGER Hot Air Soldering Station [1]?

This feels stupid, but I seem to have problems with it: No matter at what temperature (tried 300-480°C) and no matter how long (tried 2-6 mins) I'll blow at some chip on some old PCB, the solder will not soften. I've tried to desolder some SOIC8 and some larger RAMs, all with pins. If I blow at regular 0,7mm solder (leaded and lead-free), it will melt, as will solder paste.

It seems that the handle and heating element are the same as in the 858+ stations.

Anyone any hint as to why I'm too stupid to desolder with this piece?


cheers,
  - pit

[1] https://de.aliexpress.com/item/KSGER-Hot-Air-Gun-Soldering-Station-Handle-Electronic-STM32-Digital-T12-Nozzle-Stand-220V-DIY-Welding/32820878426.html

thm_w:
Didn't know they had come out with these, looks like they could be a slight improvement over the 858D with a better and compact controller.

Do you have a thermocouple to measure the output air temperature? Just hold it about 1cm past the tip and see how well it agrees with the controller display.

For removing chips, set the flow rate to 80% or more, and put on the second largest or largest round tip thats shown in the photo. That should be plenty to heat up most PCBs.

0xPIT:
Yes, I got it because of the small size, my lab desk is full :)

Thanks for you help, bigger nozzle and more airflow helped, I did not expect that.
Strangely, almost no YouTube video mentions temperature and airflow.

kripton2035:
these stations have a pretty nice look !

Hergen Lehmann:
I bought one of these a few weeks ago, but unfortunately the controller box gave up with a bang and smoke after only 10minutes of operation.

Further analysis showed several construction errors:

1. The heater is operated at mains voltage with only very thin wires running through the handpiece cable. As only one input terminal is fused, there is a 50-50 chance that unfused live ends up on wires not suitable to carry short circuit current (at least in countries using a reversible mains plug).

2. There was a wiring error (unsure, whether in the handpiece or the control unit), resulting into the PE from the heater shell running back and forth through the heater thermocouple before actually reaching ground in the control box.

3. To make things even worse, the ground connection further runs through a very thin PCB track on the power board before finally reaching the PE input terminal.

4. There is no thermal runaway protection.

My unit seems to have failed from some kind of short circuit in the heater, leading to a burned up ground PCB track (3), leading to mains voltage reaching the control circuit, and finally blowing up almost everything on the control board. :-(

So be careful with these! You should at least check the wiring and add a proper PE/ground connection. A second fuse to limit the current flow in case of a heater failure may also be a good idea.

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version