Products > Other Equipment & Products

Metcal MX 5000 Error: Non-Conforming Cartridge Detected

(1/1)

Zucca:
https://www.manualslib.com/manual/1281662/Metcal-Mx-500.html?page=11

Anyone got this message like me? I still have to do my homework to investigate what is going on, I just wanted to know if someone had the same issue with original metcal tips and what they do to solve it.

Thanks.

thm_w:
You saw this thread right? https://www.eevblog.com/forum/reviews/metcal-mx-ps5000-issue/

Is the station consuming any significant power before it says that? Think I saw it once with a thermaltronics power tip but never again.
Have you tried with another handle, or with no handle, what does it say.

elemenoh:
Were you ever able to figure this out? I have a second hand MX-5200. A couple of cartridges throw this error after ramping too much power. One is a Metcal tweezer cartridge (its sibling is fine) which I've used for maybe 20 active hours since new. The other is a new Thermaltronics cartridge. I've tried a different hand piece and get the same result. If it were just the one tweezer cart I'd assume that just went bad somehow, but I'm suspicious that the new Thermaltronics cart is also bad.

My MX-5200 likely had a hard life. I had to replace a broken power switch and unstick a relay to get it working. So maybe there's some other marginal component on it. But all of my other cartridges work fine.  ¯\(ツ)/¯ 

Zucca:
Ah in my case I messed my 5200 FW upgrading it to a new version (there is a thread somewhere in this blog)... so I revert the FW to stock and solved the problem.

Navigation

[0] Message Index

There was an error while thanking
Thanking...
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod