Products > Other Equipment & Products

YouDe 852D+ knockoff rework hot air/soldering station teardown, review and mods

(1/2) > >>

My Zhongdi ZD-987 soldering/desoldering station broke recently, and since it was still under warranty, but the seller had no replacement units in stock, I got the money back. Since I wanted to get a soldering/hot air station anyway, I ordered a unit on eBay sold as "852D+" with no manufacturer name anywhere. It was a new unit, but since it had a UK plug, but was being sold in Belgium, I got it for 60€ delivered to germany. Fully aware of the experiences others had with those knockoff rework stations, I thought it was a pretty sweet deal, even if only for the parts. I expected to use this till the triac died, hopefully saving the hot air heater from burning up by carefully watching over the device. I planned to then fit in some custom electronics.

So today the package arrives at my doorstep, and the first thing I notice while unpacking the device is the fact that it has two wide and seperate switches at the front panel, instead of the slim pair pictured in the auction. There are at least two different units on the market that can be distinguished by looking only at the outside.

Since there was a marking on the UK plug saying it is "fused", I curiously opened the plug first (german plugs don't have fuses in them). Also I noticed that the cable was quite a bit thinner than what I would have expected. It is marked 0,75mm^2, but the wires are incredibly thin, much thinner than actual 0,75mm^2 wire. Unscrewing the plug, I immediately noticed that the hot and earth wires are not actually screwed into the terminals! Plugging this in would have been disastrous... Also the wires were just tinned as preparation to screwing them into the terminals. The local code mandates wire sleeves, and rightly so!

The plug had to come off anyway, so I decided to replace the entire mains wire with a proper 3x0,75mm^2 H05VV-F with a VDE mark and a nice molded plug at the end. So  I proceeded with opening up the device itself. The first impression was actually pretty good! The build is quite clean, with all wires neatly heatshrunk and tied together. Screws and connectors are gunked down with a tough red glue. There is not a chance anything could come apart during shipping. Also the internals looked quite different than any units I'd seen online. There is only one front panel PCB, a transformer and the membrane pump. The latter being securely cabletied in two places, kind of strapping the air reservoir to the pump. The internal mains wiring is quite a bit thicker than what is coming into the device, looking like proper 0,75mm^2.

The case ground point looked very dodgy: The hole wasn't properly deburred, so the screw stood out nearly 2mm. There was no toothed washer and no sign of removed powder coating, so I went and got the multimeter. As suspected, there was no ground connection to the metal case at all! So I disassembled the screw (which stripped on removal), opened up the hole a little, removing the burr in the process, and after scratching off the powder coating on the inside, I put a new screw and a toothed washer back in, replacing the flimsy ground wire with a 0,75mm^2 lead. I also went ahead and replaced the fuse holder with a sturdier one I had in my parts bin. I kept the original fuse, which is 250V 6A fast blowing.

The transformer's primary side is rated 220V 50Hz, the secondary windings provide 10.6V and 26V. The former is rectified and regulated down for the micro, the latter seems to be directly heating the soldering iron, switched via a triac.

Next I took out the PCB, to take a good look at the layout and manufacturing. It is marked "youde852DV4+". I don't mind the PCB at all, the layout is tidy and everything is properly marked on the silkscreen. The only thing I noticed is that the mains part of the board is not properly seperated from the rest of the circuit, and there are no isolation slots anywhere. This needs to be improved in the next revision! Soldering is okay, but there's a lot of flux residue all over the board. The chinese ain't no time to clean their PCBs ;) Also I had to clip down the LED leads...

A couple of highlights:

 * U2 7805: ST L7805CV positive voltage regulator
 * U4 M358: ST LM358N low-power dual opamp
 * U5 TM1628: TM1628 LED Driver
 * U6 BT16 (heat sink): ST BTA16-600B 600V 16A Triac
 * U7, U10 MOC3041: MOC3041 4250 Zero-Cross Optoisolator w/ Triac Driver Output 400Vp
 * U8 9454: S3F94C4EZZ-DK94 Zilog SAM88 RCRI microcontroller, 4KB Flash, 208 Bytes RAM, 14/18 GPIO, two 8bit timers, one 14bit timer, one 9ch 10bit ADC
 * U9 (no heat sink), U11 (heatsink) BT137: NXP BT137-600E 600V 8A Triac
 * U12 2W10: 1A bridge rectifier

 * V2, V3 102: BAOTER 3296 XCHC ELECTRON 1kR multiturn pot
 * JDQ1 12V: SONGLE SRD-12VDC-SL-C 10A 250VAC/30VDC relay

After fixing the wiring, I went on to test and calibrate the unit. It worked fine from the get-go. While playing around with the soldering iron, the first thing I noticed was that the device displays the setpoint while turning the pot and for a short time after letting go, and after that switches to what appears to be the current temperature. From what I read, other units called "852D+" don't display the current temp at all, and purportedly the control circuit is completely analog. With that in mind and the fact that the current temp value ramps up and down quite quickly and locks firmly in place once the setpoint is reached, I at first suspected that maybe there was some kind of trickery going on, with the ramping up/down just being some sort of animation. Also the LED's flicker behaviour didn't match the temp ramping rate, leading me to suspect that only the LED is connected to the control circuit, and the other display being faked. But after playing with both the soldering iron and the heat gun for a while, I now think that the unit does indeed display the measured value, but applies quite a bit of filtering to hide the controller's bouncyness from the user. As soon as the setpoint is reached for the first time, the displayed temp is practically frozen, hiding all over/undershooting.

Next, I set up a thermocouple to look into the controller's behaviour and calibration. The soldering iron's factory temp calibration was pretty spot on, being off by less than 10°C. At this point, I first noticed the unstable controller bouncing around for quite some time, never really settling on a temp. It also sometimes overshoots by more than 50°C for a couple of seconds before bouncing around within 5-10°C of the setpoint! After fiddling around with the heat gun, I came back to the soldering iron and adjusted the calibration just a tad to match my thermocouple's readout.

Turning to the hot air side of the device, the first thing that got me was that the calibration was off by some 40-60°C! I left the heat gun in the holder, clamped the thermocouple with a "helping hand" and positioned it right at the end of the 8mm nozzle, neatly centered in the air stream and careful not to touch the nozzle at all. Regardless of air flow and temperature setting, the temp was consistently too high. So I started fiddling around with the multi turn pot on the PCB. Conveniently, the silkscreen reads "L-CIRCUIT" for the soldering iron's control and "F-CIRCUIT" for the heat gun's. I'm not sure what L and F mean, but the letters matched the marks near the respective switch connectors. The calibration adjustment is pretty easy, since the multiturn pots seem to be quite accurate. Even though the controller appears to be a little unstable, I managed to get the air temp to swing symmetrically around the setpoint. Overall, the air temp is stable enough to be usable, though I noticed that sometimes the controller gets upset for no reason at all and overshoots pretty far for a few seconds, even though it had had settled before (same behaviour on the soldering iron). But for hand-held SMT rework, I guess this is decent enough as it is. The PCB's and device's thermal mass should low-pass those spontaneus deviations. If temperature is absolutely critical for your application, you wouldn't get this el cheapo station anyway, would ya? ;)

After running both the soldering iron and the heat gun different settings for about an hour, I can attest that the temperatures on the PCB are pretty low. Nothing got any warmer than 30-35°C, making me pretty confident that this circuit should last a while. Note that the case was off the whole time.

The soldering iron is marked "907 24V 80W ESD SAFE". The tips appear to be interchangeable with Hakko 900M series. The wire is a bit stiff, I really liked the iron of my ZD-987 better than this. Maybe I'll look into replacing it. Note that the iron's tip is not grounded. In fact, there is a missing resistor marked "R16 1,5M" right next to the soldering iron connector on the PCB. This resistor ties the iron's tip down to the circuit's ground connection. But I wasn't able to figure out how this is supposed to be connected to earth. If anything, one could put a banana jack somewhere on the case and connect it to the grounding pin of the iron, so the device can be tied into the bench ground point if required. The heat gun is not grounded as well. Unfortunately, there is no easy way to tie the metal can down to earth. One could run an additional ground wire through the hose, but connecting it to the metal part would require a spot welder. Or maybe there's room to put a screw through the metal jacket? I did not disassemble the heat gun yet, but the manual states how to open the handle to replace the heater.

I measured 20VAC between chassis ground and the soldering iron's tip, and 10VAC between ground and the shroud on the heat gun. Plugging the unit in is enough for this, no need to turn anything on. The value does not change when turned on. Interestingly enough, flipping the mains plug around results in 15VAC on the iron and 0.5VAC on the heat gun... The unit should be unplugged while not in use, not only because of this, but because the transformer is wired directly to the mains. I think I'm going to install a switch in the back!

As for my conclusion: I expected the worst, but got a pretty decent tool! Especially considering the price, I'm really happy how this turned out. Yes, there was some rework required, but it is to be expected with those cheap chinese knock-offs of knock-offs. But one should NEVER EVER expect to be able to just plug a device like this into the outlet and start working. Had I not at least looked into the plug, I would have quite possibly started a fire. The non-working ground connection really needed to be fixed as well before firing the unit up for the first time.

I tried to add a 1M resistor between the tip contact and the ground point. This dropped the voltage on the iron's tip to under 2V. However, since I was not positive about where on the PCB to connect this to, I just soldered one side on the resistor on one pad of R16 and ran a cable to the chassis ground point. However, the iron's heater control is now easily upsettable by running mid-to-high airflow. I suppose the long cable acts as an antenna, somehow disturbing the sensor readout...
I removed the mod for the time being, and I'm in the process of reversing parts of the PCB anyway, so I'll look into the grounding possibilities, too.

I'm thinking about replacing the controller with an AVR, creating a small adapter PCB that plugs directly into the socket. Anyone interested in helping in creating the firmware?

there is already a thread about replacement firmware for 858d somewhere on the forum, fully working at this point I think

Yeah, but the 858D is a hot air only station, with the blower in the handle, and with buttons to adjust the temperature. Should have been obvious, if you looked at the pictures ;)

he I was stupidly thinking a starting point would help you   |O


[0] Message Index

[#] Next page

There was an error while thanking
Go to full version