Products > Other Equipment & Products

CFW for KSGER/Quicko STM32 Soldering Stations

<< < (801/809) > >>

sst311212:

--- Quote from: DavidAlfa on February 27, 2024, 02:50:03 pm ---About the C210 issue, no idea, it's connected in the same way as T12, but the output is much lower, about ADC 1500 for 400°C.
Try a manual calibration in CALIBRATION > SETTINGS.
--- End quote ---
Tip will heat up when adjusting default cal250 value in calibration setting menu.
It's no sense that you need to insert tip first when changing default cal value, or maybe these settings should move to iron menu.



--- Quote from: cosmin1 on February 27, 2024, 07:15:47 pm ---Yes, it's connected as the T12. But in calibration process... it glow like a nice red bulb and burned out...  |O
So i was thinking if i copy the fw from a same version pcb already calibrated with the C210, maybe no need to calibrate again.

--- End quote ---
You can dump chip's full data(ADDR:0x8000000 SIZE:0x20000) from the old one and write it into new chip.

cosmin1:
I used this calibration method. Can't calibrate without the inserted tip.



Is there a way to erase the chip's content? It has the original Ksger fw, can't read, can't write, can't erase...

Or the only way is to replace the STM and program it as i wish?

I am using the JBC C210 tip in this configuration on KSGER 2.1S board, with 12V power supply.
Same way the T245, but with 24V power supply.
Green wire not connected.

DavidAlfa:
Are you even reading? I said to clear the option bits.
This is explained in the programming Readme.
Same as why you need to insert the tip, also explained in the operation manual.
Guys, don't be lazy and read!

cosmin1:
No need to argue, i don't know what option bits you are talking about.
I am using the original firmware, not yours. With yours i get checksum error and continously restarting.
The meaning of the forum is to ask what we don't know.

I finally succeeded to erase the "locked" MCU.
But no matter how i try, the fw copied from the other MCU is only 4kb... So not working when i upload in the new MCU.
The original file is 74kb and working. But i still have the calibration problem.
So... in the calibration process the c210 tip is turning glue red. I can't calibrate him without burning out. Can anyone help me out with this. I tried to calibrate without the tip, but did't help.

DavidAlfa:
Then you have a fake/clone! Newer firmware uses different features which unfaced lots of fake stm32!

Option bytes unlocking and fake device detection are described in the programming section:

https://github.com/deividAlfa/stm32_soldering_iron_controller/blob/master/Readme_files/Programming.md


--- Quote from: cosmin1 on February 28, 2024, 06:58:58 pm ---But no matter how i try, the fw copied from the other MCU is only 4kb

--- End quote ---
Because when reading with ST-Link you must set size to 0x20000.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

There was an error while thanking
Thanking...
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod