Author Topic: CFW for KSGER/Quicko STM32 Soldering Stations  (Read 825642 times)

Duffy82 and 3 Guests are viewing this topic.

Offline spleenharvester

  • Contributor
  • Posts: 24
  • Country: gb
Re: CFW for KSGER/Quicko STM32 Soldering Stations
« Reply #4125 on: June 11, 2024, 07:37:59 pm »
Tested CFW on it, works perfectly except for:

  • Stand has no effect
  • Encoder turns the opposite direction (spinning to the right decreases the temp)
  • General issue with the building_script.bat file - lines 230 and 231, the "2" at the end of "Release 2" are causing the script to throw an error as they are being interpreted as arguments. Also I don't think it's mentioned anywhere but on Windows you have to launch the script from a command window that is opened in the root directory of the T12 firmware folder, otherwise you'll get a "file not found" error during copying
« Last Edit: June 11, 2024, 07:40:23 pm by spleenharvester »
 

Offline DavidAlfa

  • Super Contributor
  • ***
  • Posts: 6083
  • Country: es
Re: CFW for KSGER/Quicko STM32 Soldering Stations
« Reply #4126 on: June 11, 2024, 08:15:58 pm »
Did you expect to randonly download the batch file and place it anywhere?
Hantek DSO2x1x            Drive        FAQ          DON'T BUY HANTEK! (Aka HALF-MADE)
Stm32 Soldering FW      Forum      Github      Donate
 

Offline spleenharvester

  • Contributor
  • Posts: 24
  • Country: gb
Re: CFW for KSGER/Quicko STM32 Soldering Stations
« Reply #4127 on: June 11, 2024, 08:18:51 pm »
No, I have not placed it anywhere, it is in the root of the T12 folder. But if you run it from that folder by double clicking on it it interprets everything as being relative to C:\Windows\System32, which causes the script to throw weird errors as the paths assume you are in C:\stm32_soldering_iron_controller or wherever you have saved the folder. It took a while to figure out what it was doing as the output is piped to nul (I think the only thing it came up with was '/STM32F103 file not found' or something like that) so it might be worth mentioning in the readme that you need to open a cmd window, navigate to the T12 folder, then use that command window to launch the batch file.
« Last Edit: June 11, 2024, 08:21:12 pm by spleenharvester »
 

Offline DavidAlfa

  • Super Contributor
  • ***
  • Posts: 6083
  • Country: es
Re: CFW for KSGER/Quicko STM32 Soldering Stations
« Reply #4128 on: June 11, 2024, 08:20:49 pm »
That only happens when you run it as admin, which you should never do unless stated.

lines 230 and 231, the "2" at the end of "Release 2" are causing the script to throw an error as they are being interpreted as arguments.

It's " 2>nul >nul". That's not an argument, by a piep redirection to make it silent. It's been working for years.
Likely, like the system32 thing, theres a problem in your system. Which Windows version?

About the stand mode, are you sure you understood how it works? Read the manual.
« Last Edit: June 11, 2024, 08:24:22 pm by DavidAlfa »
Hantek DSO2x1x            Drive        FAQ          DON'T BUY HANTEK! (Aka HALF-MADE)
Stm32 Soldering FW      Forum      Github      Donate
 

Offline spleenharvester

  • Contributor
  • Posts: 24
  • Country: gb
Re: CFW for KSGER/Quicko STM32 Soldering Stations
« Reply #4129 on: June 11, 2024, 08:22:52 pm »
I get "C:\ Access is denied" from CubeIDE during compile if I don't run it as admin.
 

Offline spleenharvester

  • Contributor
  • Posts: 24
  • Country: gb
Re: CFW for KSGER/Quicko STM32 Soldering Stations
« Reply #4130 on: June 11, 2024, 08:27:07 pm »
That only happens when you run it as admin, which you should never do unless stated.

lines 230 and 231, the "2" at the end of "Release 2" are causing the script to throw an error as they are being interpreted as arguments.

It's " 2>nul >nul". That's not an argument, by a piep redirection to make it silent. It's been working for years.
Likely, like the system32 thing, theres a problem in your system. Which Windows version?

About the stand mode, are you sure you understood how it works? Read the manual.

It's definitely not 2>nul >nul, because I unsilenced it and CubeIDE specifically shows an error that states the 2 is being interpreted as an argument.

It's Win11, just tested and it happens on multiple Win11 installs here. One is only a few weeks old.

Stand works fine on stock firmware, it triggers standby when the iron contacts the metal. I don't think any other Quicko stations have used this in the past have they so there's probably just not code in it for CFW?
 

Offline DavidAlfa

  • Super Contributor
  • ***
  • Posts: 6083
  • Country: es
Re: CFW for KSGER/Quicko STM32 Soldering Stations
« Reply #4131 on: June 11, 2024, 08:40:03 pm »
Strange. Did you install CubeIDE as admin?
Try right-clicking over C:\ST -> Properties -> Security -> Advanced

Change owner to Everyone, tick "Replace all owner in objects and subfolders", click Apply.
In permissions, click Add, Select entity, write "Everyone", tick "Total control", click "Replace all entries", click Apply.

Now accessing ST folder shouldn't require admin rights whatsoever.

It's definitely not 2>nul >nul, because I unsilenced it and CubeIDE specifically shows an error that states the 2 is being interpreted as an argument.
So you induced a fault yourself. To unsilence it you must remove the entire "2>nul >nul", leaving the "2" is wrong.

>nul redirects the standard output.
2>nul redirects the error output.

Stand works fine on stock firmware, it triggers standby when the iron contacts the metal. I don't think any other Quicko stations have used this in the past have they so there's probably just not code in it for CFW?
So there's a dedicated input for stand in this board? First one having this. The CFW expects you to reroute the original shake signal, as explained in the manual.
There you'll also see there's an option to invert the encoder rotation.
« Last Edit: June 11, 2024, 08:46:07 pm by DavidAlfa »
Hantek DSO2x1x            Drive        FAQ          DON'T BUY HANTEK! (Aka HALF-MADE)
Stm32 Soldering FW      Forum      Github      Donate
 

Offline spleenharvester

  • Contributor
  • Posts: 24
  • Country: gb
Re: CFW for KSGER/Quicko STM32 Soldering Stations
« Reply #4132 on: June 11, 2024, 08:53:46 pm »
Strange. Did you install CubeIDE as admin?
Try tight-clicking over C:\ST -> Properties -> Security -> Advanced

Change owner to Everyone, tick "Replace all owner in objects and subfolders", click Apply.
In permissions, click Add, Select entity, write "Everyone", tick "Total control", click "Replace all entries", click Apply.

Now accessing ST folder shouldn't require admin rights whatsoever.

That worked  :)

Quote
So you induced a fault yourself. To unsilence it you must remove the entire "2>nul >nul", leaving the "2" is wrong.

Yes I stand corrected, now that I've rechecked it with a fresh unzipped archive I see the error I was originally having was actually caused by the aforementioned admin rights issue, apologies!

Quote
So there's a dedicated input for stand in ths board? First one having this. The CFW expects you to reroute the original shake signal, as explained in the manual.

Yes, it's that pad with the Chinese writing next to it we discussed a few pages back - it's vacant on the T12-958v2 but has a wire bridging it to the stand on the T12-A. Assuming I've traced the schematic properly (attached) and interpreted it properly, it looks like docking the iron on the stand causes pin PD1 to be pulled low.
 

Offline DavidAlfa

  • Super Contributor
  • ***
  • Posts: 6083
  • Country: es
Re: CFW for KSGER/Quicko STM32 Soldering Stations
« Reply #4133 on: June 11, 2024, 09:10:06 pm »
Ok. Added support for dedicated stand input. Give it a try!
v1.13.12
« Last Edit: June 11, 2024, 09:31:24 pm by DavidAlfa »
Hantek DSO2x1x            Drive        FAQ          DON'T BUY HANTEK! (Aka HALF-MADE)
Stm32 Soldering FW      Forum      Github      Donate
 
The following users thanked this post: ststefanov13, spleenharvester

Offline spleenharvester

  • Contributor
  • Posts: 24
  • Country: gb
Re: CFW for KSGER/Quicko STM32 Soldering Stations
« Reply #4134 on: June 11, 2024, 09:54:24 pm »
Ok. Added support for dedicated stand input. Give it a try!
v1.13.12

Working perfectly. Thanks v much!
 

Offline ststefanov13

  • Regular Contributor
  • *
  • Posts: 52
  • Country: bg
Re: CFW for KSGER/Quicko STM32 Soldering Stations
« Reply #4135 on: June 12, 2024, 06:03:19 am »
For David, there is no update of the Beta coefficients of the older boards, there the pull-up resistor is 4.7 k, only on the quеcoo it is 10 k.

« Last Edit: June 12, 2024, 09:55:20 am by ststefanov13 »
 

Offline DavidAlfa

  • Super Contributor
  • ***
  • Posts: 6083
  • Country: es
Re: CFW for KSGER/Quicko STM32 Soldering Stations
« Reply #4136 on: June 12, 2024, 02:05:16 pm »
What are you telling me exactly?
Hantek DSO2x1x            Drive        FAQ          DON'T BUY HANTEK! (Aka HALF-MADE)
Stm32 Soldering FW      Forum      Github      Donate
 
The following users thanked this post: ststefanov13

Offline Polf

  • Regular Contributor
  • *
  • Posts: 55
  • Country: ru
Re: CFW for KSGER/Quicko STM32 Soldering Stations
« Reply #4137 on: June 12, 2024, 04:58:18 pm »
Ok. Added support for dedicated stand input. Give it a try!
v1.13.12
David, hello! I flashed version 1.13.12, but there is still 1.13.11 in the Menu -> System, please fix it (checked for KSGER_v2_OLED and KSGER_v3_OLED). Thanks!
 

Offline ststefanov13

  • Regular Contributor
  • *
  • Posts: 52
  • Country: bg
Re: CFW for KSGER/Quicko STM32 Soldering Stations
« Reply #4138 on: June 12, 2024, 05:00:22 pm »
stm32_soldering_iron_controller/BOARDS/KSGER/v2/STM32F101/Core/Inc/board.h   
stm32_soldering_iron_controller/BOARDS/KSGER/v3/STM32F101/Core/Inc/board.h
stm32_soldering_iron_controller/BOARDS/Quicko/STM32F103/Core/Inc/board.h

#define NTC_BETA      3450
 

Offline DavidAlfa

  • Super Contributor
  • ***
  • Posts: 6083
  • Country: es
Re: CFW for KSGER/Quicko STM32 Soldering Stations
« Reply #4139 on: June 12, 2024, 06:45:01 pm »
And are you sure they all have 3950 beta?

but there is still 1.13.11 in the Menu
Thanks, I forgot :)
Hantek DSO2x1x            Drive        FAQ          DON'T BUY HANTEK! (Aka HALF-MADE)
Stm32 Soldering FW      Forum      Github      Donate
 
The following users thanked this post: Polf, ststefanov13

Offline oleg401169

  • Contributor
  • Posts: 37
  • Country: ua
Re: CFW for KSGER/Quicko STM32 Soldering Stations
« Reply #4140 on: June 14, 2024, 05:20:05 pm »
Hello David! I built a soldering station using the Ksger v3.0 topology and encountered the following problem - all the lcd displays on the 7565 controller that I have require connecting the cs pin (all methods to get around the problem did not lead to success). I tried to recompile the sources myself for my display , but so far I’ve only gotten as far as uncommenting the lines in board.h, but as far as I understand, I still need to assign a pin for the cs pin of the display - can you tell me where to make the changes?
 

Offline DavidAlfa

  • Super Contributor
  • ***
  • Posts: 6083
  • Country: es
Re: CFW for KSGER/Quicko STM32 Soldering Stations
« Reply #4141 on: June 14, 2024, 09:45:53 pm »
Open the .IOC file in the IDE, take any free pin, set as GPIO Output, name it as DISPLAY_CS.
Then just enable "#define USE_CS" in board.h

« Last Edit: June 14, 2024, 09:51:20 pm by DavidAlfa »
Hantek DSO2x1x            Drive        FAQ          DON'T BUY HANTEK! (Aka HALF-MADE)
Stm32 Soldering FW      Forum      Github      Donate
 
The following users thanked this post: oleg401169

Offline oleg401169

  • Contributor
  • Posts: 37
  • Country: ua
Re: CFW for KSGER/Quicko STM32 Soldering Stations
« Reply #4142 on: June 14, 2024, 10:52:59 pm »
Thank you very much, as soon as I try I will immediately inform you about the results! Thanks again!
 

Offline oleg401169

  • Contributor
  • Posts: 37
  • Country: ua
Re: CFW for KSGER/Quicko STM32 Soldering Stations
« Reply #4143 on: June 15, 2024, 08:06:11 am »
It worked! The only question is that I compiled the latest version 1.13.12, but the menu shows that the version is 1.13.11, exactly the same in the finished version of the firmware for ksger v2 - although this is absolutely not critical!
 

Offline oleg401169

  • Contributor
  • Posts: 37
  • Country: ua
Re: CFW for KSGER/Quicko STM32 Soldering Stations
« Reply #4144 on: June 15, 2024, 09:46:39 am »
Corrected
 

Offline DavidAlfa

  • Super Contributor
  • ***
  • Posts: 6083
  • Country: es
Re: CFW for KSGER/Quicko STM32 Soldering Stations
« Reply #4145 on: June 15, 2024, 12:16:32 pm »
This is already corrected, I silently reuploaded the v1.13.12 release.
But you must download the new code to get the updates.
« Last Edit: June 16, 2024, 08:33:04 pm by DavidAlfa »
Hantek DSO2x1x            Drive        FAQ          DON'T BUY HANTEK! (Aka HALF-MADE)
Stm32 Soldering FW      Forum      Github      Donate
 
The following users thanked this post: oleg401169

Offline oleg401169

  • Contributor
  • Posts: 37
  • Country: ua
Re: CFW for KSGER/Quicko STM32 Soldering Stations
« Reply #4146 on: June 16, 2024, 06:49:06 pm »
I reinstalled the firmware, and also recompiled and installed the firmware for my display on the st7565 - everything works fine! Thank you for your work!
 

Offline Hunghanh2009

  • Contributor
  • Posts: 18
  • Country: vn
Re: CFW for KSGER/Quicko STM32 Soldering Stations
« Reply #4147 on: June 23, 2024, 04:07:15 pm »
Hello David! I built a soldering station using the Ksger v3.0 topology and encountered the following problem - all the lcd displays on the 7565 controller that I have require connecting the cs pin (all methods to get around the problem did not lead to success). I tried to recompile the sources myself for my display , but so far I’ve only gotten as far as uncommenting the lines in board.h, but as far as I understand, I still need to assign a pin for the cs pin of the display - can you tell me where to make the changes?

The CS pin is pulled down to GND, the screen still works. Is it necessary to add pins to the IDE and board.h?
 

Offline oleg401169

  • Contributor
  • Posts: 37
  • Country: ua
Re: CFW for KSGER/Quicko STM32 Soldering Stations
« Reply #4148 on: June 25, 2024, 06:59:20 pm »
Not necessarily, just in my case the display didn't want to work without the cs pin connected. In the original circuit the cs pin is not used, but for some displays, like mine, it is required.
 

Offline Crackn

  • Contributor
  • Posts: 12
Re: CFW for KSGER/Quicko STM32 Soldering Stations
« Reply #4149 on: June 26, 2024, 06:17:13 am »
Ok. Added support for dedicated stand input. Give it a try!
v1.13.12

hello, I ordered a stand that have a connector with 2 wires on it. one is for stand signal you already implemented. the second wire is for tip swap and when you touch the tip at it, it goes low so you can use it to switch off the pwm or sleep for xx seconds to tip swap.

is there a way to implement it on the firmware?

btw, I have the new quecoo T12 958 with ksger v3.4 board.

thanks
« Last Edit: June 26, 2024, 07:07:56 am by Crackn »
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf