Products > Other Equipment & Products

X-Soldering pro not working whith origijal JBC tips

(1/1)

dmendesf:
I got a X-Soldering pro from aliexpress and a few original JBC tips (240 and 210) but both doesn't work. When the probe rests it says "power down mode" and shows the ambient temperture (probably wrong). When I pick it up it gives an error and does`t heat up. Any hints?

thm_w:
Did it come with any tips, do those work?

What error is displayed?

dmendesf:
Reviving my (own) old topic. I bought a X-Soldering pro at Aliexpress and asked a friend to buy original JBC tips in USA. When both arrived I tested the station and it didn't work: probes where recognized while the handle was at the base

[attach=1]

but as soon as I take them out it tries to heat up but fails:

[attach=2]

If I return the handle to the base it doesn't return to work:

[attach=3]

Only way to make the station recognize the probes again is power cycling. The most incredible part is that a few days later I tried again and the station worked wonderfully.... and now it stopped working again, same syntoms. Any ideas? I think it may be noise injected from ground pin... will disconnect it and see wha happens.

thm_w:
Do you have a properly earth grounded outlet?

dmendesf:
Yes I do have a proper eath ground. Lifted it and nothing changed. I did more tests today and think the problem is different: I used another station to heat the 245 and 210 tips and the X-Soldering pro showed the increasing temperatures. Seems it's not driving power thru the tips to heat them and shows the error sign when the integrator error (from PD/ PID controller) saturates.

Navigation

[0] Message Index

There was an error while thanking
Thanking...
Go to full version