Electronics > RF, Microwave, Ham Radio

Help in understanding signal output from a frequency mixer

(1/2) > >>

samosmireno:
Hello,

I have a frequency mixer TFM-3MH+ where I need to output a low frequency signal of 10-100Hz

The signals that I'm sending at input ports from a signal generator are:

- Sine wave of frequency 6.9 MHz at LO port (+17 dBm)

- Sine wave of frequency 6.9 MHz+10Hz at RF port (-39 dBm)

So, the output of the mixer should be a sum of: frequency sum (6.9 MHz+6.9MHz+10Hz) and a difference (10Hz).

When I filter out the high frequency component, the signal that I'm getting is:

https://pasteboard.co/TuZ7eU7b94wS.png (10Hz)

https://pasteboard.co/hURPGvHgLK2P.png (80 Hz)

Can anyone explain what can cause these glitches in the signal?

How to avoid them?

Can I add some circuit after the output to smooth the signal?



The spec of the mixer is here:

https://www.minicircuits.com/pdfs/TFM-3MH+.pdf

fourfathom:
I don't know how your scope behaves, but it it possible that it is undersampling the sum signal (6.9M + 6.9M + 10), and so displaying an alias at 80 Hz?  Try reducing your scope time base to something like 10ns/div and see what it shows.

TimFox:
Also, there is a finite rejection of the LO power into the IF output.  According to the datasheet, this is something like 50 or 55 dB.  Therefore, one expects +17 dBm - 50 dB = -33 dBm or so of 6.90 MHz at the IF output.  The conversion loss (RF to IF) is roughly 4.5 dB, so the expected IF output from -39 dBm at the RF port is lower than the LO leakage, about -43.5 dBm.  How much rejection of the 6.90 MHz signal do you get when you filter out the high-frequency components (6.90 and 13.80 MHz)?  When the 'scope is set to display a 10 or 80 Hz sine wave, it will probably undersample the 6.90 MHz signal that makes it out of the filter, which will give strange aliases.

edpalmer42:
How did you filter out the high frequencies from the IF output?  In the 10 Hz picture, the vertical part of the glitches implies a high frequency.  If the high frequency components were filtered out before getting to the scope, the glitch must be something generated by the scope.

fourfathom:
Good points above.  What is the filter you are using, and for that matter, how do you get the separate 10Hz and 80Hz displays?  If you have both of these frequencies on the mixer output the scope should be displaying the additive sum of the two, or perhaps one modulating the other.  But if your two inputs are clean there shouldn't be an 80Hz component in the mixer output, so I suspect some sort of scope sampling alias.  And that glitch is "interesting".

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version