Electronics > RF, Microwave, Ham Radio

Microwave not heating

(1/2) > >>

Hi everyone,

I’m back to this lovely forum again, so I tried to heat up my food using my microwave after 8 month and realised it’s not heating up at all while it turns on, tried on all options (level of heat) no worked expect the very last I assume is 750W if I’m not mistaken. I can provide pictures next day as well,
And even the very last option wasn’t supper heat at all when I set for 2 min bowl of water. Only the bowl would be heating!

What I’ve done tested thermocouple, capacitor, magnetron, door switches, fuse, and the diode (replaced) they’re reading all good (on continuity) and cap value.

Any idea of this?
Please do let me know if future info needed or pictures, I have been away from this forum for long.

lol I have bowls like this too, the colored ceramic ones prevent heat from going into the food, but they get hot

Do you get voltage at the primary of the HV transformer when the unit is cooking? The safest way to test this is to disconnect the wire to the primary and connect it to another load like an incandescent lamp. You might also be able to hear the transformer humming when it comes on. This will tell you if the problem is on the primary or secondary side.

FWIW, resistance test (if that's how you tested) on the magnetron isn't guarantee it's still good. Wasn't in my case.

Yes I've had magnetrons fail more than once such that the filament checked good and nothing was shorted but they did not oscillate. It has been relatively rare though, the most common problems are faulty door interlock switches and cracked solder joints.


[0] Message Index

[#] Next page

There was an error while thanking
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod