Electronics > RF, Microwave, Ham Radio

WSJT-X on Pi

(1/6) > >>

metrologist:
I tried to set up WSJT-X on my raspberry Pi 3 that I just upgraded to Bullseye. I'm not a Linux bub, and all I recall is something about dependencies.

I used Method B: https://www.fs-pcba.com/how-to-install-wsjt-x-on-raspberry-pi/

I think after updating to the newer OS that I was able to get through step 2, but maybe the response was still not found.

I tried step 6. to fix broken install, and after the scary message, I said "Yes, do as I say!"

But still broken.

I was installing the package from here: https://wsjt.sourceforge.io/wsjtx.html

And I don't know what to try next.

Oh, I googled and found this site, which I'll try tonight.

http://www.hamskey.com/2017/12/install-wsjt-x-and-fldigi-on-raspberry.html

mag_therm:
I suggest you continue trying with your first link because it is current.

the last link you posted is way too old ( from 2017)

I have wsjt-x and fldigi running here on linux Fedora.  with 2 sdr transceivers.
regards,
KE8UZF

vk4ffab:

--- Quote from: metrologist on April 23, 2024, 06:53:55 pm ---I tried to set up WSJT-X on my raspberry Pi 3 that I just upgraded to Bullseye. I'm not a Linux bub, and all I recall is something about dependencies.

I used Method B: https://www.fs-pcba.com/how-to-install-wsjt-x-on-raspberry-pi/

I think after updating to the newer OS that I was able to get through step 2, but maybe the response was still not found.

I tried step 6. to fix broken install, and after the scary message, I said "Yes, do as I say!"

But still broken.

I was installing the package from here: https://wsjt.sourceforge.io/wsjtx.html

And I don't know what to try next.

Oh, I googled and found this site, which I'll try tonight.

http://www.hamskey.com/2017/12/install-wsjt-x-and-fldigi-on-raspberry.html

--- End quote ---

Don't compile from source, just download the arm deb file from the prinston site and click on it to install it, dpackage will deal with the dependencies and it will just work.

  wsjtx_2.6.1_armhf.deb

metrologist:
The links to the princeton site I found went to 404. I don't like to download from SourceForge but that's all I could find.

Here is the issue:

pi@raspberrypi:~/Downloads $ sudo dpkg -i wsjtx_2.6.1_armhf.deb

(Reading database ... 113061 files and directories currently installed.)
Preparing to unpack wsjtx_2.6.1_armhf.deb ...
Unpacking wsjtx (2.6.1) over (2.6.1) ...
dpkg: dependency problems prevent configuration of wsjtx:
 wsjtx depends on libgfortran5 (>= 8.3) | libgfortran4 (>= 7.3) | libgfortran3 (>= 6.3); however:
  Package libgfortran5 is not installed.
  Package libgfortran4 is not installed.
  Version of libgfortran3:armhf on system is 4.9.2-10.
 wsjtx depends on libgomp1 (>= 6); however:
  Version of libgomp1:armhf on system is 4.9.2-10.
 wsjtx depends on libqt5serialport5 (>= 5.7); however:
  Package libqt5serialport5 is not installed.
 wsjtx depends on libqt5multimedia5-plugins (>= 5.7); however:
  Package libqt5multimedia5-plugins is not installed.
 wsjtx depends on libqt5widgets5 (>= 5.7); however:
  Version of libqt5widgets5:armhf on system is 5.3.2+dfsg-4+rpi1.
 wsjtx depends on libqt5network5 (>= 5.7); however:
  Version of libqt5network5:armhf on system is 5.3.2+dfsg-4+rpi1.
 wsjtx depends on libqt5printsupport5 (>= 5.7); however:
  Version of libqt5printsupport5:armhf on system is 5.3.2+dfsg-4+rpi1.
 wsjtx depends on libqt5sql5-sqlite (>= 5.7); however:
  Pa
dpkg: error processing package wsjtx (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.13.3-6) ...
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for mime-support (3.58) ...
Errors were encountered while processing:
 wsjtx
pi@raspberrypi:~/Downloads $

metrologist:
OK, I did this:

pi@raspberrypi:~ $ sudo apt install libgfortran5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libc6-dbg : Depends: libc6 (= 2.19-18+deb8u7) but 2.31-13+rpi1+deb11u8 is to be installed
 libc6-dev : Depends: libnsl-dev but it is not going to be installed
 libcrypt-dev : Breaks: manpages-dev (< 5.01-1) but 3.74-1 is to be installed
 libnih1 : Depends: libc6 (< 2.20) but 2.31-13+rpi1+deb11u8 is to be installed
 manpages : Breaks: manpages-dev (< 5.09-2) but 3.74-1 is to be installed
 openssh-sftp-server : Depends: openssh-client (= 1:6.7p1-5+deb8u3) but 1:8.4p1-5+deb11u3 is to be installed
 wsjtx : Depends: libgomp1 (>= 6) but 4.9.2-10 is to be installed
         Depends: libqt5serialport5 (>= 5.7) but it is not going to be installed
         Depends: libqt5multimedia5-plugins (>= 5.7) but it is not going to be installed
         Depends: libqt5widgets5 (>= 5.7) but 5.3.2+dfsg-4+rpi1 is to be installed
         Depends: libqt5network5 (>= 5.7) but 5.3.2+dfsg-4+rpi1 is to be installed
         Depends: libqt5printsupport5 (>= 5.7) but 5.3.2+dfsg-4+rpi1 is to be installed
         Depends: libqt5sql5-sqlite (>= 5.7) but it is not going to be installed
         Depends: libboost-log1.62.0 (>= 1.62.0) but it is not installable or
                  libboost-log1.65.1 (>= 1.65.1) but it is not installable or
                  libboost-log1.67.0 (>= 1.67.0) but it is not installable or
                  libboost-log1.71.0 (>= 1.71.0) but it is not going to be installed or
                  libboost-log1.74.0 (>= 1.74.0) but it is not going to be installed
         Depends: libboost-filesystem1.74.0 (>= 1.74.0) but it is not going to be installed
         Depends: libboost-log1.74.0 (>= 1.74.0) but it is not going to be installed
         Depends: libboost-thread1.74.0 (>= 1.74.0) but it is not going to be installed
         Depends: libfftw3-single3 (>= 3.3.5) but 3.3.4-2+rvt is to be installed
         Depends: libqt5core5a (>= 5.15.1) but 5.3.2+dfsg-4+rpi1 is to be installed
         Depends: libqt5gui5 (>= 5.14.1) but 5.3.2+dfsg-4+rpi1 is to be installed or
                  libqt5gui5-gles (>= 5.14.1) but it is not going to be installed
         Depends: libqt5multimedia5 (>= 5.6.0~beta) but it is not going to be installed
         Depends: libqt5network5 (>= 5.15.1) but 5.3.2+dfsg-4+rpi1 is to be installed
         Depends: libqt5serialport5 (>= 5.6.0) but it is not going to be installed
         Depends: libqt5sql5 (>= 5.10.0) but it is not going to be installed
         Depends: libqt5widgets5 (>= 5.15.1) but 5.3.2+dfsg-4+rpi1 is to be installed
         Depends: libstdc++6 (>= 7) but 4.9.2-10 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
pi@raspberrypi:~ $

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod