EEVblog Electronics Community Forum

EEVblog => EEVblog Specific => Suggestions => Topic started by: Zucca on July 16, 2019, 08:32:28 pm

Title: Forum Site have a bug with high resolution monitor - Need to be fix - Low Prio
Post by: Zucca on July 16, 2019, 08:32:28 pm
My monitor is 3840x2160, here the problem I got:

(https://www.eevblog.com/forum/suggestions/eevblog-forum-site-have-a-bug-with-high-resolution-monitor/?action=dlattach;attach=786801;image)
Title: Re: EEVBlog Forum Site have a bug with high resolution monitor
Post by: gamalot on July 16, 2019, 08:42:24 pm
I bought a 4K monitor about four years ago, and I signed up for my eevblog account almost at the same time. I spend time in here every day and have never seen this problem.  :-//
Title: Re: EEVBlog Forum Site have a bug with high resolution monitor
Post by: Mr.B on July 16, 2019, 08:43:47 pm
I don't have that issue on my 4K monitors either.
Title: Re: EEVBlog Forum Site have a bug with high resolution monitor
Post by: Zucca on July 16, 2019, 10:05:12 pm
Reproducible in Vivaldi and Firefox, how can I debug it?

EDIT: if I right click on it and select inspect it opens the development window and it goes away, well sort of :-//

(https://www.eevblog.com/forum/suggestions/eevblog-forum-site-have-a-bug-with-high-resolution-monitor/?action=dlattach;attach=786897;image)
Title: Re: EEVBlog Forum Site have a bug with high resolution monitor
Post by: Zucca on July 16, 2019, 10:18:15 pm
Got it, the problem shows up when the EEVBlog Forum page is wider than 3020 pixel.
When the developer window appears on the right, the page shrinks and it goes away.
The vertical black line in the background is also there without the dev window I overlooked it.

 :-//
Title: Re: EEVBlog Forum Site have a bug with high resolution monitor
Post by: blueskull on July 16, 2019, 10:21:18 pm
Happens to me on my 12" Macbook and other Retina displays.

(https://i.kym-cdn.com/photos/images/original/000/234/885/afa.jpg)
Title: Re: EEVBlog Forum Site have a bug with high resolution monitor
Post by: gamalot on July 16, 2019, 10:23:17 pm
I've installed Firefox on my PC, now I can see it.  :)
Title: Re: EEVBlog Forum Site have a bug with high resolution monitor
Post by: coppice on July 16, 2019, 10:27:08 pm
Chrome and Firefox on Fedora do this for me when the window is more than about 3000 pixels wide.
Title: Re: EEVBlog Forum Site have a bug with high resolution monitor
Post by: gamalot on July 16, 2019, 10:36:01 pm
I can't see it in Chrome. only in Firefox.  :-//

------

I've figured it out now, my Chrome has been zoomed to 110% ......  :-DD
Title: Re: EEVBlog Forum Site have a bug with high resolution monitor
Post by: Zucca on July 17, 2019, 06:41:18 am
how funny.

If I will design a website in the future I will remember to test it on big ass monitors.
Title: Re: EEVBlog Forum Site have a bug with high resolution monitor
Post by: Shock on July 17, 2019, 09:06:51 am
The problem is with these two files they have a curved and shadowed edge. They are used twice on both the left and right side of the page. At a lower resolution two of the edges are hidden, at high resolution it exposes edges in the middle of the page.

https://www.eevblog.com/forum/Themes/default/images/theme/xmain_block.png (https://www.eevblog.com/forum/Themes/default/images/theme/xmain_block.png)  ...  (3000px wide)
https://www.eevblog.com/forum/Themes/default/images/theme/xframe_repeat.png (https://www.eevblog.com/forum/Themes/default/images/theme/xframe_repeat.png) ... (2300px wide)
In CSS #header, #header div.frame, #content_section,#content_section div.frame

Making them even wider still by increasing middle part of the images then re-optimizing similar to the originals should resolve the issue. There are better ways of doing this but would require more work.

Here is my other post that outlines a couple of other issues.
https://www.eevblog.com/forum/chat/images-embedded-between-text-how-big-is-still-tolerable-for-you/msg2541003/#msg2541003 (https://www.eevblog.com/forum/chat/images-embedded-between-text-how-big-is-still-tolerable-for-you/msg2541003/#msg2541003)

Title: Re: EEVBlog Forum Site have a bug with high resolution monitor
Post by: Zucca on July 17, 2019, 09:19:05 am
thanks for the investigation, it looks like a simple fix.
I hope gnif will do some magic about it.