Author Topic: [TIP] Firewire based instruments and Win7 / Win8  (Read 1516 times)

0 Members and 1 Guest are viewing this topic.

Offline free_electron

  • Super Contributor
  • ***
  • Posts: 7403
  • Country: us
    • SiliconValleyGarage
[TIP] Firewire based instruments and Win7 / Win8
« on: June 12, 2014, 05:36:14 pm »
There exists test equipment that uses firewire as a communications interface. Some internally, some externally. ( The Agilent 1680/1690 family of Logic analyzers for example ).
The problem starts when you want to use such machines with Windows 7/8 or want to upgrade the internal OS.

The same problem exists with certain video camera's and audio equipment like MOTU )

Microsoft altered the fire-wire driver in Win7. The new universal driver for OHCI compliant cards does no longer detect devices attempting to initiate TCP/IP transport over firewire.
So, when you plug in such a machine they are not detected .

Windows 7 solution
The problem is easily solved by going in the Device manager and selecting the firewire card

Click "Update driver software ..."
Click "Browse my computer for driver software"
Click "let me pick from a list of device driver on my computer ..." and Check the box before “Show compatible hardware”.

Select the "1394 OHCI Compliant Host Controller (Legacy)"
and click next to update the driver.

Windows 8 Solution

From a windows 7 machine get the following files :

you may need to disable the driver signing to be able to load these.
Professional Electron Wrangler.
Any comments, or points of view expressed, are my own and not endorsed , induced or compensated by my employer(s).

Offline Graz

  • Contributor
  • Posts: 12
Re: [TIP] Firewire based instruments and Win7 / Win8
« Reply #1 on: July 24, 2015, 11:24:17 pm »
I know this post is ancient and I apologize for the necromancy, but I just wanted to say thanks for the tip. I have a 1692A that I picked up for a "bargain" and it's been sitting on a shelf for months because I couldn't get it to work. Figured it wasn't such a bargain after all. I searched everywhere for a solution. Finally found this post. Now it's working perfectly.

Thanks, man! That's a great tip.

Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo