Author Topic: 2014 LabView Drivers for Siglent SDS2304X  (Read 1368 times)

0 Members and 1 Guest are viewing this topic.

Offline MikeLogix

  • Contributor
  • Posts: 46
  • Country: us
2014 LabView Drivers for Siglent SDS2304X
« on: October 23, 2017, 07:58:21 pm »
Has anyone converted the Siglent SDS2304X LabView drivers from 2015-16 to 2014? I looked at the NI website and there is only the latest versions which don't work on my version of LabView.

Thanks
 

Offline tautech

  • Super Contributor
  • ***
  • Posts: 18496
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: 2014 LabView Drivers for Siglent SDS2304X
« Reply #1 on: October 23, 2017, 08:05:06 pm »
So does the one on the Siglent page not work ?
http://siglentamerica.com/gjjrj-xq.aspx?id=2601&tid=204

Contact the guys in Ohio and let them know if there's a problem with drivers.
info@siglent.com
Avid Rabid Hobbyist
 

Offline MikeLogix

  • Contributor
  • Posts: 46
  • Country: us
Re: 2014 LabView Drivers for Siglent SDS2304X
« Reply #2 on: October 23, 2017, 08:14:37 pm »
Yes I tried those drivers. I get the following error screen:

It appears that the Siglent drivers are written for a newer version of LabView than what I have (2014).

Thanks
 

Offline tautech

  • Super Contributor
  • ***
  • Posts: 18496
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: 2014 LabView Drivers for Siglent SDS2304X
« Reply #3 on: October 23, 2017, 08:20:21 pm »
Yes I tried those drivers. I get the following error screen:

It appears that the Siglent drivers are written for a newer version of LabView than what I have (2014).

Thanks
OK, thanks for confirmation.
I'll send a heads up to the US GM to see if we can get some compatible drivers for older versions of Labview.
Avid Rabid Hobbyist
 
The following users thanked this post: MikeLogix

Offline Siglent America

  • Regular Contributor
  • *
  • Posts: 221
  • Country: us
Re: 2014 LabView Drivers for Siglent SDS2304X
« Reply #4 on: October 24, 2017, 04:49:19 pm »
Yes. Many of the LabVIEW drivers posted on NI.com were built using Labview 2015-16. I will check with Engineering to see if we can get them saved for 2014 and posted.

Can you write me at jason.chonko@siglent.com and I will respond directly to your email?

Thanks,
Jason (Siglent America)
 
The following users thanked this post: tautech, MikeLogix

Offline MikeLogix

  • Contributor
  • Posts: 46
  • Country: us
Re: 2014 LabView Drivers for Siglent SDS2304X
« Reply #5 on: October 28, 2017, 10:46:47 pm »
Now that is customer service. Thanks Jason for sending me the drivers. They seemed to have worked :) See Photo.
One question though. Normally I load drivers by using the tools panel > Find Drivers which loads drivers from the NI site. This time, I deleted the loaded Siglent Drivers (the 2015 Version) from the Instr.lib folder and copied the folder you sent me in the same folder. Only thing now is the functions for the scope do not show up in my Function pallet. So I must have missed a step somewhere? Any thoughts on what I need to do?

Thanks

 

Offline MikeLogix

  • Contributor
  • Posts: 46
  • Country: us
Re: 2014 LabView Drivers for Siglent SDS2304X
« Reply #6 on: October 29, 2017, 02:15:46 am »
Here is what I don't get. The instrument drivers do not show in the function palette, but they do show in the instrument driver finder. See screenshots.

Im a newbie to labview so still learning the software  :o

 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf