Author Topic: 53230A counter CH1 input trace fails!?  (Read 1203 times)

0 Members and 1 Guest are viewing this topic.

Offline awallin

  • Frequent Contributor
  • **
  • Posts: 666
53230A counter CH1 input trace fails!?
« on: November 19, 2014, 06:27:28 pm »
We just had the second failure of this kind:
53230A counter CH1 input just stops working all of a sudden. Inspection of the board reveals a thin trace just after the input-BNC that is broken. The fix is to add a wire from the input-BNC to the next smd-pad which happens to be unpopulated.

Anyone seen this before on the 53230A or its sister models? We have one more 100ps version and maybe a third 20ps - I'm now almost expecting them to fail in the same way since two units have already shown this  :P

Chemical corrosion? Mechanical stress from the BNC? Other ideas?

Anders
 
The following users thanked this post: SoundTech-LG

Offline SeanB

  • Super Contributor
  • ***
  • Posts: 15390
  • Country: za
Re: 53230A counter CH1 input trace fails!?
« Reply #1 on: November 19, 2014, 06:35:36 pm »
Probably the inner pin flexing as connectors are mated and disconnected. The stress is transmitted to the board. Nice fix with the wire, though I would have used a thin strip of foil to provide a more compliant connection with low inductance.
 

Offline free_electron

  • Super Contributor
  • ***
  • Posts: 7404
  • Country: us
    • SiliconValleyGarage
Re: 53230A counter CH1 input trace fails!?
« Reply #2 on: November 19, 2014, 08:37:56 pm »
how much power are you blasting in that thing ? that's a fusable trace ..
Professional Electron Wrangler.
Any comments, or points of view expressed, are my own and not endorsed , induced or compensated by my employer(s).
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf